stoken-gui-0.92-16.6.x86_64.rpm


Advertisement

Description

stoken-gui - Graphical interface program for stoken

Property Value
Distribution openSUSE Tumbleweed
Repository Security all
Package filename stoken-gui-0.92-16.6.x86_64.rpm
Package name stoken-gui
Package version 0.92
Package release 16.6
Package architecture x86_64
Package type rpm
Category Productivity/Security
Homepage http://stoken.sf.net
License LGPL-2.0-or-later AND BSD-3-Clause
Maintainer -
Download size 26.27 KB
Installed size 69.07 KB
Software Token for Linux/UNIX. It's a token code generator compatible with RSA
SecurID 128-bit (AES) tokens. It is a hobbyist project, not affiliated with or
endorsed by RSA Security.
This package contains the graphical interface program for stoken.

Alternatives

Package Version Architecture Repository
stoken-gui-0.92-16.6.i586.rpm 0.92 i586 Security
stoken-gui-0.92-1.3.x86_64.rpm 0.92 x86_64 openSUSE Oss
stoken-gui-0.92-1.3.i586.rpm 0.92 i586 openSUSE Oss
stoken-gui - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
libcairo.so.2()(64bit) -
libgdk-3.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgtk-3.so.0()(64bit) -
libpthread.so.0()(64bit) -
libstoken.so.1()(64bit) -
libstoken.so.1(STOKEN_1.3)(64bit) -
libstoken.so.1(STOKEN_PRIVATE)(64bit) -
libstoken1 = 0.92-16.6

Provides

Name Value
application() -
application(stoken-gui-small.desktop) -
application(stoken-gui.desktop) -
stoken-gui = 0.92-16.6
stoken-gui(x86-64) = 0.92-16.6

Download

Type URL
Mirror widehat.opensuse.org
Binary Package stoken-gui-0.92-16.6.x86_64.rpm
Source Package stoken-0.92-16.6.src.rpm

Install Howto

  1. Add the Security repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/security/openSUSE_Tumbleweed/ security
  2. Install stoken-gui rpm package:
    # zypper install stoken-gui

Files

Path
/usr/bin/stoken-gui
/usr/share/applications/stoken-gui-small.desktop
/usr/share/applications/stoken-gui.desktop
/usr/share/man/man1/stoken-gui.1.gz
/usr/share/pixmaps/stoken-gui.png
/usr/share/stoken/password-dialog.ui
/usr/share/stoken/pin-dialog.ui
/usr/share/stoken/tokencode-detail.ui
/usr/share/stoken/tokencode-small.ui

Changelog

2018-08-08 - tchvatal@suse.com
- Version update to 0.92:
* Fix build with new libtomcrypt
* support nette 3.x series
* See CHANGES for details
2015-03-26 - p.drouand@gmail.com
- Update to version 0.81
* Fix "make check" failures in GMT+xx timezones (xx >= 1)
- Changes from version 0.8
* Update GUI from GTK+2 to GTK+3; use glade to define the layouts
* Add next tokencode and other information to the full GUI (stoken-gui).
The "stoken-gui --small" layout is unchanged.
* Add a list of known GUIDs used to bind tokens to specific device classes
(i.e. tokens can be bound to "any BlackBerry 10").  stoken will now try
each one of these IDs when importing a new bound token.
* Add new --qr and --show-qr export options to make it easy to pass tokens
to a mobile device
* Add "stoken --next" option to show the next tokencode
* Support using nettle+gmp as an alternative to libtomcrypt
* Generate valid TKNTrailer BatchSignature sections in .sdtid output files,
allowing use with RSA's official TokenConverter utility
* Fix parsing of RSA-supplied hard token seed files
* Add "make check" and several test cases
* Fix build errors on Mac OSX, enable OSX Travis builds, and submit a
Homebrew formula
* Fix build errors when using uClibc instead of glibc
* Add experimental Windows build using MinGW (see README for instructions)
* Relicense the JNI wrapper (BSD-3-clause) so that it is easier to incorporate
into non-free Android apps
* Various fixes for minor bugs, memory leaks, etc.
- Replace pkgconfig(gtk+-2.0) require with pkgconfig(gtk+-3.0);
follow upstream changes
- Fix license to LGPL-2.0+ and BSD-3-Clause; upstream has relicensed
the JNI wrapper
- Add pkgconfig(nettle) require; new upstream dependency
- Add CHANGES and TODO to copied documentation list
2014-07-15 - darin@darins.net
- define BuildRoot
- add Group for all packages
- add --disable-static to %configure
2014-07-03 - darin@darins.net
- fix libtomcrypt dep due to rename
2014-07-03 - darin@darins.net
- set deps to libtomcrypt0 which is the correct package name
2014-06-26 - darin@darins.net
- fix requires
2014-06-26 - darin@darins.net
- Initial inclusion in openSUSE
* Ported .spec from Fedora
2014-06-23 - negativo17@gmail.com
- Update to 0.6.
2014-06-08 - rel-eng@lists.fedoraproject.org
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
2014-03-17 - negativo17@gmail.com
- Update to 0.5.
- Removed upstreamed patch.

See Also

Package Description
swing-layout-1.0.3-2.245.noarch.rpm Natural layout for Swing panels
swing-layout-javadoc-1.0.3-2.245.noarch.rpm Javadoc documentation for Swing-Layout
tarsnap-1.0.39-1.15.i686.rpm Backup tool for tarsnap.com
tarsnap-1.0.39-1.15.x86_64.rpm Backup tool for tarsnap.com
tboot-20170711_1.9.8-107.6.i586.rpm Program for performing a verified launch using Intel TXT
tboot-20170711_1.9.8-107.6.x86_64.rpm Program for performing a verified launch using Intel TXT
tcpflow-1.5.0-19.10.i586.rpm Program for capturing and collecting TCP streams
tcpflow-1.5.0-19.10.x86_64.rpm Program for capturing and collecting TCP streams
tinyca2-0.7.5-127.2.noarch.rpm A Graphical Tool for Managing a Certification Authority
tomb-2.5-1.3.noarch.rpm A minimalistic commandline tool to manage encrypted volumes
tomoyo-tools-2.5.0.20140601-185.48.i586.rpm Userspace tools for TOMOYO Linux 2.4.x
tomoyo-tools-2.5.0.20140601-185.48.x86_64.rpm Userspace tools for TOMOYO Linux 2.4.x
tpm-quote-tools-1.0.4-6.13.i586.rpm Trusted Platform Module (TPM) remote attestation tools
tpm-quote-tools-1.0.4-6.13.x86_64.rpm Trusted Platform Module (TPM) remote attestation tools
tpm-tools-1.3.9.1-48.14.i586.rpm Trusted Platform Module (TPM) administration tools
Advertisement
Advertisement