softhsm-devel-2.5.0-20.8.i586.rpm


Advertisement

Description

softhsm-devel - Development package of softhsm that includes the header files

Property Value
Distribution openSUSE Tumbleweed
Repository Security all
Package filename softhsm-devel-2.5.0-20.8.i586.rpm
Package name softhsm-devel
Package version 2.5.0
Package release 20.8
Package architecture i586
Package type rpm
Category Development/Libraries/C and C++
Homepage http://www.opendnssec.org/
License BSD-2-Clause
Maintainer -
Download size 21.25 KB
Installed size 64.66 KB
The devel package contains the libsofthsm include files

Alternatives

Package Version Architecture Repository
softhsm-devel-2.5.0-20.8.x86_64.rpm 2.5.0 x86_64 Security
softhsm-devel-2.5.0-1.2.x86_64.rpm 2.5.0 x86_64 openSUSE Oss
softhsm-devel-2.5.0-1.2.i586.rpm 2.5.0 i586 openSUSE Oss
softhsm-devel - - -

Requires

Name Value
openssl-devel -
softhsm = 2.5.0-20.8
sqlite3-devel -

Provides

Name Value
softhsm-devel = 2.5.0-20.8
softhsm-devel(x86-32) = 2.5.0-20.8

Download

Type URL
Mirror widehat.opensuse.org
Binary Package softhsm-devel-2.5.0-20.8.i586.rpm
Source Package softhsm-2.5.0-20.8.src.rpm

Install Howto

  1. Add the Security repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/security/openSUSE_Tumbleweed/ security
  2. Install softhsm-devel rpm package:
    # zypper install softhsm-devel

Files

Path
/usr/include/softhsm/P11Attributes.h
/usr/include/softhsm/P11Objects.h
/usr/include/softhsm/SoftHSM.h
/usr/include/softhsm/access.h

Changelog

2018-09-24 - Michael Ströder <michael@stroeder.com>
- Update to version 2.5.0
Updates:
* Issue #323: Support for EDDSA with vendor defined mechanisms.
* Issue #362: CMake Build System Support for SoftHSM.
* Issue #368: Support migrating 32-bit SoftHSMv1 DB on 64-bit system (LP64).
* Issue #385: Default is not to build EDDSA since it has not been released in OpenSSL.
* Issue #387: Windows: Add VS2017 detection to Configure.py.
* Issue #412: Replace PKCS11 headers with a version from p11-kit.
Bugfixes:
* Issue #366: Support cross-compilation.
* Issue #377: Duplicate symbol error with custom p11test.
* Issue #386: Use RDRAND in OpenSSL if that engine is available.
* Issue #388: Update DBTests.cpp to fix x86 test failure.
* Issue #393: Not setting CKA_PUBLIC_KEY_INFO correctly.
* Issue #401: Wrong key and keyserver mentioned in installation documentation.
* Issue #408: Remove mutex callbacks after C_Finalize().
2018-02-27 - mardnh@gmx.de
- Update to version 2.4.0
* Support PKCS#8 for GOST.
* Support for CKA_ALLOWED_MECHANISMS.
* Support CKA_ALWAYS_AUTHENTICATE for private key objects.
* Support for CKM_DES3_CMAC and CKM_AES_CMAC.
* Support for CKM_AES_GCM.
* Document that initialized tokens will be reassigned to another
slot (based on the token serial number).
* Support for CKM_RSA_PKCS_PSS.
* Import AES keys with softhsm2-util.
* softhsm2-util will check the configuration and report any
issues before loading the PKCS#11 library.

See Also

Package Description
spectre-meltdown-checker-0.40-18.1.i586.rpm Spectre & Meltdown Vulnerability Checker
spectre-meltdown-checker-0.40-18.1.x86_64.rpm Spectre & Meltdown Vulnerability Checker
srm-1.2.15-29.36.i586.rpm A secure replacement for rm
srm-1.2.15-29.36.x86_64.rpm A secure replacement for rm
ssdeep-2.14.1-21.13.i586.rpm Context Triggered Piecewise Hashing values
ssdeep-2.14.1-21.13.x86_64.rpm Context Triggered Piecewise Hashing values
sshguard-2.3.1-38.7.i586.rpm SSH brute force attack protector
sshguard-2.3.1-38.7.x86_64.rpm SSH brute force attack protector
sshuttle-0.78.4-11.1.noarch.rpm VPN over an SSH tunnel
ssldump-0.9b3-498.21.i586.rpm SSLv3/TLS Network Protocol Analyzer
ssldump-0.9b3-498.21.x86_64.rpm SSLv3/TLS Network Protocol Analyzer
sslh-1.20-1.8.i586.rpm SSL/SSH multiplexer
sslh-1.20-1.8.x86_64.rpm SSL/SSH multiplexer
sslscan-1.11.10-17.11.i586.rpm SSL cipher scanning tool
sslscan-1.11.10-17.11.x86_64.rpm SSL cipher scanning tool
Advertisement
Advertisement