softhsm-2.5.0-20.8.i586.rpm


Advertisement

Description

softhsm - Software version of a PKCS#11 Hardware Security Module

Property Value
Distribution openSUSE Tumbleweed
Repository Security all
Package filename softhsm-2.5.0-20.8.i586.rpm
Package name softhsm
Package version 2.5.0
Package release 20.8
Package architecture i586
Package type rpm
Category Productivity/Security
Homepage http://www.opendnssec.org/
License BSD-2-Clause
Maintainer -
Download size 353.04 KB
Installed size 1.36 MB
OpenDNSSEC is providing a software implementation of a generic
cryptographic device with a PKCS#11 interface, the SoftHSM. SoftHSM is
designed to meet the requirements of OpenDNSSEC, but can also work together
with other cryptographic products because of the PKCS#11 interface.

Alternatives

Package Version Architecture Repository
softhsm-2.5.0-20.8.x86_64.rpm 2.5.0 x86_64 Security
softhsm-2.5.0-1.2.x86_64.rpm 2.5.0 x86_64 openSUSE Oss
softhsm-2.5.0-1.2.i586.rpm 2.5.0 i586 openSUSE Oss
softhsm - - -

Requires

Name Value
libc.so.6(GLIBC_2.28) -
libcrypto.so.1.1 -
libcrypto.so.1.1(OPENSSL_1_1_0) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libnspr4.so -
libnss3.so -
libnssutil3.so -
libplc4.so -
libplds4.so -
libpthread.so.0 -
libsmime3.so -
libsoftokn3.so -
libsoftokn3.so(NSS_3.4) -
libsqlite3.so.0 -
libssl3.so -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.9) -
libz.so.1 -
mozilla-nss-tools -
p11-kit -
shadow -

Provides

Name Value
config(softhsm) = 2.5.0-20.8
libsofthsm2.so -
softhsm = 2.5.0-20.8
softhsm(x86-32) = 2.5.0-20.8

Download

Type URL
Mirror widehat.opensuse.org
Binary Package softhsm-2.5.0-20.8.i586.rpm
Source Package softhsm-2.5.0-20.8.src.rpm

Install Howto

  1. Add the Security repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/security/openSUSE_Tumbleweed/ security
  2. Install softhsm rpm package:
    # zypper install softhsm

Files

Path
/etc/softhsm2.conf
/usr/bin/softhsm2-dump-file
/usr/bin/softhsm2-keyconv
/usr/bin/softhsm2-migrate
/usr/bin/softhsm2-pk11install
/usr/bin/softhsm2-util
/usr/lib/pkcs11/libsofthsm2.so
/usr/lib/softhsm/libsofthsm.so
/usr/share/doc/packages/softhsm/LICENSE
/usr/share/doc/packages/softhsm/NEWS
/usr/share/doc/packages/softhsm/README.md
/usr/share/man/man1/softhsm2-dump-file.1.gz
/usr/share/man/man1/softhsm2-keyconv.1.gz
/usr/share/man/man1/softhsm2-migrate.1.gz
/usr/share/man/man1/softhsm2-util.1.gz
/usr/share/man/man5/softhsm2.conf.5.gz
/usr/share/p11-kit/
/usr/share/p11-kit/modules/softhsm.module
/usr/share/p11-kit/modules/softhsm2.module
/var/lib/softhsm/
/var/lib/softhsm/tokens/

Changelog

2018-09-24 - Michael Ströder <michael@stroeder.com>
- Update to version 2.5.0
Updates:
* Issue #323: Support for EDDSA with vendor defined mechanisms.
* Issue #362: CMake Build System Support for SoftHSM.
* Issue #368: Support migrating 32-bit SoftHSMv1 DB on 64-bit system (LP64).
* Issue #385: Default is not to build EDDSA since it has not been released in OpenSSL.
* Issue #387: Windows: Add VS2017 detection to Configure.py.
* Issue #412: Replace PKCS11 headers with a version from p11-kit.
Bugfixes:
* Issue #366: Support cross-compilation.
* Issue #377: Duplicate symbol error with custom p11test.
* Issue #386: Use RDRAND in OpenSSL if that engine is available.
* Issue #388: Update DBTests.cpp to fix x86 test failure.
* Issue #393: Not setting CKA_PUBLIC_KEY_INFO correctly.
* Issue #401: Wrong key and keyserver mentioned in installation documentation.
* Issue #408: Remove mutex callbacks after C_Finalize().
2018-02-27 - mardnh@gmx.de
- Update to version 2.4.0
* Support PKCS#8 for GOST.
* Support for CKA_ALLOWED_MECHANISMS.
* Support CKA_ALWAYS_AUTHENTICATE for private key objects.
* Support for CKM_DES3_CMAC and CKM_AES_CMAC.
* Support for CKM_AES_GCM.
* Document that initialized tokens will be reassigned to another
slot (based on the token serial number).
* Support for CKM_RSA_PKCS_PSS.
* Import AES keys with softhsm2-util.
* softhsm2-util will check the configuration and report any
issues before loading the PKCS#11 library.

See Also

Package Description
softhsm-devel-2.5.0-20.8.i586.rpm Development package of softhsm that includes the header files
softhsm-devel-2.5.0-20.8.x86_64.rpm Development package of softhsm that includes the header files
spectre-meltdown-checker-0.40-18.1.i586.rpm Spectre & Meltdown Vulnerability Checker
spectre-meltdown-checker-0.40-18.1.x86_64.rpm Spectre & Meltdown Vulnerability Checker
srm-1.2.15-29.36.i586.rpm A secure replacement for rm
srm-1.2.15-29.36.x86_64.rpm A secure replacement for rm
ssdeep-2.14.1-21.13.i586.rpm Context Triggered Piecewise Hashing values
ssdeep-2.14.1-21.13.x86_64.rpm Context Triggered Piecewise Hashing values
sshguard-2.3.1-38.7.i586.rpm SSH brute force attack protector
sshguard-2.3.1-38.7.x86_64.rpm SSH brute force attack protector
sshuttle-0.78.4-11.1.noarch.rpm VPN over an SSH tunnel
ssldump-0.9b3-498.21.i586.rpm SSLv3/TLS Network Protocol Analyzer
ssldump-0.9b3-498.21.x86_64.rpm SSLv3/TLS Network Protocol Analyzer
sslh-1.20-1.8.i586.rpm SSL/SSH multiplexer
sslh-1.20-1.8.x86_64.rpm SSL/SSH multiplexer
Advertisement
Advertisement