python-systemd-231-6.1.i586.rpm


Advertisement

Description

python-systemd - Python wrappers for systemd functionality

Property Value
Distribution openSUSE Tumbleweed
Repository Security all
Package name python-systemd
Package version 231
Package release 6.1
Package architecture i586
Package type rpm
Installed size 189.44 KB
Download size 56.40 KB
Official Mirror widehat.opensuse.org
Python module for native access to the systemd facilities. Functionality is seperated into a number of modules:
* systemd.journal supports sending of structured messages to the journal and reading journal files,
* systemd.daemon wraps parts of libsystemd useful for writing daemons and socket activation,
* systemd.id128 provides functions for querying machine and boot identifiers and a lists of message identifiers provided by systemd,
* systemd.login wraps parts of libsystemd used to query logged in users and available seats and machines.

Alternatives

Package Version Architecture Repository
python-systemd-231-6.1.x86_64.rpm 231 x86_64 Security
python-systemd - - -

Requires

Name Value
libc.so.6(GLIBC_2.17) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpython2.7.so.1.0 -
libsystemd.so.0 -
libsystemd.so.0(LIBSYSTEMD_209) -
libsystemd.so.0(LIBSYSTEMD_214) -
libsystemd.so.0(LIBSYSTEMD_219) -
python(abi) = 2.7

Provides

Name Value
python-systemd = 231-6.1
python-systemd(x86-32) = 231-6.1

Download

Type URL
Binary Package python-systemd-231-6.1.i586.rpm
Source Package python-systemd-231-6.1.src.rpm

Install Howto

  1. Add the Security repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/security/openSUSE_Tumbleweed/ security
  2. Install python-systemd rpm package:
    # zypper install python-systemd

Files

Path
/usr/lib/python2.7/site-packages/python_systemd-231-py2.7.egg-info
/usr/lib/python2.7/site-packages/systemd/__init__.py
/usr/lib/python2.7/site-packages/systemd/__init__.pyc
/usr/lib/python2.7/site-packages/systemd/_daemon.so
/usr/lib/python2.7/site-packages/systemd/_journal.so
/usr/lib/python2.7/site-packages/systemd/_reader.so
/usr/lib/python2.7/site-packages/systemd/daemon.py
/usr/lib/python2.7/site-packages/systemd/daemon.pyc
/usr/lib/python2.7/site-packages/systemd/id128.so
/usr/lib/python2.7/site-packages/systemd/journal.py
/usr/lib/python2.7/site-packages/systemd/journal.pyc
/usr/lib/python2.7/site-packages/systemd/login.so
/usr/lib/python2.7/site-packages/systemd/test/test_daemon.py
/usr/lib/python2.7/site-packages/systemd/test/test_daemon.pyc
/usr/lib/python2.7/site-packages/systemd/test/test_journal.py
/usr/lib/python2.7/site-packages/systemd/test/test_journal.pyc
/usr/share/doc/packages/python-systemd/LICENSE.txt
/usr/share/doc/packages/python-systemd/README.md

Changelog

2015-10-31 - jweberhofer@weberhofer.at
- Upgrade to release 231
* Various build fixes and cleanups: documentation can be generated with 'make
sphinx-html', pip install works out of the box.
* Tests that cover most of the python code were added. As a result, a bug in
sd_is_mq was fixed in systemd 227.
* Functions sd_pid_notify and sd_pid_notify_with_fds are now wrapped as
optional arguments to notify(), when compiled against a new-enough
libsystemd.
- Run tests
- Removed obsolete python-systemd-libraries-for-opensuse-1310.patch patch
- New build dependencies had been added
2015-10-22 - jweberhofer@weberhofer.at
- python-systemd-libraries-for-opensuse-1310.patch allows compilation
on openSUSE 13.1
2015-10-19 - jweberhofer@weberhofer.at
- Initial release 230
- This package is needed to resolve
bnc#917818 - fail2ban can not use systemd-journal to ban ips

See Also

Package Description
python2-bencode-1.2.0-3.11.noarch.rpm The BitTorrent bencode module as light-weight, standalone package
python2-capng-0.7.9-41.9.i586.rpm Python bindings for libcap-ng library
python2-capng-0.7.9-41.9.x86_64.rpm Python bindings for libcap-ng library
python2-pykeepass-3.0.2-3.1.noarch.rpm Low-level library to interact with keepass databases
python2-pyscard-1.9.7-11.7.i586.rpm Python module adding smart card support
python2-pyscard-1.9.7-11.7.x86_64.rpm Python module adding smart card support
python3-bencode-1.2.0-3.11.noarch.rpm The BitTorrent bencode module as light-weight, standalone package
python3-capng-0.7.9-41.9.i586.rpm Python bindings for libcap-ng library
python3-capng-0.7.9-41.9.x86_64.rpm Python bindings for libcap-ng library
python3-pykeepass-3.0.2-3.1.noarch.rpm Low-level library to interact with keepass databases
python3-pyscard-1.9.7-11.7.i586.rpm Python module adding smart card support
python3-pyscard-1.9.7-11.7.x86_64.rpm Python module adding smart card support
qtpass-1.2.3-3.21.i586.rpm A multi-platform gui for pass
qtpass-1.2.3-3.21.x86_64.rpm A multi-platform gui for pass
ratproxy-1.58-1.55.i586.rpm A passive web application security assessment tool
Advertisement
Advertisement