perl-macros-1.0-22.4.i586.rpm


Advertisement

Description

perl-macros - Perl macros for rpm build

Property Value
Distribution openSUSE Tumbleweed
Repository Security all
Package filename perl-macros-1.0-22.4.i586.rpm
Package name perl-macros
Package version 1.0
Package release 22.4
Package architecture i586
Package type rpm
Category Development/Libraries/Perl
Homepage -
License GPL-2.0+
Maintainer -
Download size 10.74 KB
Installed size 5.28 KB
This package provides perl rpm macros.
You need it for building perl modules
Authors:
Christian Wittmer <chris@computersalat.de>

Alternatives

Package Version Architecture Repository
perl-macros-1.0-22.4.x86_64.rpm 1.0 x86_64 Security
perl-macros - - -

Requires

Name Value
perl -

Provides

Name Value
perl-macros = 1.0-22.4
perl-macros(x86-32) = 1.0-22.4
perl_gen_filelist -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package perl-macros-1.0-22.4.i586.rpm
Source Package perl-macros-1.0-22.4.src.rpm

Install Howto

  1. Add the Security repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/security/openSUSE_Tumbleweed/ security
  2. Install perl-macros rpm package:
    # zypper install perl-macros

Files

Path
/etc/rpm/macros.suse-perl
/usr/share/doc/packages/perl-macros/README

Changelog

2017-10-11 - adrian.glaubitz@suse.com
- Use correct license name in License field (GPL-2.0+)
2017-10-08 - jayvdb@gmail.com
- Require ExtUtils::MakeMaker on Scientific Linux
2011-08-16 - chris@computersalat.de
- added rhel patch for fixing perl_gen_filelist
* on 64bit systems
vendorlib -> /usr/lib/perl5/vendor_perl/5.8.8
vendorarch -> /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi
2010-11-30 - coolo@novell.com
- require perl-devel on fedora too
2010-11-30 - coolo@novell.com
- add a not so nice hack to make sure we overwrite perl's macros
on older suse distributions
- sync perl macros with perl
2010-11-29 - coolo@novell.com
- some more fixes for fedora builds
2010-11-29 - coolo@novell.com
- sync macros from perl package
2010-11-29 - kukuk@suse.de
- Install as macros.perl.suse on non openSUSE distributions
2010-11-29 - kukuk@suse.de
- Add %perl_make_install
2010-02-12 - chris@computersalat.de
- fix for mandir
o only add if exist :)

See Also

Package Description
phrasendrescher-1.2.2c-3.7.i586.rpm A modular and multi processing Pass Phrase cracking Tool
phrasendrescher-1.2.2c-3.7.x86_64.rpm A modular and multi processing Pass Phrase cracking Tool
prey-0.6.4-1.22.noarch.rpm Tracking device for your laptop
python-pydeep-0.2-2.32.i586.rpm Python bindings for ssdeep
python-pydeep-0.2-2.32.x86_64.rpm Python bindings for ssdeep
python-scan-build-2.0.6-1.19.noarch.rpm static code analyzer wrapper for Clang
python-systemd-231-6.1.i586.rpm Python wrappers for systemd functionality
python-systemd-231-6.1.x86_64.rpm Python wrappers for systemd functionality
python2-bencode-1.2.0-4.3.noarch.rpm The BitTorrent bencode module as light-weight, standalone package
python2-capng-0.7.9-41.12.i586.rpm Python bindings for libcap-ng library
python2-capng-0.7.9-41.12.x86_64.rpm Python bindings for libcap-ng library
python2-pykeepass-3.0.3-7.2.noarch.rpm Low-level library to interact with keepass databases
python2-pyscard-1.9.8-16.2.i586.rpm Python module adding smart card support
python2-pyscard-1.9.8-16.2.x86_64.rpm Python module adding smart card support
python3-bencode-1.2.0-4.3.noarch.rpm The BitTorrent bencode module as light-weight, standalone package
Advertisement
Advertisement