libcdk5-5.0.20190224-179.1.x86_64.rpm


Advertisement

Description

libcdk5 - The Runtime for the Curses Development Kit - Shared library

Property Value
Distribution openSUSE Tumbleweed
Repository Security all
Package filename libcdk5-5.0.20190224-179.1.x86_64.rpm
Package name libcdk5
Package version 5.0.20190224
Package release 179.1
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage http://invisible-island.net/cdk/
License BSD-3-Clause
Maintainer -
Download size 152.33 KB
Installed size 684.25 KB
CDK is a widget set developed on top of the basic curses library. It
contains 21 ready to use widgets, some of which are: a text entry
field, a scrolling list, a selection list, an alphalist, a pull-down
menu, a radio list, a viewer widget, and a dialog box.

Alternatives

Package Version Architecture Repository
libcdk5-5.0.20190224-179.1.i586.rpm 5.0.20190224 i586 Security
libcdk5-5.0.20190224-1.1.i586.rpm 5.0.20190224 i586 openSUSE Oss
libcdk5-5.0.20190224-1.1.x86_64.rpm 5.0.20190224 x86_64 openSUSE Oss
libcdk5 - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
libncurses.so.6()(64bit) -
libncurses.so.6(NCURSEST6_5.7.20081102)(64bit) -
libncursesw.so.6()(64bit) -
libncursesw.so.6(NCURSESTW6_5.7.20081102)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libtinfo.so.6()(64bit) -
libtinfo.so.6(NCURSES6_TINFO_5.0.19991023)(64bit) -
libtinfo.so.6(NCURSES6_TINFO_5.7.20081102)(64bit) -

Provides

Name Value
libcdk.so.6.2.4()(64bit) -
libcdk.so.6.2.4(CDK_2.0.0)(64bit) -
libcdk.so.6.2.4(CDK_2.3.1)(64bit) -
libcdk.so.6.2.4(CDK_2.4.1)(64bit) -
libcdk.so.6.2.4(CDK_3.1.2)(64bit) -
libcdk.so.6.2.4(CDK_4.0.3)(64bit) -
libcdk.so.6.2.4(CDK_5.0.4)(64bit) -
libcdk.so.6.2.4(CDK_6.1.4)(64bit) -
libcdk.so.6.2.4(CDK_6.2.4)(64bit) -
libcdk5 = 5.0.20190224-179.1
libcdk5(x86-64) = 5.0.20190224-179.1
libcdkw.so.6.2.4()(64bit) -
libcdkw.so.6.2.4(CDK_2.0.0)(64bit) -
libcdkw.so.6.2.4(CDK_2.3.1)(64bit) -
libcdkw.so.6.2.4(CDK_2.4.1)(64bit) -
libcdkw.so.6.2.4(CDK_3.1.2)(64bit) -
libcdkw.so.6.2.4(CDK_4.0.3)(64bit) -
libcdkw.so.6.2.4(CDK_5.0.4)(64bit) -
libcdkw.so.6.2.4(CDK_6.1.4)(64bit) -
libcdkw.so.6.2.4(CDK_6.2.4)(64bit) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libcdk5-5.0.20190224-179.1.x86_64.rpm
Source Package cdk-5.0.20190224-179.1.src.rpm

Install Howto

  1. Add the Security repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/security/openSUSE_Tumbleweed/ security
  2. Install libcdk5 rpm package:
    # zypper install libcdk5

Files

Path
/usr/lib64/libcdk.so.5.0
/usr/lib64/libcdk.so.6.2.4
/usr/lib64/libcdkw.so.5.0
/usr/lib64/libcdkw.so.6.2.4
/usr/share/doc/packages/libcdk5/CHANGES
/usr/share/doc/packages/libcdk5/EXPANDING
/usr/share/doc/packages/libcdk5/NOTES
/usr/share/doc/packages/libcdk5/README
/usr/share/doc/packages/libcdk5/TODO
/usr/share/doc/packages/libcdk5/VERSION
/usr/share/licenses/libcdk5/COPYING

Changelog

2019-02-27 - Dr. Werner Fink <werner@suse.de>
- Remove debugging code from spec file
2019-02-26 - Dr. Werner Fink <werner@suse.de>
- Update to version 5.0.20190224
+ use HDR_ROOTNAME rather than PACKAGE in top-level makefile, to
simplify building cdk and cdkw packages with non-conflicting paths.
+ add "check" rule to top-level makefile, for testing Arch Linux
package.
+ modify test-package for RPMs to work with SUSE and Mageia.
- Enable wide version of libcdk(w)
- Enable ABI soname of the shared libraries
+ Somehow strange ABI 6.2.4 but RELEASE version is still 5.0

See Also

Package Description
libclamav9-0.101.2-200.1.i586.rpm ClamAV antivirus engine runtime
libclamav9-0.101.2-200.1.x86_64.rpm ClamAV antivirus engine runtime
libduo3-1.9.18-1.21.i586.rpm Shared libraries for duo authentication
libduo3-1.9.18-1.21.x86_64.rpm Shared libraries for duo authentication
libfido2-1_0_0-1.0.0-15.1.i586.rpm FIDO U2F and FIDO 2.0 protocols
libfido2-1_0_0-1.0.0-15.1.x86_64.rpm FIDO U2F and FIDO 2.0 protocols
libfido2-devel-1.0.0-15.1.i586.rpm Development files for FIDO U2F and FIDO 2.0 protocols
libfido2-devel-1.0.0-15.1.x86_64.rpm Development files for FIDO U2F and FIDO 2.0 protocols
libfido2-utils-1.0.0-15.1.i586.rpm Utility programs making use of libfido2, a library for FIDO U2F and FIDO 2.0
libfido2-utils-1.0.0-15.1.x86_64.rpm Utility programs making use of libfido2, a library for FIDO U2F and FIDO 2.0
libfipscheck1-1.5.0-37.23.i586.rpm Library files for fipscheck
libfipscheck1-1.5.0-37.23.x86_64.rpm Library files for fipscheck
libfipscheck1-32bit-1.5.0-37.23.x86_64.rpm Library files for fipscheck
libfuzzy-devel-2.14.1-21.13.i586.rpm API for ssdeep
libfuzzy-devel-2.14.1-21.13.x86_64.rpm API for ssdeep
Advertisement
Advertisement