cppcodec-0.1-1.2.noarch.rpm


Advertisement

Description

cppcodec - Header-only C++11 library to encode/decode various encoding formats

Property Value
Distribution openSUSE Tumbleweed
Repository Security all
Package filename cppcodec-0.1-1.2.noarch.rpm
Package name cppcodec
Package version 0.1
Package release 1.2
Package architecture noarch
Package type rpm
Category Development/Libraries/C and C++
Homepage https://github.com/tplgy/cppcodec
License MIT
Maintainer -
Download size 21.55 KB
Installed size 83.78 KB
Header-only C++11 library to encode/decode base64, base64url, base32, base32hex
and hex (a.k.a. base16) as specified in RFC 4648, plus Crockford's base32.
MIT licensed with consistent, flexible API. Supports raw pointers, std::string
and (templated) character vectors without unnecessary allocations.

Alternatives

Package Version Architecture Repository
cppcodec - - -

Requires

Name Value
/usr/bin/pkg-config -

Provides

Name Value
cppcodec = 0.1-1.2
cppcodec-devel = 0.1-1.2
pkgconfig(cppcodec-1) = 0.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package cppcodec-0.1-1.2.noarch.rpm
Source Package cppcodec-0.1-1.2.src.rpm

Install Howto

  1. Add the Security repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/security/openSUSE_Tumbleweed/ security
  2. Install cppcodec rpm package:
    # zypper install cppcodec

Files

Path
/usr/include/cppcodec/base32_crockford.hpp
/usr/include/cppcodec/base32_default_crockford.hpp
/usr/include/cppcodec/base32_default_hex.hpp
/usr/include/cppcodec/base32_default_rfc4648.hpp
/usr/include/cppcodec/base32_hex.hpp
/usr/include/cppcodec/base32_rfc4648.hpp
/usr/include/cppcodec/base64_default_rfc4648.hpp
/usr/include/cppcodec/base64_default_url.hpp
/usr/include/cppcodec/base64_default_url_unpadded.hpp
/usr/include/cppcodec/base64_rfc4648.hpp
/usr/include/cppcodec/base64_url.hpp
/usr/include/cppcodec/base64_url_unpadded.hpp
/usr/include/cppcodec/hex_default_lower.hpp
/usr/include/cppcodec/hex_default_upper.hpp
/usr/include/cppcodec/hex_lower.hpp
/usr/include/cppcodec/hex_upper.hpp
/usr/include/cppcodec/parse_error.hpp
/usr/include/cppcodec/data/access.hpp
/usr/include/cppcodec/data/raw_result_buffer.hpp
/usr/include/cppcodec/detail/base32.hpp
/usr/include/cppcodec/detail/base64.hpp
/usr/include/cppcodec/detail/codec.hpp
/usr/include/cppcodec/detail/config.hpp
/usr/include/cppcodec/detail/hex.hpp
/usr/include/cppcodec/detail/stream_codec.hpp
/usr/share/pkgconfig/cppcodec-1.pc

Changelog

2018-04-10 - mrueckert@suse.de
- initial package 0.1

See Also

Package Description
cryptctl-2.3-21.22.x86_64.rpm A utility for setting up LUKS-based disk encryption
ctunnel-0.7-1.216.i586.rpm Crypto Tunnel for Proxying and Forwarding TCP Connections
ctunnel-0.7-1.216.x86_64.rpm Crypto Tunnel for Proxying and Forwarding TCP Connections
daes-0.41-3.19.i586.rpm AES Command Line Encryption Tool
daes-0.41-3.19.x86_64.rpm AES Command Line Encryption Tool
duo_unix-1.9.18-1.21.i586.rpm Duo two-factor authentication for Unix systems
duo_unix-1.9.18-1.21.x86_64.rpm Duo two-factor authentication for Unix systems
duo_unix-devel-1.9.18-1.21.i586.rpm Development files and documentation for duo_unix
duo_unix-devel-1.9.18-1.21.x86_64.rpm Development files and documentation for duo_unix
eid-mw-4.0.6+1620-2.66.i586.rpm Belgium electronic identity card PKCS#11 module and Firefox plugin
eid-mw-4.0.6+1620-2.66.x86_64.rpm Belgium electronic identity card PKCS#11 module and Firefox plugin
eid-mw-devel-4.0.6+1620-2.66.i586.rpm Belgium electronic identity card PKCS#11 module - development package
eid-mw-devel-4.0.6+1620-2.66.x86_64.rpm Belgium electronic identity card PKCS#11 module - development package
eid-mw-firefox-4.0.6+1620-2.66.i586.rpm Firefox Extension for Belgium eID Middleware
eid-mw-firefox-4.0.6+1620-2.66.x86_64.rpm Firefox Extension for Belgium eID Middleware
Advertisement
Advertisement