compartm-1.1-895.20.x86_64.rpm


Advertisement

Description

compartm - A Wrapper to Securely Run Insecure or Untrusted Programs

Property Value
Distribution openSUSE Tumbleweed
Repository Security all
Package filename compartm-1.1-895.20.x86_64.rpm
Package name compartm
Package version 1.1
Package release 895.20
Package architecture x86_64
Package type rpm
Category Productivity/Security
Homepage -
License GPL-2.0+
Maintainer -
Download size 27.77 KB
Installed size 56.82 KB
Compartment provides all possibilities (chroot, kernel capabilities)
for securely running insecure or untrusted programs. It provides all
necessary options to fine-tune the security tightening process as
needed.
Authors:
--------
Marc Heuse <marc@suse.de>

Alternatives

Package Version Architecture Repository
compartm-1.1-895.20.i586.rpm 1.1 i586 Security
compartm-1.1-457.15.x86_64.rpm 1.1 x86_64 openSUSE Oss
compartm-1.1-457.15.i586.rpm 1.1 i586 openSUSE Oss
compartm - - -

Requires

Name Value
libc.so.6(GLIBC_2.7)(64bit) -

Provides

Name Value
compartm = 1.1-895.20
compartm(x86-64) = 1.1-895.20

Download

Type URL
Mirror widehat.opensuse.org
Binary Package compartm-1.1-895.20.x86_64.rpm
Source Package compartm-1.1-895.20.src.rpm

Install Howto

  1. Add the Security repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/security/openSUSE_Tumbleweed/ security
  2. Install compartm rpm package:
    # zypper install compartm

Files

Path
/usr/sbin/compartment
/usr/share/doc/packages/compartm/CHANGES
/usr/share/doc/packages/compartm/LICENCE
/usr/share/doc/packages/compartm/README
/usr/share/doc/packages/compartm/TODO
/usr/share/man/man1/compartment.1.gz

Changelog

2014-10-08 - jengelh@inai.de
- Remove unused specfile tags and sections
2008-09-03 - draht@suse.de
- arg from va_start(arg, format) can only be used once. Use
va_copy().
2008-09-03 - draht@suse.de
- remove the precompiled binary from the tarball.
- extern char **environ should be NULL terminated, "" is not NULL.
Cause for weird crashes in malloc(), getpwuid() and others.
2008-04-29 - mt@suse.de
- Updated cap no/name array to reflect current capabilities
- Fixed to use correct printf format for a size_t type
- Recreated compartment-1.1.diff patch file
- Removed obsolete ia64.diff
2007-02-11 - ro@suse.de
- fix build as non-root
2006-01-25 - mls@suse.de
- converted neededforbuild to BuildRequires
2005-04-09 - coolo@suse.de
- fix C
2003-07-23 - coolo@suse.de
- use BuildRoot
2003-01-10 - aj@suse.de
- Fix multi-line strings.
2002-09-17 - ro@suse.de
- removed bogus self-provides

See Also

Package Description
corkscrew-2.0-2.18.i586.rpm Tunnel SSH through HTTP Proxies
corkscrew-2.0-2.18.x86_64.rpm Tunnel SSH through HTTP Proxies
cppcodec-0.1-1.2.noarch.rpm Header-only C++11 library to encode/decode various encoding formats
cryptctl-2.3-21.22.x86_64.rpm A utility for setting up LUKS-based disk encryption
ctunnel-0.7-1.216.i586.rpm Crypto Tunnel for Proxying and Forwarding TCP Connections
ctunnel-0.7-1.216.x86_64.rpm Crypto Tunnel for Proxying and Forwarding TCP Connections
daes-0.41-3.19.i586.rpm AES Command Line Encryption Tool
daes-0.41-3.19.x86_64.rpm AES Command Line Encryption Tool
duo_unix-1.9.18-1.21.i586.rpm Duo two-factor authentication for Unix systems
duo_unix-1.9.18-1.21.x86_64.rpm Duo two-factor authentication for Unix systems
duo_unix-devel-1.9.18-1.21.i586.rpm Development files and documentation for duo_unix
duo_unix-devel-1.9.18-1.21.x86_64.rpm Development files and documentation for duo_unix
eid-mw-4.0.6+1620-2.66.i586.rpm Belgium electronic identity card PKCS#11 module and Firefox plugin
eid-mw-4.0.6+1620-2.66.x86_64.rpm Belgium electronic identity card PKCS#11 module and Firefox plugin
eid-mw-devel-4.0.6+1620-2.66.i586.rpm Belgium electronic identity card PKCS#11 module - development package
Advertisement
Advertisement