python3-pivy-0.6.4-12.4.x86_64.rpm


Advertisement

Description

python3-pivy - Coin Binding for Python

Property Value
Distribution openSUSE Tumbleweed
Repository Science all
Package name python3-pivy
Package version 0.6.4
Package release 12.4
Package architecture x86_64
Package type rpm
Installed size 18.80 MB
Download size 1.98 MB
Official Mirror widehat.opensuse.org
Pivy is a Coin binding for Python. Coin is a high-level 3D graphics library
with a C++ Application Programming Interface. Coin uses scene-graph data
structures to render real-time graphics suitable for mostly all kinds of
scientific and engineering visualization applications.
Pivy allows:
- Development of Coin applications and extensions in Python
- Interactive modification of Coin programs from within the Python interpreter
at runtime
- Incorporation of Scripting Nodes into the scene graph which are capable of
executing Python code and callbacks

Alternatives

Package Version Architecture Repository
python3-pivy-0.6.4-12.4.i586.rpm 0.6.4 i586 Science
python3-pivy-0.6.2-3.1.x86_64.rpm 0.6.2 x86_64 openSUSE Oss
python3-pivy-0.6.2-3.1.i586.rpm 0.6.2 i586 openSUSE Oss
python3-pivy - - -

Requires

Name Value
libCoin.so.60()(64bit) -
libSoQt.so.20()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libpython3.6m.so.1.0()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.8)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
python(abi) = 3.6

Provides

Name Value
python3-pivy = 0.6.4-12.4
python3-pivy(x86-64) = 0.6.4-12.4

Download

Type URL
Binary Package python3-pivy-0.6.4-12.4.x86_64.rpm
Source Package python-pivy-0.6.4-12.4.src.rpm

Install Howto

  1. Add the Science repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/science/openSUSE_Tumbleweed/ science
  2. Install python3-pivy rpm package:
    # zypper install python3-pivy

Files

Path
/usr/lib/python3.6/site-packages/Pivy-0.6.4-py3.6.egg-info
/usr/lib/python3.6/site-packages/pivy/__init__.py
/usr/lib/python3.6/site-packages/pivy/_coin.cpython-36m-x86_64-linux-gnu.so
/usr/lib/python3.6/site-packages/pivy/coin.py
/usr/lib/python3.6/site-packages/pivy/pivy_meta.py
/usr/lib/python3.6/site-packages/pivy/sogui.py
/usr/lib/python3.6/site-packages/pivy/utils.py
/usr/lib/python3.6/site-packages/pivy/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/__pycache__/coin.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/__pycache__/coin.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/__pycache__/pivy_meta.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/__pycache__/pivy_meta.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/__pycache__/sogui.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/__pycache__/sogui.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/__pycache__/utils.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/__pycache__/utils.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/graphics/__init__.py
/usr/lib/python3.6/site-packages/pivy/graphics/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/graphics/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/gui/__init__.py
/usr/lib/python3.6/site-packages/pivy/gui/_soqt.cpython-36m-x86_64-linux-gnu.so
/usr/lib/python3.6/site-packages/pivy/gui/qt.py
/usr/lib/python3.6/site-packages/pivy/gui/soqt.py
/usr/lib/python3.6/site-packages/pivy/gui/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/gui/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/gui/__pycache__/qt.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/gui/__pycache__/qt.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/gui/__pycache__/soqt.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/gui/__pycache__/soqt.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/ContextMenu.py
/usr/lib/python3.6/site-packages/pivy/quarter/ImageReader.py
/usr/lib/python3.6/site-packages/pivy/quarter/QuarterWidget.py
/usr/lib/python3.6/site-packages/pivy/quarter/SensorManager.py
/usr/lib/python3.6/site-packages/pivy/quarter/SignalThread.py
/usr/lib/python3.6/site-packages/pivy/quarter/__init__.py
/usr/lib/python3.6/site-packages/pivy/quarter/__pycache__/ContextMenu.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/__pycache__/ContextMenu.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/__pycache__/ImageReader.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/__pycache__/ImageReader.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/__pycache__/QuarterWidget.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/__pycache__/QuarterWidget.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/__pycache__/SensorManager.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/__pycache__/SensorManager.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/__pycache__/SignalThread.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/__pycache__/SignalThread.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/devices/DeviceHandler.py
/usr/lib/python3.6/site-packages/pivy/quarter/devices/DeviceManager.py
/usr/lib/python3.6/site-packages/pivy/quarter/devices/KeyboardHandler.py
/usr/lib/python3.6/site-packages/pivy/quarter/devices/MouseHandler.py
/usr/lib/python3.6/site-packages/pivy/quarter/devices/__init__.py
/usr/lib/python3.6/site-packages/pivy/quarter/devices/__pycache__/DeviceHandler.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/devices/__pycache__/DeviceHandler.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/devices/__pycache__/DeviceManager.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/devices/__pycache__/DeviceManager.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/devices/__pycache__/KeyboardHandler.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/devices/__pycache__/KeyboardHandler.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/devices/__pycache__/MouseHandler.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/devices/__pycache__/MouseHandler.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/devices/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/devices/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/eventhandlers/DragDropHandler.py
/usr/lib/python3.6/site-packages/pivy/quarter/eventhandlers/EventHandler.py
/usr/lib/python3.6/site-packages/pivy/quarter/eventhandlers/EventManager.py
/usr/lib/python3.6/site-packages/pivy/quarter/eventhandlers/__init__.py
/usr/lib/python3.6/site-packages/pivy/quarter/eventhandlers/__pycache__/DragDropHandler.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/eventhandlers/__pycache__/DragDropHandler.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/eventhandlers/__pycache__/EventHandler.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/eventhandlers/__pycache__/EventHandler.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/eventhandlers/__pycache__/EventManager.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/eventhandlers/__pycache__/EventManager.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/eventhandlers/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/eventhandlers/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/plugins/
/usr/lib/python3.6/site-packages/pivy/quarter/plugins/designer/
/usr/lib/python3.6/site-packages/pivy/quarter/plugins/designer/python/PyQuarterWidgetPlugin.py
/usr/lib/python3.6/site-packages/pivy/quarter/plugins/designer/python/__pycache__/PyQuarterWidgetPlugin.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pivy/quarter/plugins/designer/python/__pycache__/PyQuarterWidgetPlugin.cpython-36.pyc
/usr/share/doc/packages/python3-pivy/AUTHORS
/usr/share/doc/packages/python3-pivy/HACKING
/usr/share/doc/packages/python3-pivy/NEWS
/usr/share/doc/packages/python3-pivy/README.md
/usr/share/doc/packages/python3-pivy/THANKS
/usr/share/licenses/python3-pivy/LICENSE

Changelog

2018-10-09 - Stefan BrĂ¼ns <stefan.bruens@rwth-aachen.de>
- Update to 0.6.3
* qt5-support (qt4 not supported anymore)
- Update to 0.6.4
* bool(coin.SoGroup) -> True (also if group is empty) [same behaviour as py2]
* add graphics arrow object
* making it possible to compile with older coin version (without cmake) -> setup_old.py
* adding back qt4 compatibility (but tests are still qt5 depenent)
* added pivy.version
* some fixes
- %python_expand call to fdupes
2018-01-03 - dev@stellardeath.org
- Fix build failure when using more than one python version:
swig wrapper files were only generated the first time and
and then kept for subsequent builds.
2017-12-16 - badshah400@gmail.com
- Convert specfile to python-singlespec: fixes build failures in
Factory. Doesn't build against python2 for unknown reasons, so
turn off python2 modules until this is fixed.
- Use fdupes (added to BuildRequires) to link duplicate files.
2017-09-14 - kkaempf@suse.com
- update to 0.6.2
* builds for python3 (linux: 3.4, 3.5, 3.6; win: 3.5, 3.6)
or python2 (2.7)
* uses pyside instead of pyqt for soqt4 bindings
* has many fixes (especially for FreeCAD)
- switch to github.com/FreeCAD/pivy, coin3d.org is dead
2012-05-05 - asterios.dramis@gmail.com
- Initial release (version 0.5.0hg.609).

See Also

Package Description
python3-plplot-5.13.0-146.3.i586.rpm PLplot functions for scientific plotting with Python
python3-plplot-5.13.0-146.3.x86_64.rpm PLplot functions for scientific plotting with Python
python3-power-1.4-8.10.noarch.rpm System power status information in Python
python3-pyproj-1.9.5.1-2.73.i586.rpm Python interface to PROJ4 library
python3-pyproj-1.9.5.1-2.73.x86_64.rpm Python interface to PROJ4 library
python3-splinter-3.0-10.9.i586.rpm Python3 bindings for splinter
python3-splinter-3.0-10.9.x86_64.rpm Python3 bindings for splinter
python3-ufl-2016.2.0-1.13.noarch.rpm A domain specific language for declaration of finite element discretizations
python3-utils-2.3.0-1.1.noarch.rpm numpy-stl Supporting Utilities
python3-vtk-8.1.2-130.4.i586.rpm Python bindings for VTK
python3-vtk-8.1.2-130.4.x86_64.rpm Python bindings for VTK
python3-vtk-openmpi-8.1.2-130.4.i586.rpm Python bindings for VTK
python3-vtk-openmpi-8.1.2-130.4.x86_64.rpm Python bindings for VTK
python3-vtk-openmpi2-8.1.2-130.4.i586.rpm Python bindings for VTK
python3-vtk-openmpi2-8.1.2-130.4.x86_64.rpm Python bindings for VTK
Advertisement
Advertisement