python3-dolfin_utils-openmpi-2016.2.0-2.50.x86_64.rpm


Advertisement

Description

python3-dolfin_utils-openmpi - A package for solving large sparse systems of linear equations

Property Value
Distribution openSUSE Tumbleweed
Repository Science all
Package name python3-dolfin_utils-openmpi
Package version 2016.2.0
Package release 2.50
Package architecture x86_64
Package type rpm
Installed size 398.66 KB
Download size 126.10 KB
Official Mirror widehat.opensuse.org
dolphin is an open source CFD software (FLOW solvER, literally)
written in C++. It is mainly devoted to the resolution of the
turbulent unsteady incompressible Navier-Stokes equations.

Alternatives

Package Version Architecture Repository
python3-dolfin_utils-openmpi-2016.2.0-2.50.i586.rpm 2016.2.0 i586 Science
python3-dolfin_utils-openmpi - - -

Provides

Name Value
python3-dolfin_utils = 2016.2.0
python3-dolfin_utils-openmpi = 2016.2.0-2.50
python3-dolfin_utils-openmpi(x86-64) = 2016.2.0-2.50

Obsoletes

Name Value
python3-dolfin_utils < 2016.2.0

Download

Type URL
Binary Package python3-dolfin_utils-openmpi-2016.2.0-2.50.x86_64.rpm
Source Package dolfin-2016.2.0-2.50.src.rpm

Install Howto

  1. Add the Science repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/science/openSUSE_Tumbleweed/ science
  2. Install python3-dolfin_utils-openmpi rpm package:
    # zypper install python3-dolfin_utils-openmpi

Files

Path
/usr/lib64/mpi/gcc/openmpi/lib/
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/__init__.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/commands.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/ordereddict.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/__pycache__/__init__.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/__pycache__/commands.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/__pycache__/ordereddict.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/cppparser/CppHeaderParser.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/cppparser/__init__.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/cppparser/utils.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/cppparser/__pycache__/CppHeaderParser.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/cppparser/__pycache__/__init__.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/cppparser/__pycache__/utils.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/documentation/__init__.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/documentation/docstringutils.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/documentation/extractdocumentation.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/documentation/generatecpprst.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/documentation/generatepythonrst.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/documentation/indextemplates.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/documentation/__pycache__/__init__.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/documentation/__pycache__/docstringutils.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/documentation/__pycache__/extractdocumentation.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/documentation/__pycache__/generatecpprst.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/documentation/__pycache__/generatepythonrst.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/documentation/__pycache__/indextemplates.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/meshconvert/__init__.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/meshconvert/abaqus.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/meshconvert/meshconvert.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/meshconvert/xml_writer.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/meshconvert/__pycache__/__init__.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/meshconvert/__pycache__/abaqus.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/meshconvert/__pycache__/meshconvert.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/meshconvert/__pycache__/xml_writer.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/pjobs/__init__.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/pjobs/pjobs.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/pjobs/sge.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/pjobs/slurm.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/pjobs/torque.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/pjobs/__pycache__/__init__.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/pjobs/__pycache__/pjobs.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/pjobs/__pycache__/sge.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/pjobs/__pycache__/slurm.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/pjobs/__pycache__/torque.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/test/__init__.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/test/fixtures.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/test/paths.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/test/skips.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/test/tests.py
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/test/__pycache__/__init__.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/test/__pycache__/fixtures.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/test/__pycache__/paths.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/test/__pycache__/skips.cpython-36.pyc
/usr/lib64/mpi/gcc/openmpi/lib/python3.6/site-packages/dolfin_utils/test/__pycache__/tests.cpython-36.pyc

Changelog

2017-04-14 - kkhere.geo@gmail.com
- build using vtk-compat_gl-devel because not all systems have brand
new graphics supporting OpenGL version 3.2
- more fixes for running scripts with python3
- require cmake >= 3.5 as reported by the CMakeLists.txt

See Also

Package Description
python3-gdal-2.4.0-93.2.i586.rpm GDAL Python3 module
python3-gdal-2.4.0-93.2.x86_64.rpm GDAL Python3 module
python3-getfem-5.3-1.26.i586.rpm A generic C++ finite element library
python3-getfem-5.3-1.26.x86_64.rpm A generic C++ finite element library
python3-instant-2016.2.0-2.11.noarch.rpm A Python module that allows for instant inlining
python3-libadjoint-openmpi-2016.2.0-2.10.i586.rpm A library for adjointing computational models (python bindings w/ openmpi)
python3-libadjoint-openmpi-2016.2.0-2.10.x86_64.rpm A library for adjointing computational models (python bindings w/ openmpi)
python3-mshr-openmpi-2016.2.0-1.10.i586.rpm Python bindings for mshr to generate meshes for FEniCS
python3-mshr-openmpi-2016.2.0-1.10.x86_64.rpm Python bindings for mshr to generate meshes for FEniCS
python3-numpy-stl-2.9.0-1.1.noarch.rpm Simple library to work with STL files
python3-owslib-0.16.0-2.5.noarch.rpm Python interface to OGC Web Services
python3-pcl-0.3.1_20180828-3.5.x86_64.rpm Library for point cloud processing
python3-petsc4py-3.7.0-3.6.i586.rpm Python bindings for PETSc
python3-petsc4py-3.7.0-3.6.x86_64.rpm Python bindings for PETSc
python3-petsc4py-openmpi-3.7.0-3.6.i586.rpm Python bindings for PETSc - openmpi enabled
Advertisement
Advertisement