psurface-devel-2.0.0-3.9.i586.rpm


Advertisement

Description

psurface-devel - Development and header files for psurface

Property Value
Distribution openSUSE Tumbleweed
Repository Science x86_64 + i586
Package filename psurface-devel-2.0.0-3.9.i586.rpm
Package name psurface-devel
Package version 2.0.0
Package release 3.9
Package architecture i586
Package type rpm
Category Development/Libraries/C and C++
Homepage http://numerik.mi.fu-berlin.de/dune/psurface/index.php
License GPL-2.0
Maintainer -
Download size 52.43 KB
Installed size 210.40 KB
This package contains the development and header files for psurface.

Alternatives

Package Version Architecture Repository
psurface-devel-2.0.0-3.9.x86_64.rpm 2.0.0 x86_64 Science
psurface-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libpsurface0 = 2.0.0

Provides

Name Value
pkgconfig(psurface) = 2.0.0
psurface-devel = 2.0.0-3.9
psurface-devel(x86-32) = 2.0.0-3.9

Download

Type URL
Mirror widehat.opensuse.org
Binary Package psurface-devel-2.0.0-3.9.i586.rpm
Source Package psurface-2.0.0-3.9.src.rpm

Install Howto

  1. Add the Science repository:
    # zypper addrepo http://widehat.opensuse.org/repositories/science/openSUSE_Tumbleweed/ science
  2. Install psurface-devel rpm package:
    # zypper install psurface-devel

Files

Path
/usr/include/psurface/AmiraMeshIO.h
/usr/include/psurface/Box.h
/usr/include/psurface/CircularPatch.h
/usr/include/psurface/ContactMapping.h
/usr/include/psurface/DirectionFunction.h
/usr/include/psurface/DomainPolygon.h
/usr/include/psurface/Domains.h
/usr/include/psurface/EdgeIntersectionFunctor.h
/usr/include/psurface/GlobalNodeIdx.h
/usr/include/psurface/GmshIO.h
/usr/include/psurface/Hdf5IO.h
/usr/include/psurface/HxParamToolBox.h
/usr/include/psurface/IntersectionPrimitive.h
/usr/include/psurface/IntersectionPrimitiveCollector.h
/usr/include/psurface/MultiDimOctree.h
/usr/include/psurface/Node.h
/usr/include/psurface/NodeBundle.h
/usr/include/psurface/NormalProjector.h
/usr/include/psurface/PSurface.h
/usr/include/psurface/PSurfaceFactory.h
/usr/include/psurface/PSurfaceSmoother.h
/usr/include/psurface/PathVertex.h
/usr/include/psurface/PlaneParam.h
/usr/include/psurface/PointIntersectionFunctor.h
/usr/include/psurface/QualityRequest.h
/usr/include/psurface/SparseMatrix.h
/usr/include/psurface/StaticMatrix.h
/usr/include/psurface/StaticVector.h
/usr/include/psurface/SurfaceBase.h
/usr/include/psurface/SurfaceParts.h
/usr/include/psurface/TargetSurface.h
/usr/include/psurface/Triangulator.h
/usr/include/psurface/VertexHeap.h
/usr/include/psurface/VtkIO.h
/usr/include/psurface/b64enc.hh
/usr/include/psurface/common.hh
/usr/include/psurface/dataarraywriter.hh
/usr/include/psurface/indent.hh
/usr/include/psurface/psurfaceAPI.h
/usr/include/psurface/streams.hh
/usr/include/psurface/vtuwriter.hh
/usr/lib/libpsurface.so
/usr/lib/pkgconfig/psurface.pc

Changelog

2015-11-03 - dmitry_r@opensuse.org
- Fix pkgconfig
- Build with HDF5 support
2015-10-31 - foss@grueninger.de
- Update to Psurface 2.0.0
No upstream changelog
- The tarball download location at Gitorious is down,
the original source tarball from Debian is taken.
- Drop no longer needed patches
libpsurfave-1.3.0-configure-am-prog-ar-fix.patch
libpsurfave-1.3.0-configure-fix.patch
libpsurfave-1.3.0-no-return-in-no-void-fix.patch
- Remove special cases for suse_version <= 1210
2015-10-31 - foss@grueninger.de
- Rename package to psurface because it contains unversioned
binaries
2012-08-08 - scorot@free.fr
- fix build with -fpermissive to CXXFLAGS on openSUSE greater
than 12.1
2012-08-08 - scorot@free.fr
- fix configure.ac for openSUSE greater than 12.1
2012-08-07 - scorot@free.fr
- add patch0 to fix build with old autoconf
- add patch1 to fix no-return-in-non-void error
2012-08-07 - scorot@free.fr
- first package

See Also

Package Description
ptscotch-gnu-mpich-hpc-6.0.9-31.1.noarch.rpm Dependency package for ptscotch_6_0_9-gnu-mpich-hpc
ptscotch-gnu-mpich-hpc-6.0.9-36.2.noarch.rpm Dependency package for ptscotch_6_0_9-gnu-mpich-hpc
ptscotch-gnu-mpich-hpc-devel-6.0.9-31.1.noarch.rpm Dependency package for ptscotch_6_0_9-gnu-mpich-hpc-devel
ptscotch-gnu-mpich-hpc-devel-6.0.9-36.2.noarch.rpm Dependency package for ptscotch_6_0_9-gnu-mpich-hpc-devel
ptscotch-gnu-mvapich2-hpc-6.0.9-31.1.noarch.rpm Dependency package for ptscotch_6_0_9-gnu-mvapich2-hpc
ptscotch-gnu-mvapich2-hpc-6.0.9-36.2.noarch.rpm Dependency package for ptscotch_6_0_9-gnu-mvapich2-hpc
ptscotch-gnu-mvapich2-hpc-devel-6.0.9-31.1.noarch.rpm Dependency package for ptscotch_6_0_9-gnu-mvapich2-hpc-devel
ptscotch-gnu-mvapich2-hpc-devel-6.0.9-36.2.noarch.rpm Dependency package for ptscotch_6_0_9-gnu-mvapich2-hpc-devel
ptscotch-gnu-openmpi1-hpc-6.0.9-31.1.noarch.rpm Dependency package for ptscotch_6_0_9-gnu-openmpi1-hpc
ptscotch-gnu-openmpi1-hpc-6.0.9-36.2.noarch.rpm Dependency package for ptscotch_6_0_9-gnu-openmpi1-hpc
ptscotch-gnu-openmpi1-hpc-devel-6.0.9-31.1.noarch.rpm Dependency package for ptscotch_6_0_9-gnu-openmpi1-hpc-devel
ptscotch-gnu-openmpi1-hpc-devel-6.0.9-36.2.noarch.rpm Dependency package for ptscotch_6_0_9-gnu-openmpi1-hpc-devel
ptscotch-gnu-openmpi2-hpc-6.0.9-31.1.noarch.rpm Dependency package for ptscotch_6_0_9-gnu-openmpi2-hpc
ptscotch-gnu-openmpi2-hpc-6.0.9-36.2.noarch.rpm Dependency package for ptscotch_6_0_9-gnu-openmpi2-hpc
ptscotch-gnu-openmpi2-hpc-devel-6.0.9-31.1.noarch.rpm Dependency package for ptscotch_6_0_9-gnu-openmpi2-hpc-devel
Advertisement
Advertisement