libparpack2-openmpi-3.5.0-25.25.x86_64.rpm


Advertisement

Description

libparpack2-openmpi - Files needed for developing arpack based applications

Property Value
Distribution openSUSE Tumbleweed
Repository Science all
Package name libparpack2-openmpi
Package version 3.5.0
Package release 25.25
Package architecture x86_64
Package type rpm
Installed size 295.45 KB
Download size 93.09 KB
Official Mirror widehat.opensuse.org
ARPACK is a collection of Fortran77 subroutines designed to solve
large scale eigenvalue problems. This package contains the so
library links used for building arpack based applications.

Alternatives

Package Version Architecture Repository
libparpack2-openmpi-3.5.0-25.25.i586.rpm 3.5.0 i586 Science
libparpack2-openmpi-3.5.0-1.5.x86_64.rpm 3.5.0 x86_64 openSUSE Oss
libparpack2-openmpi-3.5.0-1.5.i586.rpm 3.5.0 i586 openSUSE Oss
libparpack2-openmpi - - -

Requires

Name Value
/sbin/ldconfig -
libarpack.so.2()(64bit) -
libblas.so.3()(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libgfortran.so.5()(64bit) -
libgfortran.so.5(GFORTRAN_8)(64bit) -
liblapack.so.3()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libm.so.6(GLIBC_2.27)(64bit) -
libmpi_mpifh.so.12()(64bit) -

Provides

Name Value
libparpack.so.2()(64bit) -
libparpack2-openmpi = 3.5.0-25.25
libparpack2-openmpi(x86-64) = 3.5.0-25.25
libparpack2_3_0 = 3.5.0

Obsoletes

Name Value
libparpack2_3_0 < 3.5.0

Download

Type URL
Binary Package libparpack2-openmpi-3.5.0-25.25.x86_64.rpm
Source Package arpack-ng-3.5.0-25.25.src.rpm

Install Howto

  1. Add the Science repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/science/openSUSE_Tumbleweed/ science
  2. Install libparpack2-openmpi rpm package:
    # zypper install libparpack2-openmpi

Files

Path
/usr/lib64/mpi/gcc/openmpi/lib64/libparpack.so.2
/usr/lib64/mpi/gcc/openmpi/lib64/libparpack.so.2.0.0

Changelog

2017-07-09 - badshah400@gmail.com
- Update to version 3.5.0:
* Improve cmake build system: disable C++ detection, set
default build type.
* Use AC_PROG_FC instead of AC_PROG_F77 for proper
inizialization for the usage of AC_FC_LINE_LENGTH.
* Improve cmake build system: add make install and fix shared
libraries.
* fix usages of DLACPY to not alias inputs
(patch from
https://software.intel.com/en-us/articles/how-to-resolve-arpack-issues-with-intel-mkl-110-update-3)
* Fix possible deadlock when PARPACK call uses communicator
with a larger number of CPUs than previous call
* Portability improvements to the autotools build system.
* Let cmake guess the default installation directories.  Can be
overridden by changing CMAKE_INSTALL_LIBDIR and
CMAKE_INSTALL_BINDIR.
* Shared libraries built by cmake now have their SONAME set
identical to those built by autotools.
* Avoid purification stage in [d,s]neupd.f if it requires
division by zero (Closes: gh#opencollab/arpack-ng#58).
2016-07-08 - dmitry_r@opensuse.org
- Update to version 3.4.0
* Build system updates
2016-05-31 - ronisbr@gmail.com
- Update to version 3.3.0
* Rename pdlamch to pdlamch10 to avoid symbol collision with
Scalapack 2.0.2 in MPI context.
* General improvements on the build system.
* libparpack links against libarpack (instead of doing a static
link).
* Reverts using {d,s}lahqr from lapack 2.
* Use dlahqr from lapack 3 instead of dlaqrb.
- Run spec-cleaner.
- Minor improvements in the .spec file.
2014-12-13 - dmitry_r@opensuse.org
- Update to version 3.2.0
* See included CHANGES file for details
* Remove obsolete 0001-Do-not-install-test-binaries.patch
2014-01-08 - badshah400@gmail.com
- Add baselibs.conf file for multiarch binaries.
2013-12-10 - sweet_f_a@gmx.de
- Update to version 3.1.4
* libparpack2: missing dependency on MPI:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=718790
* Replace LAPACK second function with ARPACK's own arscnd in PARPACK
* Fix issue #1259 in DSEUPD and SSEUPD
The Ritz vector purification step assumes workl(iq) still contains the
original Q matrix. This is however overwritten by the call to xGEQR2
earlier.
* Use configure supplied blas and lapack in the pkg-config.
Thanks to Ward Poelmans (Closes: #1320)
* Switch to automake 1.14 + libtool 2.4.2.
Thanks to Ward Poelmans (Closes: #1321)
* dseupd routine may lead to a segmentation fault
Thanks to Edouard Canot (Closes: #1323)
* dsaupd and 'BE' option returns wrong eigenvalues for a SPD matrix
Thanks to Edouard Canot (Closes: #1329)
- enable test suite
- add 0001-Do-not-install-test-binaries.patch to remove useless
test binaries, this removes the whole default arpack-ng package
2013-09-06 - dmitry_r@opensuse.org
- Update to version 3.1.3
* Replace depcomp symlink with actual file.
* Replace arpack.pc with proper autotooled arpack.pc.in
* Add debug.h to TESTS/Makefile.am sources
* "make dist" is functionnal
* Also build the library "libparpacksrcblacs" (PARPACK/UTIL/BLACS/)
* Wrong call to pdlamch was causing segfaults
* Get rid of the mpif.h occurences in the source code
* Configure detected built-in LAPACK and BLAS, but refused to use them
* Fixed division by zero in smlnum by usind p[d,s]lamch instead of the
serial
2012-08-26 - scorot@free.fr
- fix source file Url
2012-08-26 - scorot@free.fr
- fix borken obsoletes/provides in devel package
2012-07-10 - scorot@free.fr
- version 3.1.1
* Many bug fixes in the parpack lib. It is an old patch from
upstream. Thanks to Viral Shah for pinging us on this subject.
See the PARPACK_CHANGES file for the details.
* Fixed a lack of appropriate bounds check in DNAUP2.
Thanks to Pauli Virtanen for the patch (Closes: #632)
* Update of the doc about TOL in dnaupd.
* Reorder bug fixed when eigenvectors are requested and the
resulting number of converged eigenvalues is less than the
number requested. Patches from Tim Mitchell. (Closes: #664)
- spec file cleanup

See Also

Package Description
libparpack2-openmpi-32bit-3.5.0-25.25.x86_64.rpm Files needed for developing arpack based applications
libparsifal-1_1_0-1.1.0-1.46.i586.rpm A validating XML 1.0 parser written in ANSI C
libparsifal-1_1_0-1.1.0-1.46.x86_64.rpm A validating XML 1.0 parser written in ANSI C
libparsifal-devel-1.1.0-1.46.i586.rpm Development files for libparsifal
libparsifal-devel-1.1.0-1.46.x86_64.rpm Development files for libparsifal
libpastix5-openmpi-5.2.3-2.22.i586.rpm Devel files for pastix
libpastix5-openmpi-5.2.3-2.22.x86_64.rpm Devel files for pastix
libpcl1.8-1.8.1_20180821-1.12.x86_64.rpm C++ library for pcl
libpcre2-16-0-10.32-36.1.i586.rpm A library for Perl-compatible regular expressions
libpcre2-16-0-10.32-36.1.x86_64.rpm A library for Perl-compatible regular expressions
libpcre2-16-0-32bit-10.32-36.1.x86_64.rpm A library for Perl-compatible regular expressions
libpcre2-32-0-10.32-36.1.i586.rpm A library for Perl-compatible regular expressions
libpcre2-32-0-10.32-36.1.x86_64.rpm A library for Perl-compatible regular expressions
libpcre2-32-0-32bit-10.32-36.1.x86_64.rpm A library for Perl-compatible regular expressions
libpcre2-8-0-10.32-36.1.i586.rpm A library for Perl-compatible regular expressions
Advertisement
Advertisement