libdolfin2016_2-openmpi-2016.2.0-2.50.i586.rpm


Advertisement

Description

libdolfin2016_2-openmpi - A package for solving large sparse systems of linear equations

Property Value
Distribution openSUSE Tumbleweed
Repository Science all
Package name libdolfin2016_2-openmpi
Package version 2016.2.0
Package release 2.50
Package architecture i586
Package type rpm
Installed size 7.14 MB
Download size 1.88 MB
Official Mirror widehat.opensuse.org
dolphin is an open source CFD software (FLOW solvER, literally)
written in C++. It is mainly devoted to the resolution of the
turbulent unsteady incompressible Navier-Stokes equations.

Alternatives

Package Version Architecture Repository
libdolfin2016_2-openmpi-2016.2.0-2.50.x86_64.rpm 2016.2.0 x86_64 Science
libdolfin2016_2-openmpi - - -

Requires

Name Value
/sbin/ldconfig -
libboost_filesystem.so.1.64.0 -
libboost_iostreams.so.1.64.0 -
libboost_program_options.so.1.64.0 -
libboost_system.so.1.64.0 -
libboost_timer.so.1.64.0 -
libc.so.6(GLIBC_2.4) -
libcholmod 3.0.11.so
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GCC_7.0.0) -
libgcc_s.so.1(GLIBC_2.0) -
libgomp.so.1 -
libgomp.so.1(GOMP_1.0) -
libgomp.so.1(GOMP_4.0) -
libgomp.so.1(OMP_1.0) -
libhdf5.so.100 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libmpi.so.12 -
libmpi_cxx.so.1 -
libpetsc.so.3.7 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libptscotch.so.0 -
libslepc.so.3.7 -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.8) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.18) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.22) -
libstdc++.so.6(GLIBCXX_3.4.9) -
libumfpack 5.7.6.so
libvtkCommonCore.so.1 -
libvtkCommonDataModel.so.1 -
libvtkCommonExecutionModel.so.1 -
libvtkFiltersCore.so.1 -
libvtkFiltersGeneral.so.1 -
libvtkFiltersGeometry.so.1 -
libvtkFiltersHybrid.so.1 -
libvtkFiltersSources.so.1 -
libvtkIOImage.so.1 -
libvtkInteractionStyle.so.1 -
libvtkInteractionWidgets.so.1 -
libvtkRenderingAnnotation.so.1 -
libvtkRenderingCore.so.1 -
libvtkRenderingFreeType.so.1 -
libvtkRenderingLabel.so.1 -
libvtkRenderingOpenGL.so.1 -
libz.so.1 -

Provides

Name Value
libdolfin.so.2016.2 -
libdolfin2016_2 = 2016.2.0
libdolfin2016_2-openmpi = 2016.2.0-2.50
libdolfin2016_2-openmpi(x86-32) = 2016.2.0-2.50

Obsoletes

Name Value
libdolfin2016_2 < 2016.2.0

Download

Type URL
Binary Package libdolfin2016_2-openmpi-2016.2.0-2.50.i586.rpm
Source Package dolfin-2016.2.0-2.50.src.rpm

Install Howto

  1. Add the Science repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/science/openSUSE_Tumbleweed/ science
  2. Install libdolfin2016_2-openmpi rpm package:
    # zypper install libdolfin2016_2-openmpi

Files

Path
/usr/lib/mpi/gcc/openmpi/lib/libdolfin.so.2016.2
/usr/lib/mpi/gcc/openmpi/lib/libdolfin.so.2016.2.0
/usr/share/doc/packages/libdolfin2016_2-openmpi/AUTHORS
/usr/share/doc/packages/libdolfin2016_2-openmpi/COPYING
/usr/share/doc/packages/libdolfin2016_2-openmpi/COPYING.LESSER
/usr/share/doc/packages/libdolfin2016_2-openmpi/ChangeLog.rst
/usr/share/doc/packages/libdolfin2016_2-openmpi/README.rst

Changelog

2017-04-14 - kkhere.geo@gmail.com
- build using vtk-compat_gl-devel because not all systems have brand
new graphics supporting OpenGL version 3.2
- more fixes for running scripts with python3
- require cmake >= 3.5 as reported by the CMakeLists.txt

See Also

Package Description
libdunecommon0-2.4.1-3.16.i586.rpm Distributed and Unified Numerics Environment
libdunecommon0-2.4.1-3.16.x86_64.rpm Distributed and Unified Numerics Environment
libdunecommon0-openmpi-2.4.1-3.16.i586.rpm Distributed and Unified Numerics Environment
libdunecommon0-openmpi-2.4.1-3.16.x86_64.rpm Distributed and Unified Numerics Environment
libdunegeometry0-2.4.1-2.17.i586.rpm Everything related to the DUNE reference elements
libdunegeometry0-2.4.1-2.17.x86_64.rpm Everything related to the DUNE reference elements
libdunegeometry0-openmpi-2.4.1-2.17.i586.rpm Everything related to the DUNE reference elements
libdunegeometry0-openmpi-2.4.1-2.17.x86_64.rpm Everything related to the DUNE reference elements
libdunegrid0-2.4.1-4.21.i586.rpm Grid management module for DUNE
libdunegrid0-2.4.1-4.21.x86_64.rpm Grid management module for DUNE
libdunegrid0-openmpi-2.4.1-4.21.i586.rpm Grid management module for DUNE
libdunegrid0-openmpi-2.4.1-4.21.x86_64.rpm Grid management module for DUNE
libdunepdelab0-2.4.1-2.22.i586.rpm A discretisation module based on DUNE
libdunepdelab0-2.4.1-2.22.x86_64.rpm A discretisation module based on DUNE
libdunepdelab0-openmpi-2.4.1-2.22.i586.rpm A discretisation module based on DUNE
Advertisement
Advertisement