elpa-devel-2016.05.004-15.19.i586.rpm


Advertisement

Description

elpa-devel - Development files for elpa

Property Value
Distribution openSUSE Tumbleweed
Repository Science all
Package name elpa-devel
Package version 2016.05.004
Package release 15.19
Package architecture i586
Package type rpm
Installed size 54.09 KB
Download size 45.03 KB
Official Mirror widehat.opensuse.org
The elpa-devel package contains libraries and header files for
developing applications that use elpa.

Alternatives

Package Version Architecture Repository
elpa-devel-2017.05.003-1.33.x86_64.rpm 2017.05.003 x86_64 Science
elpa-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
blas devel
elpa = 2016.05.004
lapack devel
libscalapack2-openmpi devel
openmpi -

Provides

Name Value
elpa-devel = 2016.05.004-15.19
elpa-devel(x86-32) = 2016.05.004-15.19
libtool(/usr/lib/libelpa.la) -
pkgconfig(elpa-2016.05.004) = 2016.05.004

Download

Type URL
Binary Package elpa-devel-2016.05.004-15.19.i586.rpm
Source Package elpa-2016.05.004-15.19.src.rpm

Install Howto

  1. Add the Science repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/science/openSUSE_Tumbleweed/ science
  2. Install elpa-devel rpm package:
    # zypper install elpa-devel

Files

Path
/usr/include/elpa-2016.05.004/
/usr/include/elpa-2016.05.004/elpa/elpa.h
/usr/include/elpa-2016.05.004/elpa/elpa_generated.h
/usr/include/elpa-2016.05.004/elpa/elpa_kernel_constants.h
/usr/include/elpa-2016.05.004/modules/elpa.mod
/usr/include/elpa-2016.05.004/modules/elpa1.mod
/usr/include/elpa-2016.05.004/modules/elpa1_auxiliary.mod
/usr/include/elpa-2016.05.004/modules/elpa2.mod
/usr/include/elpa-2016.05.004/modules/elpa2_utilities.mod
/usr/include/elpa-2016.05.004/modules/elpa_utilities.mod
/usr/lib/libelpa.la
/usr/lib/libelpa.so
/usr/lib/pkgconfig/elpa-2016.05.004.pc
/usr/share/man/man3/elpa_invert_trm_complex.3.gz
/usr/share/man/man3/elpa_invert_trm_real.3.gz
/usr/share/man/man3/elpa_mult_ah_b_complex.3.gz
/usr/share/man/man3/elpa_mult_at_b_real.3.gz
/usr/share/man/man3/elpa_solve_evp_complex.3.gz
/usr/share/man/man3/elpa_solve_evp_complex_1stage.3.gz
/usr/share/man/man3/elpa_solve_evp_real.3.gz
/usr/share/man/man3/elpa_solve_evp_real_1stage.3.gz
/usr/share/man/man3/get_elpa_communicators.3.gz
/usr/share/man/man3/get_elpa_row_col_comms.3.gz
/usr/share/man/man3/solve_evp_complex.3.gz
/usr/share/man/man3/solve_evp_complex_1stage.3.gz
/usr/share/man/man3/solve_evp_complex_2stage.3.gz
/usr/share/man/man3/solve_evp_real.3.gz
/usr/share/man/man3/solve_evp_real_1stage.3.gz
/usr/share/man/man3/solve_evp_real_2stage.3.gz

Changelog

2016-10-25 - dev@stellardeath.org
- Update to release 2016.05.004
- fix a problem with the private state of module precision
- distribute test_project with dist tarball
- generic driver routine for ELPA 1stage and 2stage
- test case for elpa_mult_at_b_real
- test case for elpa_mult_ah_b_complex
- test case for elpa_cholesky_real
- test case for elpa_cholesky_complex
- test case for elpa_invert_trm_real
- test case for elpa_invert_trm_complex
- fix building of static library
- better choice of AVX, AVX2, AVX512 kernels
- make assumed size Fortran arrays default
2016-07-11 - dev@stellardeath.org
- Update to release 2016.05.003
Changelog for release ELPA 2016.05.003
- fix a problem with the build of SSE kernels
- make some (internal) functions public, such that they
can be used outside of ELPA
- add documentation and interfaces for new public functions
- shorten file namses and directory names for test programs
in under to by pass "make agrument list too long" error
Changelog for release ELPA 2016.05.002
- fix problem with generated *.sh- check scripts
- name library differently if build without MPI support
- install only public modules
Changelog for release ELPA 2016.05.001
- support building without MPI for one node usage
- doxygen and man pages documentation for ELPA
- cleanup of documentation
- introduction of SSE gcc intrinsic kernels
- Remove errors due to unaligned memory
- removal of Fortran "contains functions"
- Fortran interfaces for assembly and C kernels
2016-07-11 - dev@stellardeath.org
- Use a _service file to check GPG signature
2015-11-16 - dev@stellardeath.org
- Update to release 2015.11.001
2015-05-29 - dev@stellardeath.org
- Update to release 2015.05.001
2015-03-18 - dev@stellardeath.org
- Updated to maintenance release 2015.02.002
This release was in part caused by problems observed from the OpenSUSE build
server results.
2015-03-03 - dev@stellardeath.org
- Update to released version 2015.02.001
Removed 'skip_openmp_for_missing_mpi_thread_support.patch',
was merged upstream
2014-10-22 - dev@stellardeath.org
- Incorporate changes by Dmitry Roshchin, enable OpenMP in my home project
This should allow to use the same spec file for OpenMP support within
my home project with an experimental openmpi 1.8 package, while disabling
OpenMP by default otherwise.
2014-10-11 - dmitry_r@opensuse.org
- Disable openmp support for openSUSE <= 13.2
2014-10-10 - dev@stellardeath.org
- Allow building of the OpenMP version regardless of the openmpi
library version. The user is responsible for selecting an
implementation that supports MPI_THREAD_MULTIPLE

See Also

Package Description
elpa-devel-static-2016.05.004-15.19.i586.rpm Development files for elpa - static libraries
elpa-devel-static-2017.05.003-1.33.x86_64.rpm Development files for elpa - static libraries
elpa-tools-2016.05.004-15.19.i586.rpm Utility program for elpa
elpa-tools-2017.05.003-1.33.x86_64.rpm Utility program for elpa
elpa_openmp-devel-2016.05.004-15.19.i586.rpm Development files for elpa_openmp
elpa_openmp-devel-2017.05.003-1.33.x86_64.rpm Development files for elpa_openmp
elpa_openmp-devel-static-2016.05.004-15.19.i586.rpm Development files for elpa - static libraries
elpa_openmp-devel-static-2017.05.003-1.33.x86_64.rpm Development files for elpa - static libraries
elpa_openmp-tools-2016.05.004-15.19.i586.rpm Utility program for elpa_openmp
elpa_openmp-tools-2017.05.003-1.33.x86_64.rpm Utility program for elpa_openmp
emboss-explorer-2.2.0-2.12.i586.rpm Web-based Graphical User Interface for EMBOSS
emboss-explorer-2.2.0-2.12.x86_64.rpm Web-based Graphical User Interface for EMBOSS
engauge-digitizer-10.11-58.12.i586.rpm Ditigize old graphs into numbers again
engauge-digitizer-10.11-58.12.x86_64.rpm Ditigize old graphs into numbers again
engauge-digitizer-devel-doc-10.11-58.12.noarch.rpm Development documentation for Engauge Digitizer
Advertisement
Advertisement