php5-pam-1.0.3-2.18.x86_64.rpm


Advertisement

Description

php5-pam - PHP PAM integration

Property Value
Distribution openSUSE Tumbleweed
Repository PHP Extensions all
Package filename php5-pam-1.0.3-2.18.x86_64.rpm
Package name php5-pam
Package version 1.0.3
Package release 2.18
Package architecture x86_64
Package type rpm
Homepage -
License -
Maintainer -
Download size 14.73 KB
Installed size 22.54 KB
This extension provides PAM (Pluggable Authentication Modules) integration.
PAM is a system of libraries that handle the authentication tasks of applications and services.
The library provides a stable API for applications to defer to for authentication tasks.

Alternatives

Package Version Architecture Repository
php5-pam-1.0.3-2.18.i586.rpm 1.0.3 i586 PHP Extensions
php5-pam - - -

Requires

Name Value
libc.so.6(GLIBC_2.4)(64bit) -
libpam.so.0()(64bit) -
libpam.so.0(LIBPAM_1.0)(64bit) -
php(api) = 20131106
php(zend-abi) = 20131226

Provides

Name Value
config(php5-pam) = 1.0.3-2.18
php-pam = 1.0.3
php5-pam = 1.0.3-2.18
php5-pam(x86-64) = 1.0.3-2.18

Obsoletes

Name Value
php-pam < 1.0.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package php5-pam-1.0.3-2.18.x86_64.rpm
Source Package php5-pam-1.0.3-2.18.src.rpm

Install Howto

  1. Add the PHP Extensions repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/server:/php:/extensions/openSUSE_Factory/ php-extensions
  2. Install php5-pam rpm package:
    # zypper install php5-pam

Files

Path
/etc/php5/conf.d/pam.ini
/usr/lib64/php5/extensions/pam.so
/usr/share/doc/packages/php5-pam/CREDITS
/usr/share/doc/packages/php5-pam/README

Changelog

2016-01-29 - pgajdos@suse.com
- provides php-pam symbol
2016-01-13 - pgajdos@suse.com
- update to 1.0.2
2009-08-17 - crrodriguez@novell.com
- use versionng macros
2008-10-28 - crrodriguez@suse.de
- fix buil
2007-11-29 - crrodriguez@suse.de
- version 1.0.2
- Added PAM_RHOST param to facilitate RHOST auth (using $_SERVER['REMOTE_ADDR'])
2007-09-22 - crrodriguez@suse.de
- Error messages now specify which pam_* function failed
- version 1.0.1
- fix build in 64 bit

See Also

Package Description
php5-pecl-cairo-0.3.2-2.26.i586.rpm Cairo Graphics Library Extension
php5-pecl-cairo-0.3.2-2.26.x86_64.rpm Cairo Graphics Library Extension
php5-pecl-cairo-devel-0.3.2-2.26.i586.rpm Development files for libtar
php5-pecl-cairo-devel-0.3.2-2.26.x86_64.rpm Development files for libtar
php5-pecl-solr-2.3.0-2.211.i586.rpm Apache Solr Client for PHP
php5-pecl-solr-2.3.0-2.211.x86_64.rpm Apache Solr Client for PHP
php5-pecl_http-2.5.6-1.35.i586.rpm Extended HTTP Support
php5-pecl_http-2.5.6-1.35.x86_64.rpm Extended HTTP Support
php5-pecl_http-devel-2.5.6-1.35.i586.rpm Include files of php5-pecl_http
php5-pecl_http-devel-2.5.6-1.35.x86_64.rpm Include files of php5-pecl_http
php5-phalcon-3.1.2-21.3.i586.rpm A PHP framework
php5-phalcon-3.1.2-21.3.x86_64.rpm A PHP framework
php5-phk-3.0.1-2.32.i586.rpm PHK Accelerator extension
php5-phk-3.0.1-2.32.x86_64.rpm PHK Accelerator extension
php5-propro-1.0.0-3.20.i586.rpm pecl_http's Property Proxy API
Advertisement
Advertisement