php5-oauth-1.2.3-4.22.i586.rpm


Advertisement

Description

php5-oauth - oauth Consumer Extension

Property Value
Distribution openSUSE Tumbleweed
Repository PHP Extensions all
Package filename php5-oauth-1.2.3-4.22.i586.rpm
Package name php5-oauth
Package version 1.2.3
Package release 4.22
Package architecture i586
Package type rpm
Homepage -
License -
Maintainer -
Download size 48.44 KB
Installed size 117.96 KB
OAuth is a specification for exchanging private user data between providers and 3rd parties, without using usernames or passwords. This extension provides a thread safe, simple, and updated interface to consumers (3rd parties) for working with OAuth.
Requirements: ext/hash and libcurl (with https support if you plan to access resources over https).

Alternatives

Package Version Architecture Repository
php5-oauth-1.2.3-4.22.x86_64.rpm 1.2.3 x86_64 PHP Extensions
php5-oauth - - -

Requires

Name Value
libc.so.6(GLIBC_2.4) -
libcurl.so.4 -
php(api) = 20131106
php(zend-abi) = 20131226
php5 openssl

Provides

Name Value
config(php5-oauth) = 1.2.3-4.22
php-oauth = 1.2.3
php5-oauth = 1.2.3-4.22
php5-oauth(x86-32) = 1.2.3-4.22

Obsoletes

Name Value
php-oauth < 1.2.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package php5-oauth-1.2.3-4.22.i586.rpm
Source Package php5-oauth-1.2.3-4.22.src.rpm

Install Howto

  1. Add the PHP Extensions repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/server:/php:/extensions/openSUSE_Factory/ php-extensions
  2. Install php5-oauth rpm package:
    # zypper install php5-oauth

Files

Path
/etc/php5/conf.d/oauth.ini
/usr/lib/php5/extensions/oauth.so

Changelog

2016-01-29 - pgajdos@suse.com
- provides php-oauth symbol
2016-01-20 - pgajdos@suse.com
- do not require hash extension, it is in php package itself
2016-01-13 - pgajdos@suse.com
- call spec-cleaner
2013-01-07 - crrodriguez@opensuse.org
- version 1.2.3
2011-10-15 - crrodriguez@opensuse.org
- Update to version 1.2.2
2011-03-13 - crrodriguez@opensuse.org
- Update to version 1.1.0
2009-05-10 - crrodriguez@suse.de
- update to version 0.99.9
- Added 1.0a support (based on implementer Draft 2, http://oauth.googlecode.com/svn/spec/core/1.0a/drafts/2/oauth-core-1_0a.html)
- Added support for empty parameters
- Added oauth_callback support to getRequestToken
- Added oauth_verifier support to getAccessToken
- Fixed build failures for PHP5.1
2008-12-03 - crrodriguez@suse.de
- update to version 0.99.2
- Fixed PECL bug #15110 #15111 (ZTS build, Segfault and memory leak, hannes/felipe) + other memleaks
- Fixed PECL bug #15112 (incorrect cvs branch)
- Updated fetch to respect additional request params, added examples and TODO
- Updates for 5.3
- Support for older libcurl versions
- Added arginfo
- Marking as beta
2008-11-21 - crrodriguez@suse.de
- initial revision

See Also

Package Description
php5-pam-1.0.3-2.18.i586.rpm PHP PAM integration
php5-pam-1.0.3-2.18.x86_64.rpm PHP PAM integration
php5-pecl-cairo-0.3.2-2.26.i586.rpm Cairo Graphics Library Extension
php5-pecl-cairo-0.3.2-2.26.x86_64.rpm Cairo Graphics Library Extension
php5-pecl-cairo-devel-0.3.2-2.26.i586.rpm Development files for libtar
php5-pecl-cairo-devel-0.3.2-2.26.x86_64.rpm Development files for libtar
php5-pecl-solr-2.3.0-2.211.i586.rpm Apache Solr Client for PHP
php5-pecl-solr-2.3.0-2.211.x86_64.rpm Apache Solr Client for PHP
php5-pecl_http-2.5.6-1.35.i586.rpm Extended HTTP Support
php5-pecl_http-2.5.6-1.35.x86_64.rpm Extended HTTP Support
php5-pecl_http-devel-2.5.6-1.35.i586.rpm Include files of php5-pecl_http
php5-pecl_http-devel-2.5.6-1.35.x86_64.rpm Include files of php5-pecl_http
php5-phalcon-3.1.2-21.3.i586.rpm A PHP framework
php5-phalcon-3.1.2-21.3.x86_64.rpm A PHP framework
php5-phk-3.0.1-2.32.i586.rpm PHK Accelerator extension
Advertisement
Advertisement