php5-memcached-2.2.0-5.10.i586.rpm


Advertisement

Description

php5-memcached - PHP MemcacheD client Extension

Property Value
Distribution openSUSE Tumbleweed
Repository PHP Extensions all
Package filename php5-memcached-2.2.0-5.10.i586.rpm
Package name php5-memcached
Package version 2.2.0
Package release 5.10
Package architecture i586
Package type rpm
Homepage -
License -
Maintainer -
Download size 50.14 KB
Installed size 129.50 KB
This extension uses libmemcached library to provide API for
communicating with memcached servers.

Alternatives

Package Version Architecture Repository
php5-memcached-2.2.0-5.10.x86_64.rpm 2.2.0 x86_64 PHP Extensions
php5-memcached - - -

Requires

Name Value
libc.so.6(GLIBC_2.4) -
libmemcached.so.11 -
libsasl2.so.3 -
libz.so.1 -
php(api) = 20131106
php(zend-abi) = 20131226
php5 json
php5 igbinary

Provides

Name Value
config(php5-memcached) = 2.2.0-5.10
php5-memcached = 2.2.0-5.10
php5-memcached(x86-32) = 2.2.0-5.10

Download

Type URL
Mirror widehat.opensuse.org
Binary Package php5-memcached-2.2.0-5.10.i586.rpm
Source Package php5-memcached-2.2.0-5.10.src.rpm

Install Howto

  1. Add the PHP Extensions repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/server:/php:/extensions/openSUSE_Factory/ php-extensions
  2. Install php5-memcached rpm package:
    # zypper install php5-memcached

Files

Path
/etc/php5/conf.d/memcached.ini
/usr/lib/php5/extensions/memcached.so
/usr/share/doc/packages/php5-memcached/CREDITS
/usr/share/doc/packages/php5-memcached/ChangeLog
/usr/share/doc/packages/php5-memcached/LICENSE
/usr/share/doc/packages/php5-memcached/README.markdown
/usr/share/doc/packages/php5-memcached/memcached-api.php

Changelog

2016-02-19 - pgajdos@suse.com
- do not require php5-igbinary for 13.1
2014-08-24 - munix9@googlemail.com
- update to version 2.2.0
* Added the OPT_SERVER_TIMEOUT_LIMIT behaviour
- update to version 2.2.0RC1
* Fixes incorrect size when compressing serialized objects
* Fixes endianess of compressed values
- update to version 2.2.0b1
* Reinstate support for libememcached 0.x series
* Added SASL support to session handler
* Added Memcached::flushBuffers as per GH #78
* Fixes GH #54: Fixed UDP server adding with newer libmemcached
* Fixed PHP bug #65334: (Segfault if uncompress value failed)
* Fixes GH #14: get with cas token fails to fetch all results
* Fixes GH #68: memcached 2.1.0 requires libmemcached 1.0.10
* Fixes GH #69: compiling on CentOS 6.4 with libmemcached 1.0.17
* Merged PR #91: More granular session locking support
* Added session handler settings:
- memcached.sess_number_of_replicas
- memcached.sess_randomize_replica_read
- memcached.sess_remove_failed
- memcached.sess_connect_timeout
* Added support for memcached protocol handlers
* Added Memcached::setBucket for virtual bucket support
* Added support for msgpack serialization
* Memcached::setSaslAuthData returns correct status on success
* Added support for user-defined flags in set and get operations
2013-07-12 - munix9@googlemail.com
- replaced source package with the original from github,
added pull_request_42.patch and pull_request_56.patch
2013-02-12 - munix9@googlemail.com
- initial package for version 2.1.0
* Drop support for libmemcached 0.x series, now 1.0.x is required
* Add support for virtual bucket distribution
* Fix compilation against PHP 5.2

See Also

Package Description
php5-mogilefs-0.9.2-2.20.i586.rpm PHP client library to communicate with the MogileFS storage
php5-mogilefs-0.9.2-2.20.x86_64.rpm PHP client library to communicate with the MogileFS storage
php5-oauth-1.2.3-4.22.i586.rpm oauth Consumer Extension
php5-oauth-1.2.3-4.22.x86_64.rpm oauth Consumer Extension
php5-pam-1.0.3-2.18.i586.rpm PHP PAM integration
php5-pam-1.0.3-2.18.x86_64.rpm PHP PAM integration
php5-pecl-cairo-0.3.2-2.26.i586.rpm Cairo Graphics Library Extension
php5-pecl-cairo-0.3.2-2.26.x86_64.rpm Cairo Graphics Library Extension
php5-pecl-cairo-devel-0.3.2-2.26.i586.rpm Development files for libtar
php5-pecl-cairo-devel-0.3.2-2.26.x86_64.rpm Development files for libtar
php5-pecl-solr-2.3.0-2.211.i586.rpm Apache Solr Client for PHP
php5-pecl-solr-2.3.0-2.211.x86_64.rpm Apache Solr Client for PHP
php5-pecl_http-2.5.6-1.35.i586.rpm Extended HTTP Support
php5-pecl_http-2.5.6-1.35.x86_64.rpm Extended HTTP Support
php5-pecl_http-devel-2.5.6-1.35.i586.rpm Include files of php5-pecl_http
Advertisement
Advertisement