php5-gtk-devel-2.0.1-2.39.i586.rpm


Advertisement

Description

php5-gtk-devel - PHP bindings for GTK2

Property Value
Distribution openSUSE Tumbleweed
Repository PHP Extensions all
Package filename php5-gtk-devel-2.0.1-2.39.i586.rpm
Package name php5-gtk-devel
Package version 2.0.1
Package release 2.39
Package architecture i586
Package type rpm
Homepage -
License -
Maintainer -
Download size 14.21 KB
Installed size 122 B
PHP-GTK is an extension for the PHP programming language that implements language bindings for GTK+.
It provides an object-oriented interface to GTK+ classes and functions and greatly simplifies
writing client-side cross-platform GUI applications.

Alternatives

Package Version Architecture Repository
php5-gtk-devel-2.0.1-2.39.x86_64.rpm 2.0.1 x86_64 PHP Extensions
php5-gtk-devel - - -

Requires

Name Value
php5-gtk = 2.0.1

Provides

Name Value
php5-gtk-devel = 2.0.1-2.39
php5-gtk-devel(x86-32) = 2.0.1-2.39

Download

Type URL
Mirror widehat.opensuse.org
Binary Package php5-gtk-devel-2.0.1-2.39.i586.rpm
Source Package php5-gtk-2.0.1-2.39.src.rpm

Install Howto

  1. Add the PHP Extensions repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/server:/php:/extensions/openSUSE_Factory/ php-extensions
  2. Install php5-gtk-devel rpm package:
    # zypper install php5-gtk-devel

Files

Path
/usr/include/php5/ext/
/usr/include/php5/ext/php_gtk2/
/usr/include/php5/ext/php_gtk2/main/php_gtk_api.h

Changelog

2016-01-29 - pgajdos@suse.com
- provides php-gtk symbol
2015-07-07 - mailaender@opensuse.org
- build the final gtk2 version, tagged at GitHub
- avoid conflicts with gtk3 dependencies
- fix rpmlint warnings
2012-11-27 - joop.boonen@opensuse.org
- Build version 2.0.1+svn328512
2010-09-07 - joop.boonen@opensuse.org
- Build according to:
- http://oops.opsat.net/doc/gtk/configure-php.html
- as the old build breaks php cli
2010-07-03 - joop.boonen@opensuse.org
- Build version SVN300976
2010-06-03 - joop.boonen@opensuse.org
- Build version SVN300172
2010-05-21 - joop.boonen@opensuse.org
- Build version SVN299605
2010-05-17 - joop.boonen@opensuse.org
- Build version SVN299435
2010-05-16 - joop.boonen@opensuse.org
- Build version SVN299416
2010-05-15 - joop.boonen@opensuse.org
- Build version SVN299407

See Also

Package Description
php5-haru-1.0.4-2.16.i586.rpm Create PDF Documents Using the Haru Free PDF Library
php5-haru-1.0.4-2.16.x86_64.rpm Create PDF Documents Using the Haru Free PDF Library
php5-igbinary-1.2.1-2.22.i586.rpm Replacement for the Standard PHP Serializer
php5-igbinary-1.2.1-2.22.x86_64.rpm Replacement for the Standard PHP Serializer
php5-imagick-3.4.1-1.22.x86_64.rpm Wrapper to the ImageMagick/GraphicsMagick library
php5-imagick-3.4.1-1.23.i586.rpm Wrapper to the ImageMagick/GraphicsMagick library
php5-imagick-devel-3.4.1-1.22.x86_64.rpm Header files for imagick development
php5-imagick-devel-3.4.1-1.23.i586.rpm Header files for imagick development
php5-inotify-0.1.6-3.15.i586.rpm The inotify extension allows to use inotify functions in a PHP script.
php5-inotify-0.1.6-3.15.x86_64.rpm The inotify extension allows to use inotify functions in a PHP script.
php5-libsodium-1.0.2-3.21.i586.rpm A simple, low-level PHP extension for libsodium
php5-libsodium-1.0.2-3.21.x86_64.rpm A simple, low-level PHP extension for libsodium
php5-lzf-1.6.3-2.15.i586.rpm PHP LZF de/compression extension
php5-lzf-1.6.3-2.15.x86_64.rpm PHP LZF de/compression extension
php5-mailparse-2.1.6-4.29.i586.rpm Email Message Manipulation
Advertisement
Advertisement