php5-pear-phpunit-PHP_CodeCoverage-1.2.17-19.7.noarch.rpm


Advertisement

Description

php5-pear-phpunit-PHP_CodeCoverage - PHP code coverage information

Property Value
Distribution openSUSE Tumbleweed
Repository PHP Applications all
Package filename php5-pear-phpunit-PHP_CodeCoverage-1.2.17-19.7.noarch.rpm
Package name php5-pear-phpunit-PHP_CodeCoverage
Package version 1.2.17
Package release 19.7
Package architecture noarch
Package type rpm
Category Development/Libraries/PHP
Homepage http://pear.phpunit.de/
License BSD-3-Clause
Maintainer -
Download size 188.05 KB
Installed size 810.85 KB
Library that provides collection, processing, and rendering functionality for PHP code coverage information.

Alternatives

Package Version Architecture Repository
php5-pear-phpunit-PHP_CodeCoverage-1.2.17-19.2.noarch.rpm 1.2.17 noarch PHP Applications
php5-pear-phpunit-PHP_CodeCoverage - - -

Requires

Name Value
php5-pear-channel-phpunit -
php5-pear-phpunit-File_Iterator >= 1.3.0
php5-pear-phpunit-PHP_TokenStream >= 1.1.3
php5-pear-phpunit-Text_Template >= 1.1.1

Provides

Name Value
pear-PHP_CodeCoverage -
pear-php_codecoverage = 1.2.17
php-pear-PHP_CodeCoverage -
php-pear-php_codecoverage = 1.2.17
php5-pear-php_codecoverage = 1.2.17
php5-pear-phpunit-PHP_CodeCoverage = 1.2.17-19.7

Obsoletes

Name Value
pear-php_codecoverage < 1.2.17
php-pear-php_codecoverage < 1.2.17
php5-pear-php_codecoverage < 1.2.17

Download

Type URL
Mirror widehat.opensuse.org
Binary Package php5-pear-phpunit-PHP_CodeCoverage-1.2.17-19.7.noarch.rpm
Source Package php5-pear-phpunit-PHP_CodeCoverage-1.2.17-19.7.src.rpm

Install Howto

  1. Add the PHP Applications repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/server:/php:/applications/openSUSE_Tumbleweed/ php-applications
  2. Install php5-pear-phpunit-PHP_CodeCoverage rpm package:
    # zypper install php5-pear-phpunit-PHP_CodeCoverage

Files

Path
/usr/share/doc/packages/PHP_CodeCoverage/LICENSE
/usr/share/php5/PEAR/PHP/CodeCoverage.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Autoload.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Driver.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Exception.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Filter.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Util.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Version.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Driver/Xdebug.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/Clover.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/Factory.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/Node.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/PHP.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/Text.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/Dashboard.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/Directory.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/File.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/Template/coverage_bar.html.dist
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/Template/dashboard.html.dist
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/Template/directory.html.dist
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/Template/directory_item.html.dist
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/Template/file.html.dist
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/Template/file_item.html.dist
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/Template/method_item.html.dist
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/Template/css/bootstrap-responsive.min.css
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/Template/css/bootstrap.min.css
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/Template/css/nv.d3.css
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/Template/css/style.css
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/Template/img/glyphicons-halflings-white.png
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/Template/img/glyphicons-halflings.png
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/Template/js/bootstrap.min.js
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/Template/js/d3.min.js
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/Template/js/html5shiv.js
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/Template/js/jquery.min.js
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/HTML/Renderer/Template/js/nv.d3.min.js
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/Node/Directory.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/Node/File.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Report/Node/Iterator.php
/usr/share/php5/PEAR/PHP/CodeCoverage/Util/InvalidArgumentHelper.php
/var/lib/pear/PHP_CodeCoverage.xml

Changelog

2014-07-05 - gerrit.beine@gmx.de
- Update to version 1.2.17
2013-11-23 - gerrit.beine@gmx.de
- Update to version 1.2.13
* Fixed the origin of the coordinate system for the dashboard
charts
2013-08-04 - robert.munteanu@gmail.com
- Updated to version 1.2.12
* Fixed #173: JavaScript error in the HTML report.
* Fixing an issue where an anonymous function as the last "method"
in a class would cause the coverage report to ignore the rest.
- Updated to version 1.2.11
* Fixed #151: Blacklisted PHPUnit Phar.
* Fixed sebastianbergmann/phpunit#924.
- Updated to version 1.2.10
* Fixed #158: Executable code on a line that has a comment is
processed incorrectly.
* Eliminated the coupling to PHPUnit_Util_Printer in
PHP_CodeCoverage_Report_Text.
- Updated to version 1.2.9
* Improved rendering of "lines covered" numbers for functions and
methods with long names or argument lists.
* Fixed the title of the Y axis of the Code Coverage ./. Cyclomatic
Complexity dashboard chart.
* Upgraded to Highcharts 2.3.5.
* Upgraded to jQuery 1.9.1.
- Updated to version 1.2.8
* Reduced vertical whitespace in sourcecode view.
* Upgraded to Bootstrap 2.2.2.
- Updated to version 1.2.7
* The html5shiv.js is now bundled.
* Fixed sebastianbergmann/phpunit#702: @coversNothing didn't work
as documented.
- Updated to version 1.2.6
* Fixed #126: E_NOTICE thrown when generating coverage report.
- Updated to version 1.2.5
* Fixed regression introduced in PHP_CodeCoverage 1.2.4.
- Updated to version 1.2.4
* Fixed #123: Incorrect code coverage for interfaces.
- Updated to version 1.2.3
* Implemented #116: Do not rely on autoloader class map to
populate blacklist.
* Added support for parentheses after method names in the @covers
annotation.
* When addUncoveredFilesFromWhitelist=FALSE is set then files that
are whitelisted but not covered by a single test are now excluded
from the code coverage.
* Fixed #81: Non-english locales broke the coverage bars in the
HTML report.
* Fixed #118: Percentage for tested classes and traits displayed
incorrectly.
* Fixed #121: One line @covers annotations did not work.
- Updated to version 1.2.2
* Fixed #115: Backwards compatibility wrapper for trait_exists()
does not work.
- Updated to version 1.2.1
* Fixed invalid markup in the HTML report.
* The version number is now displayed when using PHP_CodeCoverage
from a Composer install or Git checkout.
- Updated to version 1.2.0
* The HTML report has been redesigned.
* The new @coversDefaultClass annotation enables short @covers
annotations when working with long class names or namespaces.
* The new @coversNothing annotation can be used so tests do not
record any code coverage. Useful for integration testing.
* When processUncoveredFilesFromWhitelist=FALSE is set then files
that are whitelisted but not covered by a single test are now
included in the code coverage but with all lines, including those
that are not executable, counted as not executed.
* PHP_CodeCoverage 1.2 is only supported on PHP 5.3.3 (or later) and
PHP 5.4.7 (or later) is highly recommended.
2012-03-11 - robert.munteanu@gmail.com
- Added missing Requires: php5-pear-phpunit-PHP_TokenStream
2012-02-25 - robert.munteanu@gmail.com
- version 1.1.2
- Fixed #80: Whitelisted files that do not exist lead to errors.
- Fixed #91: Traits are not handled properly.
- Fixed notice in
PHP_CodeCoverage_Util::resolveCoversToReflectionObjects().
- The callbable, implements, and insteadof keywords are now properly
highlighted in the HTML report.
2012-02-14 - lang@b1-systems.de
- license tag changed to BSD-3-Clause
2012-02-12 - lang@b1-systems.de
- version 1.1.1
- fixed #74: Removed extraneous spaces in displayed paths in the HTML code coverage report.
- fixed #75: CRAP index missing from HTML code coverage report.
- this adresses https://bugzilla.novell.com/show_bug.cgi?id=714933 (already removed in previous 1.1.0RC4)

See Also

Package Description
php5-pear-phpunit-PHP_Invoker-1.1.3-1.2.noarch.rpm Invoker utility for calling classes
php5-pear-phpunit-PHP_Invoker-1.1.3-1.7.noarch.rpm Invoker utility for calling classes
php5-pear-phpunit-PHP_Timer-1.0.5-18.2.noarch.rpm Utility class for timing
php5-pear-phpunit-PHP_Timer-1.0.5-18.7.noarch.rpm Utility class for timing
php5-pear-phpunit-PHP_TokenStream-1.2.2-15.2.noarch.rpm Wrapper around PHP's tokenizer extension
php5-pear-phpunit-PHP_TokenStream-1.2.2-15.7.noarch.rpm Wrapper around PHP's tokenizer extension
php5-pear-phpunit-TestListener_DBUS-1.0.0-1.2.noarch.rpm A TestListener for PHPUnit that sends events to DBUS.
php5-pear-phpunit-TestListener_DBUS-1.0.0-1.7.noarch.rpm A TestListener for PHPUnit that sends events to DBUS.
php5-pear-phpunit-TestListener_XHProf-1.0.0-1.2.noarch.rpm TestListener for PHPUnit that uses XHProf for automated profiling of the tested code
php5-pear-phpunit-TestListener_XHProf-1.0.0-1.7.noarch.rpm TestListener for PHPUnit that uses XHProf for automated profiling of the tested code
php5-pear-phpunit-Text_Template-1.2.0-18.2.noarch.rpm Simple template engine
php5-pear-phpunit-Text_Template-1.2.0-18.7.noarch.rpm Simple template engine
php5-pear-phpunit-TicketListener_Fogbugz-1.0.0-1.2.noarch.rpm A ticket listener for PHPUnit that interacts with the Fogbugz issue API
php5-pear-phpunit-TicketListener_Fogbugz-1.0.0-1.7.noarch.rpm A ticket listener for PHPUnit that interacts with the Fogbugz issue API
php5-pear-phpunit-TicketListener_GitHub-1.0.0-1.2.noarch.rpm A ticket listener for PHPUnit that interacts with the GitHub issue API
Advertisement
Advertisement