seccheck-3.0-1403.1.noarch.rpm


Advertisement

Description

seccheck - Security-Check Scripts

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Security all
Package name seccheck
Package version 3.0
Package release 1403.1
Package architecture noarch
Package type rpm
Installed size 68.93 KB
Download size 33.63 KB
Official Mirror ftp.gwdg.de
Regularly executable scripts (via cron) for checking the security of
your system.

Alternatives

Package Version Architecture Repository
seccheck-3.0-13.1.noarch.rpm 3.0 noarch openSUSE Oss
seccheck - - -

Requires

Name Value
/bin/bash -
bash -
coreutils -
cron -
diffutils -
fillup -
grep -

Provides

Name Value
config(seccheck) = 3.0-1403.1
seccheck = 3.0-1403.1
suse-security-check-3.0 -

Download

Type URL
Binary Package seccheck-3.0-1403.1.noarch.rpm
Source Package seccheck-3.0-1403.1.src.rpm

Install Howto

  1. Add the openSUSE Security repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/security/openSUSE_Tumbleweed/ opensuse-security
  2. Install seccheck rpm package:
    # zypper install seccheck

Files

Path
/etc/cron.d/autologout
/etc/cron.d/seccheck
/etc/security/autologout.conf
/usr/lib/secchk/autologout.sh
/usr/lib/secchk/basic.inc
/usr/lib/secchk/checkneverlogin
/usr/lib/secchk/helper.inc
/usr/lib/secchk/security-control.sh
/usr/lib/secchk/security-daily.sh
/usr/lib/secchk/security-monthly.sh
/usr/lib/secchk/security-weekly.sh
/usr/lib/secchk/security_daily_helper.inc
/usr/lib/secchk/security_weekly_helper.inc
/usr/lib/secchk/user_group_password_helper.inc
/usr/lib/secchk/blurbs/guessable_passwd.txt
/usr/lib/secchk/blurbs/security_control.txt
/usr/share/doc/packages/seccheck/CHANGES
/usr/share/doc/packages/seccheck/LICENCE
/usr/share/doc/packages/seccheck/README
/usr/share/doc/packages/seccheck/TODO
/usr/share/fillup-templates/sysconfig.seccheck
/var/lib/secchk/
/var/lib/secchk/data/

Changelog

2018-05-07 - vpereira@microfocus.com
- fixes proposed by the bsc#1084449:
+ introduction of SECCHK_FROM
+ deletion of empty file
2017-11-23 - rbrown@suse.com
- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)
2017-08-15 - vpereira@suse.com
- fixed: bsc#1033244: john integration were broken
2017-03-06 - vpereira@suse.com
- fixed: bsc#1021036: mute stderr on sysctl -a
2016-07-24 - vpereira@suse.com
-  fixed bnc#985802: security monthly reports were broken
2015-10-07 - vpereira@suse.com
- fixed bnc#942846: seccheck does not collect the same data in
SLES 12 and SLES 11 sp3
- seccheck-3.0-fix-bashisms.patch and daily-mailer.patch were merged into upstream
2015-10-05 - vpereira@suse.com
- use upstream version of code
2015-04-27 - vpereira@suse.com
- added patch: emails-without-subject.patch to fix bnc#923688
2015-02-03 - vpereira@suse.com
- bnc#914656: fixed function guessable_password_email definition
2014-12-17 - Led <ledest@gmail.com>
- fix bashisms in scripts
- fix chebang of autologout.sh script than contains bash-specific
constructions
- add patches:
* seccheck-3.0-fix-bashisms.patch

See Also

Package Description
secure-delete-3.1-7.6.i586.rpm Tools to wipe files, free disk space, swap and memory
secure-delete-3.1-7.6.x86_64.rpm Tools to wipe files, free disk space, swap and memory
sha1collisiondetection-1.0.3-17.5.i586.rpm Detection of SHA-1 collisions
sha1collisiondetection-1.0.3-17.5.x86_64.rpm Detection of SHA-1 collisions
sks-1.1.6-11.8.i586.rpm Synchronizing Key Server
sks-1.1.6-11.8.x86_64.rpm Synchronizing Key Server
softhsm-2.4.0-18.8.i586.rpm Software version of a PKCS#11 Hardware Security Module
softhsm-2.4.0-18.8.x86_64.rpm Software version of a PKCS#11 Hardware Security Module
softhsm-devel-2.4.0-18.8.i586.rpm Development package of softhsm that includes the header files
softhsm-devel-2.4.0-18.8.x86_64.rpm Development package of softhsm that includes the header files
spectre-meltdown-checker-0.37-10.1.i586.rpm Spectre & Meltdown Vulnerability Checker
spectre-meltdown-checker-0.37-10.1.x86_64.rpm Spectre & Meltdown Vulnerability Checker
srm-1.2.15-29.32.i586.rpm A secure replacement for rm
srm-1.2.15-29.32.x86_64.rpm A secure replacement for rm
ssdeep-2.14.1-21.8.i586.rpm Context Triggered Piecewise Hashing values
Advertisement
Advertisement