telepathy-logger-qt5-devel-17.08.0-1.1.x86_64.rpm


Advertisement

Description

telepathy-logger-qt5-devel - Qt Wrapper around TpLogger client library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename telepathy-logger-qt5-devel-17.08.0-1.1.x86_64.rpm
Package name telepathy-logger-qt5-devel
Package version 17.08.0
Package release 1.1
Package architecture x86_64
Package type rpm
Category Development/Libraries/KDE
Homepage https://github.com/KDE/telepathy-logger-qt
License LGPL-2.1-or-later
Maintainer -
Download size 23.24 KB
Installed size 53.85 KB
Telepathy-logger-qt5 is a Qt Wrapper around the TpLogger client library.
It is needed by KDE Telepathy in order to log the chat activity.

Alternatives

Package Version Architecture Repository
telepathy-logger-qt5-devel-17.08.0-6.2.x86_64.rpm 17.08.0 x86_64 KDE Applications 5
telepathy-logger-qt5-devel-17.08.0-6.2.i586.rpm 17.08.0 i586 KDE Applications 5
telepathy-logger-qt5-devel-17.08.0-1.1.i586.rpm 17.08.0 i586 openSUSE Oss
telepathy-logger-qt5-devel-16.11.60git.20170824T130902~0b4373c-1.6.x86_64.rpm 16.11.60git.20170824T130902~0b4373c x86_64 KDE Applications Unstable
telepathy-logger-qt5-devel-16.11.60git.20170824T130902~0b4373c-1.6.i586.rpm 16.11.60git.20170824T130902~0b4373c i586 KDE Applications Unstable
telepathy-logger-qt5-devel - - -

Requires

Name Value
libtelepathy-logger-qt5 = 17.08.0
telepathy-glib-devel -
telepathy-logger-devel >= 0.8.0

Provides

Name Value
cmake(TelepathyLoggerQt) = 0.9.80.0
telepathy-logger-qt5-devel = 17.08.0-1.1
telepathy-logger-qt5-devel(x86-64) = 17.08.0-1.1

Conflicts

Name Value
telepathy-logger-qt4-devel -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package telepathy-logger-qt5-devel-17.08.0-1.1.x86_64.rpm
Source Package telepathy-logger-qt5-17.08.0-1.1.src.rpm

Install Howto

Install telepathy-logger-qt5-devel rpm package:

# zypper install telepathy-logger-qt5-devel

Files

Path
/usr/include/TelepathyLoggerQt/CallEvent
/usr/include/TelepathyLoggerQt/Entity
/usr/include/TelepathyLoggerQt/Event
/usr/include/TelepathyLoggerQt/Global
/usr/include/TelepathyLoggerQt/Init
/usr/include/TelepathyLoggerQt/LogManager
/usr/include/TelepathyLoggerQt/LogWalker
/usr/include/TelepathyLoggerQt/Object
/usr/include/TelepathyLoggerQt/PendingDates
/usr/include/TelepathyLoggerQt/PendingEntities
/usr/include/TelepathyLoggerQt/PendingEvents
/usr/include/TelepathyLoggerQt/PendingOperation
/usr/include/TelepathyLoggerQt/PendingSearch
/usr/include/TelepathyLoggerQt/SearchHit
/usr/include/TelepathyLoggerQt/TelepathyLoggerQt_export.h
/usr/include/TelepathyLoggerQt/TelepathyLoggerQt_version.h
/usr/include/TelepathyLoggerQt/TelepathyLogger_version.h
/usr/include/TelepathyLoggerQt/TextEvent
/usr/include/TelepathyLoggerQt/Types
/usr/include/TelepathyLoggerQt/call-event.h
/usr/include/TelepathyLoggerQt/entity.h
/usr/include/TelepathyLoggerQt/event.h
/usr/include/TelepathyLoggerQt/global.h
/usr/include/TelepathyLoggerQt/init.h
/usr/include/TelepathyLoggerQt/log-manager.h
/usr/include/TelepathyLoggerQt/log-walker.h
/usr/include/TelepathyLoggerQt/object.h
/usr/include/TelepathyLoggerQt/pending-dates.h
/usr/include/TelepathyLoggerQt/pending-entities.h
/usr/include/TelepathyLoggerQt/pending-events.h
/usr/include/TelepathyLoggerQt/pending-operation.h
/usr/include/TelepathyLoggerQt/pending-search.h
/usr/include/TelepathyLoggerQt/search-hit.h
/usr/include/TelepathyLoggerQt/text-event.h
/usr/include/TelepathyLoggerQt/types.h
/usr/lib64/libtelepathy-logger-qt.so
/usr/lib64/cmake/TelepathyLoggerQt/TelepathyLoggerQtConfig.cmake
/usr/lib64/cmake/TelepathyLoggerQt/TelepathyLoggerQtConfigVersion.cmake
/usr/lib64/cmake/TelepathyLoggerQt/TelepathyLoggerQtTargets-none.cmake
/usr/lib64/cmake/TelepathyLoggerQt/TelepathyLoggerQtTargets.cmake

Changelog

2018-11-26 - wbauer@tmo.at
- Don't set LIB_SUFFIX manually, it's not necessary
- Update URL
- Run spec-cleaner
2018-02-08 - wbauer@tmo.at
- Force python2 by passing -DPYTHON_EXECUTABLE=%{_bindir}/python2
to cmake to fix build on Tumbleweed
2017-08-25 - wbauer@tmo.at
- Update to 17.08.0:
* fix compatibility with cmake-3.9.x
2017-02-02 - adam.majer@suse.de
- use individual libboost-*-devel packages instead of boost-devel
2015-04-24 - tittiatcoke@gmail.com
- Update to KDE Applications 15.04.0
* KDE Applications 15.04.0
* https://www.kde.org/announcements/announce-applications-15.04.0.php
2014-11-07 - alinm.elena@gmail.com
- initial comit

See Also

Package Description
telepathy-mission-control-5.16.3-3.3.i586.rpm Telepathy Mission Control instant messaging connection manager
telepathy-mission-control-5.16.3-3.3.x86_64.rpm Telepathy Mission Control instant messaging connection manager
telepathy-mission-control-devel-5.16.3-3.3.i586.rpm Telepathy Mission Control instant messaging connection manager
telepathy-mission-control-devel-5.16.3-3.3.x86_64.rpm Telepathy Mission Control instant messaging connection manager
telepathy-mission-control-plugin-goa-3.12.14-7.1.i586.rpm Telepathy Mission Control Plugin to use data from GNOME Online Accounts
telepathy-mission-control-plugin-goa-3.12.14-7.1.x86_64.rpm Telepathy Mission Control Plugin to use data from GNOME Online Accounts
telepathy-qt5-devel-0.9.7-1.9.i586.rpm Header files, libraries and development documentation for telepathy-qt5
telepathy-qt5-devel-0.9.7-1.9.x86_64.rpm Header files, libraries and development documentation for telepathy-qt5
telepathy-qt5-devel-32bit-0.9.7-1.9.x86_64.rpm Header files, libraries and development documentation for telepathy-qt5
telepathy-rakia-0.8.0-4.3.i586.rpm SIP connection manager for Telepathy
telepathy-rakia-0.8.0-4.3.x86_64.rpm SIP connection manager for Telepathy
telepathy-rakia-devel-0.8.0-4.3.i586.rpm SIP connection manager for Telepathy - development files
telepathy-rakia-devel-0.8.0-4.3.x86_64.rpm SIP connection manager for Telepathy - development files
telepathy-sipe-1.24.0-1.2.i586.rpm MS Skype for Business connection manager for Telepathy
telepathy-sipe-1.24.0-1.2.x86_64.rpm MS Skype for Business connection manager for Telepathy
Advertisement
Advertisement