suck-4.3.4-1.3.x86_64.rpm


Advertisement

Description

suck - Reading News Offline

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename suck-4.3.4-1.3.x86_64.rpm
Package name suck
Package version 4.3.4
Package release 1.3
Package architecture x86_64
Package type rpm
Category Productivity/Networking/News/Utilities
Homepage https://github.com/lazarus-pkgs/suck
License SUSE-Public-Domain
Maintainer -
Download size 118.48 KB
Installed size 323.98 KB
Suck is a program used to grab news from a remote NNTP news server and
bring it to a local machine, without having the remote server do
anything special.

Alternatives

Package Version Architecture Repository
suck-4.3.4-1.3.i586.rpm 4.3.4 i586 openSUSE Oss
suck - - -

Requires

Name Value
libc.so.6(GLIBC_2.26)(64bit) -
libssl.so.1.1()(64bit) -
libssl.so.1.1(OPENSSL_1_1_0)(64bit) -
perl = 5.28.1

Provides

Name Value
suck = 4.3.4-1.3
suck(x86-64) = 4.3.4-1.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package suck-4.3.4-1.3.x86_64.rpm
Source Package suck-4.3.4-1.3.src.rpm

Install Howto

Install suck rpm package:

# zypper install suck

Files

Path
/usr/bin/lmove
/usr/bin/rpost
/usr/bin/suck
/usr/bin/testhost
/usr/share/man/man1/lmove.1.gz
/usr/share/man/man1/rpost.1.gz
/usr/share/man/man1/suck.1.gz
/usr/share/man/man1/testhost.1.gz

Changelog

2018-08-01 - mvetter@suse.com
- Update to 4.3.4:
* Fix invalid memory access in both.c (Debian bug #858040)
* Fix SIGSEV in connect_to_nntphost (Debian bugs #716448,
[#716510], #716606)
* Fix stack smash in lmove.c and suckutils.c (Debian bug #832265)
* Fix manpage formatting (Debian bug #858262)
2017-10-26 - mvetter@suse.com
- Update to 4.3.3:
* General code cleanup
* Applying patches from Debian, Fedora and openSUSE
* Add support for IPv6
* Manpage fixes
* Default path for history file is now /var/lib/news/history
* Default path for phrases file is now /etc/suck/phrases
* Install to DESTDIR
* Don't strip binaries
- Remove:
* suck-4.3.0.dif
* suck-4.3.0-ia64.patch
* suck-4.3.0-thrperl.dif
* suck-4.3.0-fgets.patch
* suck-4.3.0-inn3_headers_location.patch
* suck-4.3.0-codecleanup.patch
- Remove conditional around inn-devel
- Use standard make install
- Solves boo#747941
2017-09-29 - mvetter@suse.com
- Update to home-made 4.3.3
2013-09-05 - mls@suse.de
- add libperl_requires, as we link against libperl and thus
need a specific version of perl
2010-04-22 - pth@novell.com
- Fix location of inn3 headers.
- Fix some compiler warnings.
- Move examples to _docdir/examples.
2007-06-04 - dmueller@suse.de
- update BuildRequires
2007-02-14 - mvaner@suse.cz
- Replaced dangerous gets with fgets, bug #223615
- fgets.patch
2006-01-25 - mls@suse.de
- converted neededforbuild to BuildRequires
2006-01-15 - schwab@suse.de
- Don't strip binaries.
2004-04-28 - ro@suse.de
- added -fno-strict-aliasing

See Also

Package Description
sudo-1.8.27-1.2.i586.rpm Execute some commands as root
sudo-1.8.27-1.2.x86_64.rpm Execute some commands as root
sudo-devel-1.8.27-1.2.i586.rpm Header files needed for sudo plugin development
sudo-devel-1.8.27-1.2.x86_64.rpm Header files needed for sudo plugin development
sudo-test-1.8.27-1.2.i586.rpm Tests for the package
sudo-test-1.8.27-1.2.x86_64.rpm Tests for the package
sudoku-sensei-02_00-2.1.i586.rpm Enjoy playing with Sudoku boards designed by yourself
sudoku-sensei-02_00-2.1.x86_64.rpm Enjoy playing with Sudoku boards designed by yourself
suil-devel-0.10.0-2.4.i586.rpm Development files for the suil library
suil-devel-0.10.0-2.4.x86_64.rpm Development files for the suil library
suil-plugin-gtk2-in-qt5-0.10.0-2.4.i586.rpm Shared object for GTK2 hosts displaying Qt5 LV2 GUIs
suil-plugin-gtk2-in-qt5-0.10.0-2.4.x86_64.rpm Shared object for GTK2 hosts displaying Qt5 LV2 GUIs
suil-plugin-qt5-in-gtk2-0.10.0-2.4.i586.rpm Shared object for Qt5 hosts displaying GTK2 LV2 GUIs
suil-plugin-qt5-in-gtk2-0.10.0-2.4.x86_64.rpm Shared object for Qt5 hosts displaying GTK2 LV2 GUIs
suil-plugin-x11-0.10.0-2.4.i586.rpm Shared object for X11 LV2 GUIs
Advertisement
Advertisement