spectre-meltdown-checker-0.40-2.1.i586.rpm


Advertisement

Description

spectre-meltdown-checker - Spectre & Meltdown Vulnerability Checker

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename spectre-meltdown-checker-0.40-2.1.i586.rpm
Package name spectre-meltdown-checker
Package version 0.40
Package release 2.1
Package architecture i586
Package type rpm
Category Productivity/Security
Homepage https://github.com/speed47/spectre-meltdown-checker
License GPL-3.0-only
Maintainer -
Download size 53.61 KB
Installed size 195.55 KB
A shell script to tell if your Linux installation is vulnerable
against the three "speculative execution" CVEs that were made public
in early 2018.
Without options, the script inspects the currently running kernel.
Alternatively, a kernel image can be specify on the command line to
analyze a non-running kernel.
The script tries to detect mitigations, including backported
non-vanilla patches, regardless of the advertised kernel version
number.

Alternatives

Package Version Architecture Repository
spectre-meltdown-checker-0.40-18.1.x86_64.rpm 0.40 x86_64 Security
spectre-meltdown-checker-0.40-18.1.i586.rpm 0.40 i586 Security
spectre-meltdown-checker-0.40-2.1.x86_64.rpm 0.40 x86_64 openSUSE Oss
spectre-meltdown-checker - - -

Provides

Name Value
spectre-meltdown-checker = 0.40-2.1
spectre-meltdown-checker(x86-32) = 0.40-2.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package spectre-meltdown-checker-0.40-2.1.i586.rpm
Source Package spectre-meltdown-checker-0.40-2.1.src.rpm

Install Howto

Install spectre-meltdown-checker rpm package:

# zypper install spectre-meltdown-checker

Files

Path
/usr/bin/spectre-meltdown-checker.sh
/usr/share/doc/packages/spectre-meltdown-checker/LICENSE
/usr/share/doc/packages/spectre-meltdown-checker/README.md

Changelog

2019-03-27 - Jan Engelhardt <jengelh@inai.de>
- Use Source URL. Remove services, just run `osc service lr
download_files` for updating.
2019-03-27 - Marcus Meissner <meissner@suse.com>
- disable the services, just run "osc service disabledrun" for upadating.
2018-10-14 - sean@suspend.net
- version 0.40
* add support for L1TF CVEs (aka Foreshadow and Foreshadow-NG)
* add summary of vulnerabilities at the end of script execution
2018-07-27 - jengelh@inai.de
- Compact and wrap description.
2018-05-30 - meissner@suse.com
- version 0.37
* lots of improvements
* spectre v4 and v3a added
2018-01-15 - adrian@suse.de
- update to version 0.31
* meltdown: detecting Xen PV, reporting as not vulnerable
* is_cpu_vulnerable: add check for old Atoms
* ibrs: check for spec_ctrl_ibrs in cpuinfo
2018-01-13 - adrian@suse.de
- update to version 0.29
* AMD updates
2018-01-12 - adrian@suse.de
- initial package of version 0.27

See Also

Package Description
speech-dispatcher-0.9.0-2.1.i586.rpm Device independent layer for speech synthesis
speech-dispatcher-0.9.0-2.1.x86_64.rpm Device independent layer for speech synthesis
speech-dispatcher-configure-0.9.0-2.1.i586.rpm Configuration tool for Speech Dispatcher
speech-dispatcher-configure-0.9.0-2.1.x86_64.rpm Configuration tool for Speech Dispatcher
speech-dispatcher-module-espeak-0.9.0-2.1.i586.rpm ESpeak module for Speech Dispatcher
speech-dispatcher-module-espeak-0.9.0-2.1.x86_64.rpm ESpeak module for Speech Dispatcher
speedcrunch-0.12-1.7.i586.rpm Calculator with history display, keyboard-oriented
speedcrunch-0.12-1.7.x86_64.rpm Calculator with history display, keyboard-oriented
speedtest-cli-2.1.1-1.1.noarch.rpm Command line interface for testing internet bandwidth
speex-1.2-1.6.i586.rpm An Open Source, Patent Free Speech Codec
speex-1.2-1.6.x86_64.rpm An Open Source, Patent Free Speech Codec
speex-devel-1.2-1.6.i586.rpm Development package for SpeeX
speex-devel-1.2-1.6.x86_64.rpm Development package for SpeeX
speexdsp-devel-1.2~rc3-4.4.i586.rpm Development package for SpeeX
speexdsp-devel-1.2~rc3-4.4.x86_64.rpm Development package for SpeeX
Advertisement
Advertisement