slrn-1.0.3-3.2.x86_64.rpm


Advertisement

Description

slrn - Threaded Newsreader

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename slrn-1.0.3-3.2.x86_64.rpm
Package name slrn
Package version 1.0.3
Package release 3.2
Package architecture x86_64
Package type rpm
Category Productivity/Networking/News/Clients
Homepage http://www.slrn.org
License GPL-2.0-or-later
Maintainer -
Download size 362.53 KB
Installed size 1.14 MB
slrn is a threaded Internet newsreader. It is customizable,
permitting redefinition of keys and it includes a sophisticated macro
language for further customization.

Alternatives

Package Version Architecture Repository
slrn-1.0.3-3.2.i586.rpm 1.0.3 i586 openSUSE Oss
slrn - - -

Requires

Name Value
libc.so.6(GLIBC_2.15)(64bit) -
libcrypto.so.1.1()(64bit) -
libcrypto.so.1.1(OPENSSL_1_1_0)(64bit) -
libslang.so.2()(64bit) -
libslang.so.2(SLANG2)(64bit) -
libssl.so.1.1()(64bit) -
libssl.so.1.1(OPENSSL_1_1_0)(64bit) -

Provides

Name Value
config(slrn) = 1.0.3-3.2
slrn = 1.0.3-3.2
slrn(x86-64) = 1.0.3-3.2

Download

Type URL
Mirror widehat.opensuse.org
Binary Package slrn-1.0.3-3.2.x86_64.rpm
Source Package slrn-1.0.3-3.2.src.rpm

Install Howto

Install slrn rpm package:

# zypper install slrn

Files

Path
/etc/slrn/slrn.rc
/usr/bin/slrn
/usr/bin/slrnpull
/usr/share/doc/packages/slrn/COPYRIGHT
/usr/share/doc/packages/slrn/FAQ
/usr/share/doc/packages/slrn/FIRST_STEPS
/usr/share/doc/packages/slrn/README
/usr/share/doc/packages/slrn/README.GroupLens
/usr/share/doc/packages/slrn/README.SSL
/usr/share/doc/packages/slrn/README.macros
/usr/share/doc/packages/slrn/README.multiuser
/usr/share/doc/packages/slrn/THANKS
/usr/share/doc/packages/slrn/changes.txt
/usr/share/doc/packages/slrn/help.txt
/usr/share/doc/packages/slrn/manual.txt
/usr/share/doc/packages/slrn/pc-keys.txt
/usr/share/doc/packages/slrn/score.sl
/usr/share/doc/packages/slrn/score.txt
/usr/share/doc/packages/slrn/slrn-doc.html
/usr/share/doc/packages/slrn/slrn.rc
/usr/share/doc/packages/slrn/slrnfuns.txt
/usr/share/doc/packages/slrn/contrib/NEWS.cleanscore
/usr/share/doc/packages/slrn/contrib/README.cleanscore
/usr/share/doc/packages/slrn/contrib/README.slrnrc-conv
/usr/share/doc/packages/slrn/contrib/cleanscore
/usr/share/doc/packages/slrn/contrib/slrnrc-conv
/usr/share/doc/packages/slrn/slrnpull/README
/usr/share/doc/packages/slrn/slrnpull/README.offline
/usr/share/doc/packages/slrn/slrnpull/SETUP
/usr/share/doc/packages/slrn/slrnpull/score
/usr/share/doc/packages/slrn/slrnpull/setgid.txt
/usr/share/doc/packages/slrn/slrnpull/slrn.rc
/usr/share/doc/packages/slrn/slrnpull/slrnpull.conf
/usr/share/doc/packages/slrn/slrnpull/slrnpull.sh
/usr/share/licenses/slrn/COPYING
/usr/share/man/man1/slrn.1.gz
/usr/share/man/man1/slrnpull.1.gz
/usr/share/slrn/
/usr/share/slrn/slang/color.sl
/usr/share/slrn/slang/gsort.sl
/usr/share/slrn/slang/ispell.sl
/usr/share/slrn/slang/latin2.sl
/usr/share/slrn/slang/mailcap.sl
/usr/share/slrn/slang/mime.sl
/usr/share/slrn/slang/multipart.sl
/usr/share/slrn/slang/nn.sl
/usr/share/slrn/slang/posthook.sl
/usr/share/slrn/slang/search.sl
/usr/share/slrn/slang/slrn.sl
/usr/share/slrn/slang/tin-art.sl
/usr/share/slrn/slang/tin-group.sl
/usr/share/slrn/slang/ttyprint.sl
/usr/share/slrn/slang/util.sl
/usr/share/slrn/slang/varset.sl
/usr/share/slrn/slang/xcomment.sl

Changelog

2018-08-19 - mcepl@suse.com
- Clean up SPEC
2017-10-17 - astieger@suse.com
- Build with OpenSSL (boo#1063780),
drop slrn-fix-libgnutls-extra-dependency.patch
2017-05-03 - astieger@suse.com
- remove unused files with restrictive licenses - bsc#1036331
2017-04-11 - jengelh@inai.de
- Ensure neutrality in description.
2017-03-26 - astieger@suse.com
- slrn 1.0.3:
* A quoted-string in the display portion of an address was not
being marked as allowing mime-encoded text.
* After calling iconv to perform a character set conversion on an
article line, call it again with just the newline character.
This resets the state for some conversion types (UTF-7).
* Disable support for SSLv3, which is vulnerable to POODLE
attacks CVE-2014-3566 bsc#1031023
* The reject_long_lines option was not working as documented.
Setting it to 0 had no effect when netiquette_warnings was set
to a non-zero value.
* replace_article_with_mime_obj, also decode
quoted-printable/base64.
* Add a file from the autoconf archive that detects libraries
needed for socket support.  The old method used X_EXTRA_LIBS,
which breaks if X in not installed.
* Added support for large (>2GB) files on 32 bit unix systems.
* Updated Danish translation
* If a mime message has already been base64/QP converted, do not
try to convert it again.
* Do not use SSL_CTX_set_options if gnutls is being used
* Use labs instead of abs for long integer
* Removed compilation date info for a reproducible build
* rfc1522_encode_word: max_nbytes was not being properly limit
checked.
2017-02-28 - sfalken@opensuse.org
- Added:
+ slrn-correct-path-to-sendmail.patch:  The ed stanza in %setup
is causing a buildfailure in openSUSE:Factory, and I don't
understand ed/regexp well enough to fix it that way.  Patching the
file directly seems to work fine.

See Also

Package Description
slrn-lang-1.0.3-3.2.noarch.rpm Translations for package slrn
sluice-0.02.08-1.2.i586.rpm Rate limiting data piping tool
sluice-0.02.08-1.2.x86_64.rpm Rate limiting data piping tool
slurm-18.08.5-2.1.i586.rpm Simple Linux Utility for Resource Management
slurm-18.08.5-2.1.x86_64.rpm Simple Linux Utility for Resource Management
slurm-auth-none-18.08.5-2.1.i586.rpm SLURM auth NULL implementation (no authentication)
slurm-auth-none-18.08.5-2.1.x86_64.rpm SLURM auth NULL implementation (no authentication)
slurm-config-18.08.5-2.1.i586.rpm Config files and directories for slurm services
slurm-config-18.08.5-2.1.x86_64.rpm Config files and directories for slurm services
slurm-config-man-18.08.5-2.1.i586.rpm Config files and directories for slurm services
slurm-config-man-18.08.5-2.1.x86_64.rpm Config files and directories for slurm services
slurm-devel-18.08.5-2.1.i586.rpm Development package for SLURM
slurm-devel-18.08.5-2.1.x86_64.rpm Development package for SLURM
slurm-doc-18.08.5-2.1.i586.rpm Documentation for SLURM
slurm-doc-18.08.5-2.1.x86_64.rpm Documentation for SLURM
Advertisement
Advertisement