saxpath-1.0_FCS-32.1.noarch.rpm


Advertisement

Description

saxpath - SAXPath is an event-based API for XPath parsers

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename saxpath-1.0_FCS-32.1.noarch.rpm
Package name saxpath
Package version 1.0_FCS
Package release 32.1
Package architecture noarch
Package type rpm
Category Development/Libraries/Java
Homepage http://www.jdom.org
License Apache-2.0
Maintainer -
Download size 30.72 KB
Installed size 24.53 KB
SAXPath is an event-based API for XPath parsers, that is, for parsers
which parse XPath  expressions. SAXPath is intended to be for XPath
what SAX is for XML. Note that the SAXPath package only parses XPath
expressions; it does not evaluate them, or even provide an object
structure for representing them once they have been parsed.

Alternatives

Package Version Architecture Repository
saxpath-1.0_FCS-69.2.noarch.rpm 1.0_FCS noarch JAVA
saxpath - - -

Requires

Name Value
java-headless -
javapackages-filesystem -

Provides

Name Value
mvn(saxpath:saxpath) = 1.0.FCS
mvn(saxpath:saxpath:pom:) = 1.0.FCS
saxpath = 1.0_FCS-32.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package saxpath-1.0_FCS-32.1.noarch.rpm
Source Package jdom-1.1.3-32.1.src.rpm

Install Howto

Install saxpath rpm package:

# zypper install saxpath

Files

Path
/usr/share/java/saxpath-1.0.jar
/usr/share/java/saxpath.jar
/usr/share/maven-metadata/jdom-saxpath.xml
/usr/share/maven-poms/saxpath-1.0.pom

Changelog

2019-03-26 - Fridrich Strba <fstrba@suse.com>
- Upgrade the jdom component to 1.1.3
- Modified patch:
* jdom-1.1-build.xml.patch
+ Remove unneeded hunk
- Added patch:
* jdom-1.1-OSGiManifest.patch
+ Make jdom an OSGi bundle
2018-11-20 - Fridrich Strba <fstrba@suse.com>
- Removed patch:
* include-glibj.jar.patch
+ The build works since ages without glibj being present, so
removing any trace of it
2018-11-20 - Fridrich Strba <fstrba@suse.com>
- Add maven pom files for the distributed jars
- Speed-up build by filtering out the failing files beforehand
and then building all with one javac invocation
2017-09-29 - fstrba@suse.com
- Fix build with jdk9: specify java source and target level 1.6
- Modified patch:
* jdom-1.1-build.xml.patch
+ specify java source and target level 1.6
- Add more BuildRequires, in order to build more java files in
stage 1
2017-09-14 - fstrba@suse.com
- Build with javac whose syntax is compatible with OpenJDK
2017-05-19 - tchvatal@suse.com
- Expand the buildignore lines for newer jdk
2015-03-31 - tchvatal@suse.com
- Provide and obsolete jaxen-bootstrap to avoid file conflict
2015-03-24 - tchvatal@suse.com
- Fix namespace clash with javapackages-tools on variables
2015-03-24 - tchvatal@suse.com
- Cleanup with spec-cleaner and add debug output
2012-06-15 - mvyskocil@suse.cz
- ignore jdk7 as well

See Also

Package Description
sazanami-fonts-20040629-212.14.noarch.rpm Japanese "Sazanami" TrueType Fonts
sbc-1.4-1.2.i586.rpm Bluetooth Low-Complexity, Sub-Band Codec Utilities
sbc-1.4-1.2.x86_64.rpm Bluetooth Low-Complexity, Sub-Band Codec Utilities
sbc-devel-1.4-1.2.i586.rpm Development files for libsbc1
sbc-devel-1.4-1.2.x86_64.rpm Development files for libsbc1
sbcl-1.4.7-1.4.i586.rpm Steel Bank Common Lisp
sbcl-1.4.7-1.4.x86_64.rpm Steel Bank Common Lisp
sbd-1.4.0+20190326.c38c5e6-1.1.i586.rpm Storage-based death
sbd-1.4.0+20190326.c38c5e6-1.1.x86_64.rpm Storage-based death
sbiload-0.4.0-17.1.i586.rpm OPL2/3 FM instrument loader
sbiload-0.4.0-17.1.x86_64.rpm OPL2/3 FM instrument loader
sbl-3.5.0.20130317.git7a75bc29-4.1.i586.rpm Screen reader for the Linux console
sbl-3.5.0.20130317.git7a75bc29-4.1.x86_64.rpm Screen reader for the Linux console
sbl-orca-3.5.0.20130317.git7a75bc29-4.1.i586.rpm brld-orca brlapi
sbl-orca-3.5.0.20130317.git7a75bc29-4.1.x86_64.rpm brld-orca brlapi
Advertisement
Advertisement