rubygem-passenger-6.0.1-1.4.i586.rpm


Advertisement

Description

rubygem-passenger - A fast and robust web server and application server for Ruby, Python

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename rubygem-passenger-6.0.1-1.4.i586.rpm
Package name rubygem-passenger
Package version 6.0.1
Package release 1.4
Package architecture i586
Package type rpm
Category Development/Languages/Ruby
Homepage https://www.phusionpassenger.com/
License MIT AND GPL-2.0-only
Maintainer -
Download size 1.72 MB
Installed size 6.90 MB
A modern web server and application server for Ruby, Python and Node.js,
optimized for performance, low memory usage and ease of use.

Alternatives

Package Version Architecture Repository
rubygem-passenger-6.0.1-1.4.x86_64.rpm 6.0.1 x86_64 openSUSE Oss
rubygem-passenger - - -

Requires

Name Value
/usr/bin/node -
/usr/bin/ruby -
libc.so.6(GLIBC_2.28) -
libcrypto.so.1.1 -
libcrypto.so.1.1(OPENSSL_1_1_0) -
libcurl.so.4 -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GLIBC_2.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.2) -
libpthread.so.0(GLIBC_2.3.2) -
libpthread.so.0(GLIBC_2.3.3) -
libpthread.so.0(GLIBC_2.3.4) -
librt.so.1 -
librt.so.1(GLIBC_2.2) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.8) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.14) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.18) -
libstdc++.so.6(GLIBCXX_3.4.19) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.9) -
rubygem(passenger) = 6.0.1
update-alternatives -

Provides

Name Value
config(rubygem-passenger) = 6.0.1-1.4
rubygem-passenger = 6.0.1-1.4
rubygem-passenger(x86-32) = 6.0.1-1.4

Download

Type URL
Mirror widehat.opensuse.org
Binary Package rubygem-passenger-6.0.1-1.4.i586.rpm
Source Package rubygem-passenger-6.0.1-1.4.src.rpm

Install Howto

Install rubygem-passenger rpm package:

# zypper install rubygem-passenger

Files

Path
/etc/passenger/locations.ini
/usr/lib/passenger/
/usr/lib/passenger/6.0.1/
/usr/lib/passenger/6.0.1/bin/passenger
/usr/lib/passenger/6.0.1/bin/passenger-config
/usr/lib/passenger/6.0.1/bin/passenger-install-apache2-module
/usr/lib/passenger/6.0.1/bin/passenger-install-nginx-module
/usr/lib/passenger/6.0.1/bin/passenger-memory-stats
/usr/lib/passenger/6.0.1/bin/passenger-status
/usr/lib/passenger/6.0.1/buildout/
/usr/lib/passenger/6.0.1/helper-scripts/README.md
/usr/lib/passenger/6.0.1/helper-scripts/backtrace-sanitizer.rb
/usr/lib/passenger/6.0.1/helper-scripts/crash-watch.rb
/usr/lib/passenger/6.0.1/helper-scripts/meteor-loader.rb
/usr/lib/passenger/6.0.1/helper-scripts/node-loader.js
/usr/lib/passenger/6.0.1/helper-scripts/prespawn
/usr/lib/passenger/6.0.1/helper-scripts/rack-loader.rb
/usr/lib/passenger/6.0.1/helper-scripts/rack-preloader.rb
/usr/lib/passenger/6.0.1/helper-scripts/wsgi-loader.py
/usr/lib/passenger/6.0.1/helper-scripts/download_binaries/extconf.rb
/usr/lib/passenger/6.0.1/nodejs_supportlib/
/usr/lib/passenger/6.0.1/nodejs_supportlib/phusion_passenger/line_reader.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/codify/codify.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/codify/package.json
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/context.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/package.json
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/async-listener/glue.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/async-listener/index.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/async-listener/package.json
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/async-listener/node_modules/
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/async-listener/node_modules/shimmer/index.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/async-listener/node_modules/shimmer/package.json
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/emitter-listener/listener.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/emitter-listener/package.json
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/emitter-listener/node_modules/
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/emitter-listener/node_modules/shimmer/index.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/emitter-listener/node_modules/shimmer/package.json
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/network-byte-order/package.json
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/network-byte-order/lib/index.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/LICENSE
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/package.json
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/common.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/config.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/container.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/exception.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/logger.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/transports.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/config/cli-config.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/config/npm-config.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/config/syslog-config.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/transports/console.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/transports/daily-rotate-file.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/transports/file.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/transports/http.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/transports/memory.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/transports/transport.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/transports/webhook.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/async/LICENSE
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/async/package.json
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/async/lib/async.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/async/support/sync-package-managers.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/MIT-LICENSE.txt
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/package.json
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/safe.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/colors.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/extendStringPrototype.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/index.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/styles.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/custom/trap.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/custom/zalgo.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/maps/america.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/maps/rainbow.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/maps/random.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/maps/zebra.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/system/supports-colors.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/themes/generic-logging.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/cycle/cycle.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/cycle/package.json
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/eyes/LICENSE
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/eyes/package.json
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/eyes/lib/eyes.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/isstream/LICENSE.md
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/isstream/isstream.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/isstream/package.json
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/pkginfo/LICENSE
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/pkginfo/package.json
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/pkginfo/lib/pkginfo.js
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/stack-trace/License
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/stack-trace/package.json
/usr/lib/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/stack-trace/lib/stack-trace.js
/usr/lib/passenger/6.0.1/resources/mime.types
/usr/lib/passenger/6.0.1/resources/release.txt
/usr/lib/passenger/6.0.1/resources/union_station_gateway.crt
/usr/lib/passenger/6.0.1/resources/update_check_client_cert.p12
/usr/lib/passenger/6.0.1/resources/update_check_client_cert.pem
/usr/lib/passenger/6.0.1/resources/update_check_server_pubkey.pem
/usr/lib/passenger/6.0.1/resources/standalone_default_root/index.html
/usr/lib/passenger/6.0.1/resources/templates/
/usr/lib/passenger/6.0.1/resources/templates/apache2/apache_install_broken.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/apache2/apache_must_be_compiled_with_compatible_mpm.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/apache2/config_snippets.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/apache2/deployment_example.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/apache2/installing_against_a_different_apache.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/apache2/mpm_unknown.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/apache2/multiple_apache_installations_detected.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/apache2/notify_apache_module_installed.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/apache2/possible_solutions_for_compilation_and_installation_problems.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/apache2/present_choice_for_no_update_config.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/apache2/rpm_installation_recommended.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/apache2/run_installer_as_root_for_apache_analysis.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/apache2/welcome.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/config/
/usr/lib/passenger/6.0.1/resources/templates/config/agent_compiler/confirm_enable_optimizations.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/config/installation_utils/cannot_create_user_support_binaries_dir.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/config/installation_utils/download_tool_missing.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/config/installation_utils/passenger_not_installed_as_root.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/config/installation_utils/support_binaries_dir_not_writable_despite_running_as_root.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/config/installation_utils/unexpected_filesystem_problem.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/config/installation_utils/user_support_binaries_dir_not_writable.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/config/nginx_engine_compiler/possible_solutions_for_download_and_extraction_problems.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/README.md
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/webpack.config.js
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/dist/bundle.js
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/dist/styles.css
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/DetailsView.jsx
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/GetHelpView.jsx
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/JourneyView.css
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/JourneyView.jsx
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/PageMain.css
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/PageMain.jsx
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/ProblemDescriptionView.jsx
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/ProcessDetailsView.jsx
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/SolutionDescriptionView.css
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/SolutionDescriptionView.jsx
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/SummaryView.jsx
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/SystemComponentView.css
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/SystemComponentView.jsx
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/SystemComponentsView.css
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/SystemComponentsView.jsx
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/Tab.jsx
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/Tabs.jsx
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/index.html.template
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/index.jsx
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/bootstrap/bootstrap.css
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/bootstrap/bootstrap.js
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/with_details/src/bootstrap/config.json
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/without_details/webpack.config.js
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/without_details/dist/bundle.js
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/without_details/dist/styles.css
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/without_details/src/index.html.template
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/without_details/src/index.js
/usr/lib/passenger/6.0.1/resources/templates/error_renderer/without_details/src/main.css
/usr/lib/passenger/6.0.1/resources/templates/installer_common/cannot_access_files_as_root.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/installer_common/gem_install_permission_problems.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/installer_common/low_amount_of_memory_warning.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/installer_common/run_installer_as_root.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/installer_common/world_inaccessible_directories.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/nginx/ask_for_extra_configure_flags.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/nginx/cannot_write_to_dir.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/nginx/config_snippets.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/nginx/config_snippets_inserted.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/nginx/confirm_extra_configure_flags.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/nginx/deployment_example.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/nginx/nginx_module_sources_not_available.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/nginx/other_nginx_installations_exist.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/nginx/pcre_checksum_could_not_be_verified.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/nginx/pcre_could_not_be_downloaded.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/nginx/pcre_could_not_be_extracted.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/nginx/possible_solutions_for_compilation_and_installation_problems.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/nginx/possible_solutions_for_download_and_extraction_problems.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/nginx/query_download_and_install.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/nginx/welcome.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/standalone/cannot_write_to_dir.txt.erb
/usr/lib/passenger/6.0.1/resources/templates/standalone/config.erb
/usr/lib/passenger/6.0.1/resources/templates/standalone/footer.erb
/usr/lib/passenger/6.0.1/resources/templates/standalone/global.erb
/usr/lib/passenger/6.0.1/resources/templates/standalone/http.erb
/usr/lib/passenger/6.0.1/resources/templates/standalone/mass_deployment_default_server.erb
/usr/lib/passenger/6.0.1/resources/templates/standalone/rails_asset_pipeline.erb
/usr/lib/passenger/6.0.1/resources/templates/standalone/server.erb
/usr/lib/passenger/6.0.1/src/
/usr/lib/passenger/6.0.1/support-binaries/PassengerAgent
/usr/lib/tmpfiles.d/passenger.conf

Changelog

2019-01-14 - mschnitzer@suse.com
- updated to version 6.0.1 (boo#1121748)
* Adds Ubuntu 18.10 "Cosmic" packages.
* Skips trying to set oom score in LXC container environments.
Closes GH-2143.
* Fixes an issue during the GLS startup handshake where ephemeral
ports could be exhausted. Closes GH-2144.
* Updated Ruby versions used in precompiled binaries (used for
e.g. gem installs) to include 2.5.3, and 2.4.5 (removed: 2.4.4).
* Bumps the preferred Nginx version to 1.15.8.
* Updated various library versions used in precompiled binaries
(used for e.g. gem installs):
- Curl: 7.62.0 -> 7.63.0
- Git: 2.19.2 -> 2.20.1
- Gnupg: 2.2.11 -> 2.2.12
- libassuan: 2.5.1 -> 2.5.2
- libgpg_error: 1.32 -> 1.33
- Ruby: 2.4.4 -> 2.4.5, + 2.5.3
- RubyGems: 2.7.6 -> 3.0.1
2018-11-30 - mschnitzer@suse.com
- updated to version 6.0.0 (boo#1117900)
* Introduces support for *all* programming languages. Yes that's
right... Java, Elixir, Go ? Passenger now supports them all!
This effort is called "generic language support".
* Bumps the preferred Nginx version to 1.15.7.
* Introduces anonymous usage telemetry, which helps us improve
Passenger. Please read the docs on what data is collected and
how to disable this.
* [Nginx] Introduces a new option "passenger_request_buffering on|off",
to allow disabling request body buffering. This is only supported
in Nginx >= 1.15.3. Closes GH-2121.
* Updated various library versions used in precompiled binaries
(used for e.g. gem installs):
- OpenSSL: 1.0.2q (was: 1.0.2p)
- libcurl: 7.62.0 (was: 7.61.1)
- Ruby: 2.3.8 (was: 2.3.7)
2018-11-11 - mschnitzer@suse.com
- updated to version 5.3.7 (boo#1115545)
* Fixes package installation issues on Ubuntu 18.04. These issues
were caused by an update released by Ubuntu on the nginx-common
package. Closes GH-2122, GH-2140.
* Fixes compilation problems and warnings with GCC 8.2. Tested on
Alpine Linux edge 2018-11-05. Closes GH-2139.
* Fixes compatibility with libcurl 7.62.0. Contributed by
Po-Chuan Hsieh (@sunpoet).
* Changes minimum supported macOS version to 10.11 El Capitan.
* Removes packages for Ubuntu 17.10 Artful.
2018-11-05 - mschnitzer@suse.com
- updated to version 5.3.6 (boo#1114735)
* Fixes smart spawning. A regression in 5.3.5 (due to a refactoring) made it so that Passenger only used the direct spawning method. This issue was mostly noticeable in the form of increased process spawning times between 5.3.4 and 5.3.5.
* Fixes Passenger Core and application processes staying on the Watchdog's OOM score (unkillable). Closes GH-2105.
* Fixes "mach_vm_map failed" warnings on macOS >= High Sierra. These warnings were harmless, but annoying. Closes GH-2101.
* Fixes `passenger-config compile-agent` compilation with optimizations. The optimization flags were not properly passed to the compiler.
* Fixes a crash that could occur when HTTP clients send a chunked transfer-encoding body containing a chunk larger than 429496729 bytes.
* Improves detection of the system Apache's include headers on macOS High Sierra and later.
* Fixes RVM gemset detection on RVM 1.29.
* No longer supplies precompiled Ruby extensions for Ruby 1.9.3 and 2.0.0. When running Ruby 1.9.3 and 2.0.0, Passenger will attempt to compile from source instead.
- changed suse.patch to apply again
- changed fix_shebangs.patch to apply again

See Also

Package Description
rubygem-passenger-apache2-6.0.1-1.4.i586.rpm Passenger apache module
rubygem-passenger-apache2-6.0.1-1.4.x86_64.rpm Passenger apache module
rubygem-passenger-nginx-6.0.1-1.4.i586.rpm Passenger Nginx module
rubygem-passenger-nginx-6.0.1-1.4.x86_64.rpm Passenger Nginx module
rubygem-rice-1.7.0-1.19.i586.rpm Your swiss army knife for executing external commands in Ruby safely
rubygem-rice-1.7.0-1.19.x86_64.rpm Your swiss army knife for executing external commands in Ruby safely
rubygem-rice-doc-1.7.0-1.19.i586.rpm RDoc documentation for rice
rubygem-rice-doc-1.7.0-1.19.x86_64.rpm RDoc documentation for rice
rubygem-ruby-fcgi-0.8.9-10.22.i586.rpm FastCGI library for Ruby
rubygem-ruby-fcgi-0.8.9-10.22.x86_64.rpm FastCGI library for Ruby
rubygem-ruby-fcgi-doc-0.8.9-10.22.i586.rpm RDoc documentation for ruby-fcgi
rubygem-ruby-fcgi-doc-0.8.9-10.22.x86_64.rpm RDoc documentation for ruby-fcgi
rubygem-ruby-fcgi-testsuite-0.8.9-10.22.i586.rpm Test suite for ruby-fcgi
rubygem-ruby-fcgi-testsuite-0.8.9-10.22.x86_64.rpm Test suite for ruby-fcgi
rubygem-sexp_processor-3_2-3.2.0-9.15.i586.rpm sexp_processor branches from ParseTree bringing all the generic sexp processing tools with it
Advertisement
Advertisement