ruby2.6-rubygem-unicorn-doc-5.5.0-1.1.i586.rpm


Advertisement

Description

ruby2.6-rubygem-unicorn-doc - RDoc documentation for unicorn

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ruby2.6-rubygem-unicorn-doc-5.5.0-1.1.i586.rpm
Package name ruby2.6-rubygem-unicorn-doc
Package version 5.5.0
Package release 1.1
Package architecture i586
Package type rpm
Category Development/Languages/Ruby
Homepage https://bogomips.org/unicorn/
License GPL-2.0-only OR GPL-3.0-only OR Ruby
Maintainer -
Download size 62.28 KB
Installed size 63.79 KB
Documentation generated at gem installation time.
Usually in RDoc and RI formats.

Alternatives

Package Version Architecture Repository
ruby2.6-rubygem-unicorn-doc-5.5.0-1.1.x86_64.rpm 5.5.0 x86_64 openSUSE Oss
ruby2.6-rubygem-unicorn-doc - - -

Requires

Name Value
ruby2.6-rubygem-unicorn = 5.5.0

Provides

Name Value
ruby2.6-rubygem-unicorn-doc = 5.5.0-1.1
ruby2.6-rubygem-unicorn-doc(x86-32) = 5.5.0-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ruby2.6-rubygem-unicorn-doc-5.5.0-1.1.i586.rpm
Source Package rubygem-unicorn-5.5.0-1.1.src.rpm

Install Howto

Install ruby2.6-rubygem-unicorn-doc rpm package:

# zypper install ruby2.6-rubygem-unicorn-doc

Files

Path
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/cache.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/cdesc-Unicorn.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/after_fork-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/after_worker_exit-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/after_worker_ready-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/before_exec-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/before_fork-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/canonicalize_tcp-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/cdesc-Configurator.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/check_client_connection-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/client_body_buffer_size-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/default_middleware-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/listen-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/logger-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/pid-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/preload_app-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/rewindable_input-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/stderr_path-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/stdout_path-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/timeout-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/user-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/worker_exec-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/worker_processes-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Configurator/working_directory-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Const/cdesc-Const.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpParser/add_parse-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpParser/body_eof%3f-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpParser/buf-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpParser/cdesc-HttpParser.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpParser/clear-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpParser/content_length-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpParser/env-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpParser/filter_body-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpParser/headers%3f-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpParser/headers-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpParser/hijacked%21-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpParser/keepalive%3f-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpParser/max_header_len%3d-c.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpParser/new-c.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpParser/next%3f-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpParser/parse-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpParser/response_start_sent%3d-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpParser/response_start_sent-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpParser/trailers-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpParserError/cdesc-HttpParserError.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpResponse/cdesc-HttpResponse.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpResponse/httpdate-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/HttpServer/cdesc-HttpServer.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/OobGC/cdesc-OobGC.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/OobGC/new-c.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/PrereadInput/cdesc-PrereadInput.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/RequestEntityTooLargeError/cdesc-RequestEntityTooLargeError.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/RequestURITooLongError/cdesc-RequestURITooLongError.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/StreamInput/cdesc-StreamInput.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/StreamInput/each-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/StreamInput/eof%21-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/StreamInput/eof%3f-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/StreamInput/filter_body-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/StreamInput/gets-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/StreamInput/read-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/StreamInput/read_all-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/TeeInput/cdesc-TeeInput.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/TeeInput/consume%21-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/TeeInput/gets-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/TeeInput/read-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/TeeInput/rewind-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/TeeInput/size-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/TeeInput/tee-i.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/TmpIO/cdesc-TmpIO.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/TmpIO/new-c.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Util/cdesc-Util.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Util/reopen_logs-c.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Worker/cdesc-Worker.ri
/usr/lib/ruby/gems/2.6.0/doc/unicorn-5.5.0/ri/Unicorn/Worker/user-i.ri

Changelog

2019-03-14 - Stephan Kulow <coolo@suse.com>
- updated to version 5.5.0
see installed NEWS
=== unicorn 5.5.0.pre1 / 2018-12-20 20:11 UTC
Jeremy Evans contributed the "default_middleware" configuration option:
https://bogomips.org/unicorn-public/20180913192055.GD48926@jeremyevans.local/
Jeremy also contributed the ability to use separate groups for the process
and log files:
https://bogomips.org/unicorn-public/20180913192449.GE48926@jeremyevans.local/
There's also a couple of uninteresting minor optimizations and
documentation additions.
Eric Wong (10):
remove random seed reset atfork
use IO#wait instead of kgio_wait_readable
Merge branch '5.4-stable'
shrink pipes under Linux
socket_helper: add hint for FreeBSD users for accf_http(9)
tests: ensure -N/--no-default-middleware not supported in config.ru
doc: update more URLs to use HTTPS and avoid redirects
deduplicate strings VM-wide in Ruby 2.5+
doc/ISSUES: add links to git clone-able mail archives of our dependencies
README: minor updates and additional disclaimer
Jeremy Evans (2):
Make Worker#user support different process primary group and log file group
Support default_middleware configuration option
=== unicorn 5.4.1 / 2018-07-23 17:13 UTC
This release quiets some warnings for Ruby 2.6 preview releases
and enables tests to pass under Ruby 1.9.3.  Otherwise, nothing
interesting for Ruby 2.0..2.5 users.  *YAWN*
Eric Wong (1):
quiet some mismatched indentation warnings
Fumiaki MATSUSHIMA (1):
Use IO#wait instead to fix test for Ruby 1.9
2018-09-05 - coolo@suse.com
- updated to version 5.4.1
see installed NEWS
=== unicorn 5.4.0 / 2017-12-23 23:33 UTC
Rack hijack support improves as the app code can capture and use
the Rack `env' privately without copying it (to avoid clobbering
by another client).  Thanks to Sam Saffron for reporting and
testing this new feature:
https://bogomips.org/unicorn-public/CAAtdryPG3nLuyo0jxfYW1YHu1Q+ZpkLkd4KdWC8vA46B5haZxw@mail.gmail.com/T/
We also now support $DEBUG being set by the Rack app (instead of
relying on the "-d" CLI switch).  Thanks to James P Robinson Jr
for reporting this bug:
https://bogomips.org/unicorn-public/D6324CB4.7BC3E%25james.robinson3@cigna.com/T/
(Coincidentally, this fix will be irrelevant for Ruby 2.5
which requires 'pp' by default)
There's a few minor test cleanups and documentation updates, too.
All commits since v5.3.1 (2017-10-03):
reduce method calls with String#start_with?
require 'pp' if $DEBUG is set by Rack app
avoid reusing env on hijack
tests: cleanup some unused variable warnings
ISSUES: add a note about Debian BTS interopability
Roughly all mailing discussions since the last release:
https://bogomips.org/unicorn-public/?q=d:20171004..20171223
2018-02-27 - factory-auto@kulow.org
- updated to version 5.4.0
see installed NEWS
=== unicorn 5.3.1 / 2017-10-03 19:03 UTC
This release fixes an occasional GC problem introduced in v5.3.0
to reduce global variable overhead (commit 979ebcf91705709b)
Thanks to Xuanzhong Wei for the patch which lead to this release:
https://bogomips.org/unicorn-public/20171003182054.76392-1-azrlew@gmail.com/T/#u
https://bogomips.org/unicorn-public/20171003145718.30404-1-azrlew@gmail.com/T/#u
Xuanzhong Wei (1):
fix GC issue on rb_global_variable array

See Also

Package Description
ruby2.6-rubygem-unicorn-testsuite-5.5.0-1.1.i586.rpm Test suite for unicorn
ruby2.6-rubygem-unicorn-testsuite-5.5.0-1.1.x86_64.rpm Test suite for unicorn
ruby2.6-rubygem-unicorn-worker-killer-0.4.4-1.7.i586.rpm Kill unicorn workers by memory and request counts
ruby2.6-rubygem-unicorn-worker-killer-0.4.4-1.7.x86_64.rpm Kill unicorn workers by memory and request counts
ruby2.6-rubygem-unicorn-worker-killer-doc-0.4.4-1.7.i586.rpm RDoc documentation for unicorn-worker-killer
ruby2.6-rubygem-unicorn-worker-killer-doc-0.4.4-1.7.x86_64.rpm RDoc documentation for unicorn-worker-killer
ruby2.6-rubygem-url_safe_base64-0.2.2-1.5.i586.rpm Converts strings to/from a slightly modified base64 that contains
ruby2.6-rubygem-url_safe_base64-0.2.2-1.5.x86_64.rpm Converts strings to/from a slightly modified base64 that contains
ruby2.6-rubygem-url_safe_base64-doc-0.2.2-1.5.i586.rpm RDoc documentation for url_safe_base64
ruby2.6-rubygem-url_safe_base64-doc-0.2.2-1.5.x86_64.rpm RDoc documentation for url_safe_base64
ruby2.6-rubygem-url_safe_base64-testsuite-0.2.2-1.5.i586.rpm Test suite for url_safe_base64
ruby2.6-rubygem-url_safe_base64-testsuite-0.2.2-1.5.x86_64.rpm Test suite for url_safe_base64
ruby2.6-rubygem-vagrant-spec-0.0.1.abfc344.git-1.1.i586.rpm Tool and library for testing Vagrant plugins
ruby2.6-rubygem-vagrant-spec-0.0.1.abfc344.git-1.1.x86_64.rpm Tool and library for testing Vagrant plugins
ruby2.6-rubygem-vagrant-spec-doc-0.0.1.abfc344.git-1.1.i586.rpm RDoc documentation for vagrant-spec
Advertisement
Advertisement