ruby2.6-rubygem-trollop-testsuite-2.9.9-1.3.i586.rpm


Advertisement

Description

ruby2.6-rubygem-trollop-testsuite - Test suite for trollop

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ruby2.6-rubygem-trollop-testsuite-2.9.9-1.3.i586.rpm
Package name ruby2.6-rubygem-trollop-testsuite
Package version 2.9.9
Package release 1.3
Package architecture i586
Package type rpm
Category Development/Languages/Ruby
Homepage http://manageiq.github.io/optimist/
License Ruby
Maintainer -
Download size 19.40 KB
Installed size 50.68 KB
Test::Unit or RSpec files, useful for developers.

Alternatives

Package Version Architecture Repository
ruby2.6-rubygem-trollop-testsuite-2.9.9-1.3.x86_64.rpm 2.9.9 x86_64 openSUSE Oss
ruby2.6-rubygem-trollop-testsuite - - -

Requires

Name Value
ruby2.6-rubygem-trollop = 2.9.9

Provides

Name Value
ruby2.6-rubygem-trollop-testsuite = 2.9.9-1.3
ruby2.6-rubygem-trollop-testsuite(x86-32) = 2.9.9-1.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ruby2.6-rubygem-trollop-testsuite-2.9.9-1.3.i586.rpm
Source Package rubygem-trollop-2.9.9-1.3.src.rpm

Install Howto

Install ruby2.6-rubygem-trollop-testsuite rpm package:

# zypper install ruby2.6-rubygem-trollop-testsuite

Files

Path
/usr/lib/ruby/gems/2.6.0/gems/trollop-2.9.9/test/test_helper.rb
/usr/lib/ruby/gems/2.6.0/gems/trollop-2.9.9/test/trollop_test.rb
/usr/lib/ruby/gems/2.6.0/gems/trollop-2.9.9/test/support/assert_helpers.rb
/usr/lib/ruby/gems/2.6.0/gems/trollop-2.9.9/test/trollop/command_line_error_test.rb
/usr/lib/ruby/gems/2.6.0/gems/trollop-2.9.9/test/trollop/help_needed_test.rb
/usr/lib/ruby/gems/2.6.0/gems/trollop-2.9.9/test/trollop/parser_educate_test.rb
/usr/lib/ruby/gems/2.6.0/gems/trollop-2.9.9/test/trollop/parser_opt_test.rb
/usr/lib/ruby/gems/2.6.0/gems/trollop-2.9.9/test/trollop/parser_parse_test.rb
/usr/lib/ruby/gems/2.6.0/gems/trollop-2.9.9/test/trollop/parser_test.rb
/usr/lib/ruby/gems/2.6.0/gems/trollop-2.9.9/test/trollop/version_needed_test.rb

Changelog

2018-09-05 - coolo@suse.com
- updated to version 2.9.9
see installed History.txt
== [2.9.9] / 2018-08-49
* [DEPRECATION] This gem has been renamed to optimist and will no longer be supported. Please switch to optimist as soon as possible.
2018-07-12 - factory-auto@kulow.org
- updated to version 2.1.3
see installed History.txt
2018-07-11 - factory-auto@kulow.org
- updated to version 2.1.3
see installed History.txt
2015-05-28 - tampakrap@opensuse.org
- Fix license to Ruby as requested by babelworx on SR#307272
2015-03-11 - coolo@suse.com
- updated to version 2.1.2
2015-02-09 - coolo@suse.com
- updated to version 2.1.1
* Remove curses as a hard dependency. It is optional. This can leverage the gem if it is present.
* Fix ruby -w warnings
== 2.1.0 / 2015-01-02
* Integer parser now supports underscore separator.
* Add Parser#usage and Parser#synopsis commands for creating a standard banner
message. Using Parser#banner directly will override both of those.
* Add Parser#ignore_invalid_options to prevent erroring on unknown options.
* Allow flags to act as switches if they have defaults set and no value is
passed on the commandline
* Parser#opt learned to accept a block or a :callback option which it will call
after parsing the option.
* Add Trollop::educate which displays the help message and dies.
* Reformat help message to be more GNUish.
* Fix command name in help message when script has no extension.
* Fix handling of newlines inside descriptions
* Documentation and other fixes.
2012-08-26 - coolo@suse.com
- updated to version 2.0
* Change flag logic: --no-X will always be false, and --X will always be true,
regardless of default.
* For flags that default to true, display --no-X instead of --X in the help
menu. Accept both versions on the commandline.
* Fix a spurious warning
* Update Rakefile to 1.9
* Minor documentation fixes
2010-06-14 - mrueckert@suse.de
- update to version 1.16.2
* Bugfix in Trollop::options. Thanks to Brian C. Thomas for
pointing it out.
- additional changes from version 1.16.1
* Bugfix in Trollop::die method introduced in last release.
- additional changes from version 1.16
* Add Trollop::with_standard_exception_handling method for easing
the use of Parser directly.
* Handle scientific notation in float arguments,
thanks to Will Fitzgerald.
* Drop hoe dependency.
2010-06-11 - mrueckert@suse.de
- use rubygems_requires macro
2010-02-16 - dmacvicar@novell.com
- initial package for 1.15

See Also

Package Description
ruby2.6-rubygem-turbolinks-5.2.0-1.3.i586.rpm Turbolinks makes navigating your web application faster
ruby2.6-rubygem-turbolinks-5.2.0-1.3.x86_64.rpm Turbolinks makes navigating your web application faster
ruby2.6-rubygem-turbolinks-doc-5.2.0-1.3.i586.rpm RDoc documentation for turbolinks
ruby2.6-rubygem-turbolinks-doc-5.2.0-1.3.x86_64.rpm RDoc documentation for turbolinks
ruby2.6-rubygem-turbolinks-source-5.2.0-1.3.i586.rpm Turbolinks JavaScript assets
ruby2.6-rubygem-turbolinks-source-5.2.0-1.3.x86_64.rpm Turbolinks JavaScript assets
ruby2.6-rubygem-turbolinks-source-doc-5.2.0-1.3.i586.rpm RDoc documentation for turbolinks-source
ruby2.6-rubygem-turbolinks-source-doc-5.2.0-1.3.x86_64.rpm RDoc documentation for turbolinks-source
ruby2.6-rubygem-tzinfo-0-0.3.55-1.3.i586.rpm Daylight-savings aware timezone library
ruby2.6-rubygem-tzinfo-0-0.3.55-1.3.x86_64.rpm Daylight-savings aware timezone library
ruby2.6-rubygem-tzinfo-1.2-1.2.5-1.2.i586.rpm Daylight savings aware timezone library
ruby2.6-rubygem-tzinfo-1.2-1.2.5-1.2.x86_64.rpm Daylight savings aware timezone library
ruby2.6-rubygem-tzinfo-2.0.0-1.3.i586.rpm Time Zone Library
ruby2.6-rubygem-tzinfo-2.0.0-1.3.x86_64.rpm Time Zone Library
ruby2.6-rubygem-tzinfo-data-1.2019.1-1.1.i586.rpm Timezone Data for TZInfo
Advertisement
Advertisement