ruby2.6-rubygem-trollop-doc-2.9.9-1.3.i586.rpm


Advertisement

Description

ruby2.6-rubygem-trollop-doc - RDoc documentation for trollop

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ruby2.6-rubygem-trollop-doc-2.9.9-1.3.i586.rpm
Package name ruby2.6-rubygem-trollop-doc
Package version 2.9.9
Package release 1.3
Package architecture i586
Package type rpm
Category Development/Languages/Ruby
Homepage http://manageiq.github.io/optimist/
License Ruby
Maintainer -
Download size 35.59 KB
Installed size 51.81 KB
Documentation generated at gem installation time.
Usually in RDoc and RI formats.

Alternatives

Package Version Architecture Repository
ruby2.6-rubygem-trollop-doc-2.9.9-1.3.x86_64.rpm 2.9.9 x86_64 openSUSE Oss
ruby2.6-rubygem-trollop-doc - - -

Requires

Name Value
ruby2.6-rubygem-trollop = 2.9.9

Provides

Name Value
ruby2.6-rubygem-trollop-doc = 2.9.9-1.3
ruby2.6-rubygem-trollop-doc(x86-32) = 2.9.9-1.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ruby2.6-rubygem-trollop-doc-2.9.9-1.3.i586.rpm
Source Package rubygem-trollop-2.9.9-1.3.src.rpm

Install Howto

Install ruby2.6-rubygem-trollop-doc rpm package:

# zypper install ruby2.6-rubygem-trollop-doc

Files

Path
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/cache.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/cdesc-Trollop.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/die-c.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/die-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/educate-c.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/educate-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/options-c.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/options-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/with_standard_exception_handling-c.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/with_standard_exception_handling-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/BooleanOption/cdesc-BooleanOption.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/BooleanOption/flag%3f-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/BooleanOption/new-c.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/BooleanOption/parse-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/CommandlineError/cdesc-CommandlineError.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/CommandlineError/error_code-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/CommandlineError/new-c.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/DateArrayOption/cdesc-DateArrayOption.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/DateArrayOption/multi_arg%3f-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/DateArrayOption/type_format-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/DateOption/cdesc-DateOption.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/DateOption/parse-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/DateOption/type_format-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/FloatArrayOption/cdesc-FloatArrayOption.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/FloatArrayOption/multi_arg%3f-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/FloatArrayOption/type_format-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/FloatOption/cdesc-FloatOption.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/FloatOption/parse-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/FloatOption/type_format-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/HelpNeeded/cdesc-HelpNeeded.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/IOArrayOption/cdesc-IOArrayOption.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/IOArrayOption/multi_arg%3f-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/IOArrayOption/type_format-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/IOOption/cdesc-IOOption.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/IOOption/parse-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/IOOption/type_format-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/IntegerArrayOption/cdesc-IntegerArrayOption.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/IntegerArrayOption/multi_arg%3f-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/IntegerArrayOption/type_format-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/IntegerOption/cdesc-IntegerOption.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/IntegerOption/parse-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/IntegerOption/type_format-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/array_default%3f-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/callback-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/cdesc-Option.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/create-c.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/default-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/desc-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/description_with_default-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/educate-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/flag%3f-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/get_klass_from_default-c.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/get_type_from_disdef-c.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/handle_long_opt-c.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/handle_short_opt-c.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/long-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/multi%3f-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/multi-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/multi_arg%3f-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/multi_given-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/name-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/new-c.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/opts%3d-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/opts-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/parse-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/register_alias-c.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/required%3f-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/short%3f-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/short-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/single_arg%3f-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Option/type_format-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/banner-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/cdesc-Parser.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/cloaker-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/collect_argument_parameters-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/conflicts-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/depends-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/die-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/each_arg-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/educate-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/educate_on_error-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/ignore_invalid_options-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/leftovers-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/legacy_width-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/new-c.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/opt-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/parse-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/register-c.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/registry_getopttype-c.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/resolve_default_short_options%21-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/specs-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/stop_on-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/stop_on_unknown-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/synopsis-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/text-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/usage-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/version-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/wrap_line-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/Parser/vals/cdesc-vals.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/StringArrayOption/cdesc-StringArrayOption.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/StringArrayOption/multi_arg%3f-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/StringArrayOption/type_format-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/StringOption/cdesc-StringOption.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/StringOption/parse-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/StringOption/type_format-i.ri
/usr/lib/ruby/gems/2.6.0/doc/trollop-2.9.9/ri/Trollop/VersionNeeded/cdesc-VersionNeeded.ri

Changelog

2018-09-05 - coolo@suse.com
- updated to version 2.9.9
see installed History.txt
== [2.9.9] / 2018-08-49
* [DEPRECATION] This gem has been renamed to optimist and will no longer be supported. Please switch to optimist as soon as possible.
2018-07-12 - factory-auto@kulow.org
- updated to version 2.1.3
see installed History.txt
2018-07-11 - factory-auto@kulow.org
- updated to version 2.1.3
see installed History.txt
2015-05-28 - tampakrap@opensuse.org
- Fix license to Ruby as requested by babelworx on SR#307272
2015-03-11 - coolo@suse.com
- updated to version 2.1.2
2015-02-09 - coolo@suse.com
- updated to version 2.1.1
* Remove curses as a hard dependency. It is optional. This can leverage the gem if it is present.
* Fix ruby -w warnings
== 2.1.0 / 2015-01-02
* Integer parser now supports underscore separator.
* Add Parser#usage and Parser#synopsis commands for creating a standard banner
message. Using Parser#banner directly will override both of those.
* Add Parser#ignore_invalid_options to prevent erroring on unknown options.
* Allow flags to act as switches if they have defaults set and no value is
passed on the commandline
* Parser#opt learned to accept a block or a :callback option which it will call
after parsing the option.
* Add Trollop::educate which displays the help message and dies.
* Reformat help message to be more GNUish.
* Fix command name in help message when script has no extension.
* Fix handling of newlines inside descriptions
* Documentation and other fixes.
2012-08-26 - coolo@suse.com
- updated to version 2.0
* Change flag logic: --no-X will always be false, and --X will always be true,
regardless of default.
* For flags that default to true, display --no-X instead of --X in the help
menu. Accept both versions on the commandline.
* Fix a spurious warning
* Update Rakefile to 1.9
* Minor documentation fixes
2010-06-14 - mrueckert@suse.de
- update to version 1.16.2
* Bugfix in Trollop::options. Thanks to Brian C. Thomas for
pointing it out.
- additional changes from version 1.16.1
* Bugfix in Trollop::die method introduced in last release.
- additional changes from version 1.16
* Add Trollop::with_standard_exception_handling method for easing
the use of Parser directly.
* Handle scientific notation in float arguments,
thanks to Will Fitzgerald.
* Drop hoe dependency.
2010-06-11 - mrueckert@suse.de
- use rubygems_requires macro
2010-02-16 - dmacvicar@novell.com
- initial package for 1.15

See Also

Package Description
ruby2.6-rubygem-trollop-testsuite-2.9.9-1.3.i586.rpm Test suite for trollop
ruby2.6-rubygem-trollop-testsuite-2.9.9-1.3.x86_64.rpm Test suite for trollop
ruby2.6-rubygem-turbolinks-5.2.0-1.3.i586.rpm Turbolinks makes navigating your web application faster
ruby2.6-rubygem-turbolinks-5.2.0-1.3.x86_64.rpm Turbolinks makes navigating your web application faster
ruby2.6-rubygem-turbolinks-doc-5.2.0-1.3.i586.rpm RDoc documentation for turbolinks
ruby2.6-rubygem-turbolinks-doc-5.2.0-1.3.x86_64.rpm RDoc documentation for turbolinks
ruby2.6-rubygem-turbolinks-source-5.2.0-1.3.i586.rpm Turbolinks JavaScript assets
ruby2.6-rubygem-turbolinks-source-5.2.0-1.3.x86_64.rpm Turbolinks JavaScript assets
ruby2.6-rubygem-turbolinks-source-doc-5.2.0-1.3.i586.rpm RDoc documentation for turbolinks-source
ruby2.6-rubygem-turbolinks-source-doc-5.2.0-1.3.x86_64.rpm RDoc documentation for turbolinks-source
ruby2.6-rubygem-tzinfo-0-0.3.55-1.3.i586.rpm Daylight-savings aware timezone library
ruby2.6-rubygem-tzinfo-0-0.3.55-1.3.x86_64.rpm Daylight-savings aware timezone library
ruby2.6-rubygem-tzinfo-1.2-1.2.5-1.2.i586.rpm Daylight savings aware timezone library
ruby2.6-rubygem-tzinfo-1.2-1.2.5-1.2.x86_64.rpm Daylight savings aware timezone library
ruby2.6-rubygem-tzinfo-2.0.0-1.3.i586.rpm Time Zone Library
Advertisement
Advertisement