ruby2.6-rubygem-sshkit-1.18.0-1.3.i586.rpm


Advertisement

Description

ruby2.6-rubygem-sshkit - SSHKit makes it easy to write structured, testable SSH commands in

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ruby2.6-rubygem-sshkit-1.18.0-1.3.i586.rpm
Package name ruby2.6-rubygem-sshkit
Package version 1.18.0
Package release 1.3
Package architecture i586
Package type rpm
Category Development/Languages/Ruby
Homepage http://github.com/capistrano/sshkit
License MIT
Maintainer -
Download size 298.16 KB
Installed size 364.43 KB
A comprehensive toolkit for remotely running commands in a structured manner
on groups of servers.

Alternatives

Package Version Architecture Repository
ruby2.6-rubygem-sshkit-1.18.0-1.3.x86_64.rpm 1.18.0 x86_64 openSUSE Oss
ruby2.6-rubygem-sshkit - - -

Requires

Name Value
ruby(abi) = 2.6.0
rubygem(ruby:2.6.0:net-scp) >= 1.1.2
rubygem(ruby:2.6.0:net-ssh) >= 2.8.0

Provides

Name Value
ruby2.6-rubygem-sshkit = 1.18.0-1.3
ruby2.6-rubygem-sshkit(x86-32) = 1.18.0-1.3
rubygem(ruby:2.6.0:sshkit) = 1.18.0
rubygem(ruby:2.6.0:sshkit:1) = 1.18.0
rubygem(ruby:2.6.0:sshkit:1.18) = 1.18.0
rubygem(ruby:2.6.0:sshkit:1.18.0) = 1.18.0
rubygem(sshkit) = 1.18.0

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ruby2.6-rubygem-sshkit-1.18.0-1.3.i586.rpm
Source Package rubygem-sshkit-1.18.0-1.3.src.rpm

Install Howto

Install ruby2.6-rubygem-sshkit rpm package:

# zypper install ruby2.6-rubygem-sshkit

Files

Path
/usr/lib/ruby/gems/2.6.0/cache/sshkit-1.18.0.gem
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/.gitignore
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/.travis.yml
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/.yardopts
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/BREAKING_API_WISHLIST.md
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/CHANGELOG.md
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/CONTRIBUTING.md
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/Dangerfile
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/EXAMPLES.md
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/FAQ.md
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/Gemfile
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/LICENSE.md
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/README.md
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/RELEASING.md
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/Rakefile
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/Vagrantfile
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/sshkit.gemspec
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/examples/
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/examples/images/example_output.png
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/examples/images/logo.png
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/core_ext/array.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/core_ext/hash.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/all.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/color.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/command.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/command_map.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/configuration.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/coordinator.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/deprecation_logger.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/dsl.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/exception.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/host.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/log_message.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/logger.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/mapping_interaction_handler.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/version.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/backends/abstract.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/backends/connection_pool.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/backends/local.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/backends/netssh.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/backends/printer.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/backends/skipper.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/backends/connection_pool/cache.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/backends/connection_pool/nil_cache.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/backends/netssh/known_hosts.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/formatters/abstract.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/formatters/black_hole.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/formatters/dot.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/formatters/pretty.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/formatters/simple_text.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/runners/abstract.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/runners/group.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/runners/null.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/runners/parallel.rb
/usr/lib/ruby/gems/2.6.0/gems/sshkit-1.18.0/lib/sshkit/runners/sequential.rb
/usr/lib/ruby/gems/2.6.0/specifications/sshkit-1.18.0.gemspec
/usr/share/doc/packages/ruby2.6-rubygem-sshkit/CHANGELOG.md
/usr/share/doc/packages/ruby2.6-rubygem-sshkit/LICENSE.md
/usr/share/doc/packages/ruby2.6-rubygem-sshkit/README.md

Changelog

2018-11-22 - Stephan Kulow <coolo@suse.com>
- updated to version 1.18.0
see installed CHANGELOG.md
[#]# [1.18.0][] (2018-10-21)
* [#435](https://github.com/capistrano/sshkit/pull/435): Consistent verbosity configuration #capture and #test methods - [@NikolayRys](https://github.com/NikolayRys)
2018-07-08 - factory-auto@kulow.org
- updated to version 1.17.0
see installed CHANGELOG.md
[#]# [1.17.0][] (2018-07-07)
* [#430](https://github.com/capistrano/sshkit/pull/430): [Feature] Command Argument STDOUT/capistrano.log Hiding - [@NorseGaud](https://github.com/NorseGaud)
2018-05-21 - factory-auto@kulow.org
- updated to version 1.16.1
see installed CHANGELOG.md
[#]# [1.16.1][] (2018-05-20)
* [#425](https://github.com/capistrano/sshkit/pull/425): Command#group incorrectly escapes double quotes, resulting in a a syntax error when specifying the group execution using `as`. This issue manifested when user command quotes changed from double quotes to single quotes. This fix removes the double quote escaping - [@pblesi](https://github.com/pblesi).
2018-02-27 - factory-auto@kulow.org
- updated to version 1.16.0
see installed CHANGELOG.md
[#]# [1.16.0][] (2018-02-03)
* [#417](https://github.com/capistrano/sshkit/pull/417): Cache key generation for connections becomes slow when `known_hosts` is a valid `net/ssh` options and `known_hosts` file is big. This changes the cache key generation and fixes performance issue - [@ElvinEfendi](https://github.com/ElvinEfendi).
[#]# [1.15.1][] (2017-11-18)
This is a small bug-fix release that fixes problems with `upload!` and `download!` that were inadvertently introduced in 1.15.0.
[#]## Breaking changes
* None
[#]## Bug fixes
* [#410](https://github.com/capistrano/sshkit/pull/410): fix NoMethodError when using upload!/download! with Pathnames - [@UnderpantsGnome](https://github.com/UnderpantsGnome)
* [#411](https://github.com/capistrano/sshkit/pull/410): fix upload!/download! when using relative paths outside of `within` blocks -  [@Fjan](https://github.com/Fjan)
[#]# [1.15.0][] (2017-11-03)
[#]## New features
* [#408](https://github.com/capistrano/sshkit/pull/408): upload! and download! now respect `within` - [@sj26](https://github.com/sj26)
[#]## Potentially breaking changes
* `upload!` and `download!` now support remote paths which are
relative to the `within` working directory. They were previously documented
as only supporting absolute paths, but relative paths still worked relative
to the remote working directory. If you rely on the previous behaviour you
may need to adjust your code.
2017-08-03 - coolo@suse.com
- updated to version 1.14.0
see installed CHANGELOG.md
[#]# [1.14.0][] (2017-06-30)
[#]## Breaking changes
* None
[#]## New features
* [#401](https://github.com/capistrano/sshkit/pull/401): Add :log_percent option to specify upload!/download! transfer log percentage - [@aubergene](https://github.com/aubergene)
2017-04-01 - coolo@suse.com
- updated to version 1.13.1
see installed CHANGELOG.md
[#]# [1.13.1][] (2017-03-31)
[#]## Breaking changes
* None
[#]## Bug fixes
* [#397](https://github.com/capistrano/sshkt/pull/397): Fix NoMethodError assign_defaults with net-ssh older than 4.0.0 - [@shirosaki](https://github.com/shirosaki)
2017-03-25 - coolo@suse.com
- updated to version 1.13.0
see installed CHANGELOG.md
[#]# [1.13.0][] (2017-03-24)
[#]## Breaking changes
* None
[#]## New features
* [#372](https://github.com/capistrano/sshkit/pull/372): Use cp_r in local backend with recursive option - [@okuramasafumi](https://github.com/okuramasafumi)
[#]## Bug fixes
* [#390](https://github.com/capistrano/sshkit/pull/390): Properly wrap Ruby StandardError w/ add'l context - [@mattbrictson](https://github.com/mattbrictson)
* [#392](https://github.com/capistrano/sshkit/pull/392): Fix open two connections with changed cache key - [@shirosaki](https://github.com/shirosaki)

See Also

Package Description
ruby2.6-rubygem-sshkit-doc-1.18.0-1.3.i586.rpm RDoc documentation for sshkit
ruby2.6-rubygem-sshkit-doc-1.18.0-1.3.x86_64.rpm RDoc documentation for sshkit
ruby2.6-rubygem-sshkit-testsuite-1.18.0-1.3.i586.rpm Test suite for sshkit
ruby2.6-rubygem-sshkit-testsuite-1.18.0-1.3.x86_64.rpm Test suite for sshkit
ruby2.6-rubygem-stackdeck-0.2.0-8.13.i586.rpm Manages stack traces across language boundaries
ruby2.6-rubygem-stackdeck-0.2.0-8.13.x86_64.rpm Manages stack traces across language boundaries
ruby2.6-rubygem-stackdeck-doc-0.2.0-8.13.i586.rpm RDoc documentation for stackdeck
ruby2.6-rubygem-stackdeck-doc-0.2.0-8.13.x86_64.rpm RDoc documentation for stackdeck
ruby2.6-rubygem-stackdeck-testsuite-0.2.0-8.13.i586.rpm Test suite for stackdeck
ruby2.6-rubygem-stackdeck-testsuite-0.2.0-8.13.x86_64.rpm Test suite for stackdeck
ruby2.6-rubygem-stomp-1.4.8-1.3.i586.rpm Ruby client for the Stomp messaging protocol
ruby2.6-rubygem-stomp-1.4.8-1.3.x86_64.rpm Ruby client for the Stomp messaging protocol
ruby2.6-rubygem-stomp-doc-1.4.8-1.3.i586.rpm RDoc documentation for stomp
ruby2.6-rubygem-stomp-doc-1.4.8-1.3.x86_64.rpm RDoc documentation for stomp
ruby2.6-rubygem-stomp-testsuite-1.4.8-1.3.i586.rpm Test suite for stomp
Advertisement
Advertisement