ruby2.6-rubygem-slim-testsuite-4.0.1-2.3.i586.rpm


Advertisement

Description

ruby2.6-rubygem-slim-testsuite - Test suite for slim

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ruby2.6-rubygem-slim-testsuite-4.0.1-2.3.i586.rpm
Package name ruby2.6-rubygem-slim-testsuite
Package version 4.0.1
Package release 2.3
Package architecture i586
Package type rpm
Category Development/Languages/Ruby
Homepage http://slim-lang.com/
License MIT
Maintainer -
Download size 53.25 KB
Installed size 137.46 KB
Test::Unit or RSpec files, useful for developers.

Alternatives

Package Version Architecture Repository
ruby2.6-rubygem-slim-testsuite-4.0.1-2.3.x86_64.rpm 4.0.1 x86_64 openSUSE Oss
ruby2.6-rubygem-slim-testsuite - - -

Requires

Name Value
/usr/bin/ruby.ruby2.6 -
ruby2.6-rubygem-slim = 4.0.1

Provides

Name Value
ruby2.6-rubygem-slim-testsuite = 4.0.1-2.3
ruby2.6-rubygem-slim-testsuite(x86-32) = 4.0.1-2.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ruby2.6-rubygem-slim-testsuite-4.0.1-2.3.i586.rpm
Source Package rubygem-slim-4.0.1-2.3.src.rpm

Install Howto

Install ruby2.6-rubygem-slim-testsuite rpm package:

# zypper install ruby2.6-rubygem-slim-testsuite

Files

Path
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/helper.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_code_blocks.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_code_escaping.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_code_evaluation.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_code_output.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_code_structure.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_commands.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_embedded_engines.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_encoding.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_erb_converter.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_html_attributes.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_html_escaping.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_html_structure.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_parser_errors.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_pretty.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_ruby_errors.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_slim_template.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_splat_prefix_option.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_tabs.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_text_interpolation.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_thread_options.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/core/test_unicode.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/include/test_include.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/include/files/recursive.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/include/files/slimfile.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/include/files/textfile
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/include/files/subdir/test.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/literate/TESTS.md
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/literate/helper.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/literate/run.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/logic_less/test_logic_less.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/Rakefile
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/config.ru
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/controllers/application_controller.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/controllers/entries_controller.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/controllers/slim_controller.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/helpers/application_helper.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/models/entry.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/views/
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/views/entries/edit.html.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/views/layouts/application.html.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/views/slim/_partial.html.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/views/slim/content_for.html.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/views/slim/erb.html.erb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/views/slim/form_for.html.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/views/slim/helper.html.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/views/slim/integers.html.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/views/slim/no_layout.html.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/views/slim/normal.html.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/views/slim/partial.html.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/views/slim/splat.html.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/views/slim/thread_options.html.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/views/slim/variables.html.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/app/views/slim/xml.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/config/application.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/config/boot.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/config/environment.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/config/routes.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/config/environments/test.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/config/initializers/backtrace_silencers.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/config/initializers/inflections.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/config/initializers/mime_types.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/config/initializers/secret_token.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/config/initializers/session_store.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/config/locales/en.yml
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/script/rails
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/test/helper.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/rails/test/test_slim.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/sinatra/contest.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/sinatra/helper.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/sinatra/test_core.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/sinatra/test_include.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/sinatra/views/embed_include_js.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/sinatra/views/embed_js.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/sinatra/views/footer.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/sinatra/views/hello.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/sinatra/views/layout2.slim
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/smart/test_smart_text.rb
/usr/lib/ruby/gems/2.6.0/gems/slim-4.0.1/test/translator/test_translator.rb

Changelog

2018-11-22 - Stephan Kulow <coolo@suse.com>
- updated to version 4.0.1
see installed CHANGES
4.0.1 (2018-09-02)
* Fix incompatibility issue with Slim Include plugin and new ability to specifiy attributes for embedded engines #819
4.0.0 (2018-08-26)
* Add ability to specify attributes for embedded engines using TagEngine - #653
* Set Tilt's default encoding to utf-8 - #800
* Prevent generation of invalid Ruby code in heredoc - #770
* Don't convert underscores to dashes on data attributes - #807 [Backward incompatible]
* Update description in README.jp.md - #795
* Removed support for embedded engines: Asciidoc, Builder, Creole, Erb, Nokogiri, Opal, Org-Ruby, Styl, Wikicloth
* Fix tests
2017-12-08 - mmeister@suse.com
- updated to version 3.0.9
see installed CHANGES
2017-05-23 - coolo@suse.com
- updated to version 3.0.8
see installed CHANGES
3.0.8 (2017-05-06)
* Added splat_prefix configuration option for Angular2 syntax support
* Require Ruby >= 2.0.0
* Relax temple dependency
2016-05-22 - coolo@suse.com
- updated to version 3.0.7
see installed CHANGES
3.0.7 (2016-05-22)
* Add additional attributes feature to shortcuts
* Freeze string literals
2015-06-12 - coolo@suse.com
- updated to version 3.0.6
see installed CHANGES
3.0.6 (2015-06-05)
* Fix warnings #625
2015-06-03 - coolo@suse.com
- updated to version 3.0.4
see installed CHANGES
2015-03-07 - coolo@suse.com
- updated to version 3.0.3
2015-02-09 - coolo@suse.com
- updated to version 3.0.2
* slimrb: Add option --locals
* Fix issues in the test suite (#576), thanks @dmke!
3.0.1
* Allow more special characters in html attribute names (See https://html.spec.whatwg.org/multipage/syntax.html#attributes-2), #567
* Fix: Code attributes mutate their argument (#571)
3.0.0
* Drop 1.8.7 support
* Deprecate default_options in favor of options
* Support xml pretty printing with format: :xml
* Deprecate `='`, `=='` and `tag'` syntax for trailing whitespace. Use `=<` etc. instead.
* slimrb: Remove deprecated plugin options -l and -t
2.1.0
* Parser: Require pairwise braces in quoted attributes
* Parser: add :attr_list_delims and :code_attr_delims
* Parser: deprecate :attr_delims
* Parser: relax text indentation requirements:
| line
next line
tag some text
more text
* Parser: allow first line to be indented
* Parser: allow inline embedded languages:
.content: markdown: This is **important**
* Parser: allow line breaks in quoted attributes
* Added Opal as embedded engine
* slimrb: Change meaning of -r, deprecate -t and -l
* Fix issue with inserted end (#485)
* Add experimental 'slim/include' plugin (Might change in the future)
* Add experimental 'slim/smart' plugin (Might change in the future)
* Drop jruby18 support
* Fix rails error reporting #587 (Manipulate stacktrace)
2014-11-03 - tboerger@suse.com
- Added last missing bits for new macros
2014-10-13 - adrian@suse.de
- adapt to new rubygem packaging style

See Also

Package Description
ruby2.6-rubygem-slop-3-3.6.0-1.13.i586.rpm Simple Lightweight Option Parsing
ruby2.6-rubygem-slop-3-3.6.0-1.13.x86_64.rpm Simple Lightweight Option Parsing
ruby2.6-rubygem-slop-3_3-3.3.3-1.13.i586.rpm Option gathering made easy
ruby2.6-rubygem-slop-3_3-3.3.3-1.13.x86_64.rpm Option gathering made easy
ruby2.6-rubygem-slop-4.6.2-1.3.i586.rpm Simple Lightweight Option Parsing
ruby2.6-rubygem-slop-4.6.2-1.3.x86_64.rpm Simple Lightweight Option Parsing
ruby2.6-rubygem-slop-doc-3-3.6.0-1.13.i586.rpm RDoc documentation for slop
ruby2.6-rubygem-slop-doc-3-3.6.0-1.13.x86_64.rpm RDoc documentation for slop
ruby2.6-rubygem-slop-doc-3_3-3.3.3-1.13.i586.rpm RDoc documentation for slop
ruby2.6-rubygem-slop-doc-3_3-3.3.3-1.13.x86_64.rpm RDoc documentation for slop
ruby2.6-rubygem-slop-doc-4.6.2-1.3.i586.rpm RDoc documentation for slop
ruby2.6-rubygem-slop-doc-4.6.2-1.3.x86_64.rpm RDoc documentation for slop
ruby2.6-rubygem-slop-testsuite-3-3.6.0-1.13.i586.rpm Test suite for slop
ruby2.6-rubygem-slop-testsuite-3-3.6.0-1.13.x86_64.rpm Test suite for slop
ruby2.6-rubygem-slop-testsuite-3_3-3.3.3-1.13.i586.rpm Test suite for slop
Advertisement
Advertisement