ruby2.6-rubygem-ruby_parser-testsuite-3.13.1-1.1.x86_64.rpm


Advertisement

Description

ruby2.6-rubygem-ruby_parser-testsuite - Test suite for ruby_parser

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ruby2.6-rubygem-ruby_parser-testsuite-3.13.1-1.1.x86_64.rpm
Package name ruby2.6-rubygem-ruby_parser-testsuite
Package version 3.13.1
Package release 1.1
Package architecture x86_64
Package type rpm
Category Development/Languages/Ruby
Homepage https://github.com/seattlerb/ruby_parser
License MIT
Maintainer -
Download size 41.68 KB
Installed size 181.83 KB
Test::Unit or RSpec files, useful for developers.

Alternatives

Package Version Architecture Repository
ruby2.6-rubygem-ruby_parser-testsuite-3.13.1-1.1.i586.rpm 3.13.1 i586 openSUSE Oss
ruby2.6-rubygem-ruby_parser-testsuite - - -

Requires

Name Value
ruby2.6-rubygem-ruby_parser = 3.13.1

Provides

Name Value
ruby2.6-rubygem-ruby_parser-testsuite = 3.13.1-1.1
ruby2.6-rubygem-ruby_parser-testsuite(x86-64) = 3.13.1-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ruby2.6-rubygem-ruby_parser-testsuite-3.13.1-1.1.x86_64.rpm
Source Package rubygem-ruby_parser-3.13.1-1.1.src.rpm

Install Howto

Install ruby2.6-rubygem-ruby_parser-testsuite rpm package:

# zypper install ruby2.6-rubygem-ruby_parser-testsuite

Files

Path
/usr/lib64/ruby/gems/2.6.0/gems/ruby_parser-3.13.1/test/test_ruby_lexer.rb
/usr/lib64/ruby/gems/2.6.0/gems/ruby_parser-3.13.1/test/test_ruby_parser.rb
/usr/lib64/ruby/gems/2.6.0/gems/ruby_parser-3.13.1/test/test_ruby_parser_extras.rb

Changelog

2019-03-29 - Stephan Kulow <coolo@suse.com>
- updated to version 3.13.1
see installed History.rdoc
=== 3.13.1 / 2019-03-25
* 1 major enhancement:
* Overhauled RubyLexer#lex_state to allow for multi-state value.
* 5 minor enhancements:
* Added RubyParser#current so scripts can poke around inside.
* Cleaned up and modernized bin/ruby_parse_extract_error.
* Removed RubyLexer#in_lex_state? in favor of State#=~ and #==.
* Renamed RubyLexer#in_arg_state? to is_after_operator?.
* Replaced all use of :expr_<*> symbols w/ bitfields.
* 15 bug fixes:
* Added tests to show #233 already fixed.
* Fixed a lexer state bug dealing with complex edge case in hash  key w/ interpolated symbol and an array value. Not a great fix. (presidentbeef)
* Fixed a number of lex_state check problems.
* Fixed alias and undef keyword data.
* Fixed bug normalizing to utf-8 on tail of dstr (post-interpolation). (mvz)
* Fixed handling of hex chars for bare unicode escape. (mvz)
* Fixed handling of invalid string octals more gracefully. Needs generalization.
* Fixed lexing of regexps w/ backslashed unicode. I hope.
* Fixed parse_percent for EXPR_FITEM edge cases. Fixed bug #125.
* Fixed parsing of op_asgn on constants (eg ::X ||= 1).
* Fixed precedence of rescue modifier on assignments. (mvz/whitequark)
* Fixed some EXPR_FNAME edge cases.
* Fixed using unicode in gvars. Fixed bug 202. (331299)
* Handle invalid string literals more gracefully.
* Minor fix lexing %s[]
2019-03-14 - Stephan Kulow <coolo@suse.com>
- updated to version 3.13.0
see installed History.rdoc
=== 3.13.0 / 2019-03-12
* 3 major enhancements:
* Removed 1.8 and 1.9 support. Moved to ruby_parser-legacy gem.
* Added tentative 2.6 support.
* Updated ruby_parser.yy to ruby 2.4 architecture.
* 22 minor enhancements:
* Added debug3 and cmp3 rake tasks that use the above tools.
* Added tLONELY to compare/normalize.rb
* Added tools/munge.rb, tools/ripper.rb, and debugging.md
* 2.6: Added trailing .. and ... support.
* Extended StackState to log more state changes, making debugging easier.
* Extended StackState#store to take an initial value.
* Improved logging / debugging in StackState.
* Improved normalization and parser compare tasks.
* Improved tools/munge.rb output.
* In f_arglist, track in_kwarg if no parens.
* In process_newline_or_comment, handle NL if in_kwarg there vs normal.
* Refactored normalized values to WORDLIST.
* Refactored parser: push up to relop and rel_expr.
* Removed Keyword.keyword18.
* Removed RubyLexer version attr_accessors.
* Removed long dead deprecations internal to RubyParserStuff.
* Removed version arg to RubyLexer#initialize (default nil + no-op).
* Renamed Keyword.keyword19 to Keyword.keyword.
* Renamed process_bracing to process_brace_close
* Renamed process_curly_brace to process_brace_open
* Report first parse error message if all parser versions fail, not last.
* Updated parser to track against 2.6.
* 11 bug fixes:
* Fix some shift/reduce errors.
* Fixed BEGIN blocks having different arg value that END blocks. (mvz)
* Fixed all reported unused non-terminals/rules.
* Fixed bug 272.
* Fixed bug in interpolated symbol lists. (strviola)
* Fixed bug where block shadow arguments were not registered as lvars. (akimd)
* Fixed bug where kwsplat args weren't treated as lvars. (mvz)
* Fixed lex_state and other internals in many cases.
* Fixed shebang in compare/normalize.rb to use env. Avoids rubygems freaking.
* Fixed some more internal state bugs.
* Fixed tRCURLY -> tSTRING_DEND for interpolation brace closes.

See Also

Package Description
ruby2.6-rubygem-rubyforge-2.0.4-13.13.i586.rpm A script which automates a limited set of rubyforge operations
ruby2.6-rubygem-rubyforge-2.0.4-13.13.x86_64.rpm A script which automates a limited set of rubyforge operations
ruby2.6-rubygem-rubyforge-doc-2.0.4-13.13.i586.rpm RDoc documentation for rubyforge
ruby2.6-rubygem-rubyforge-doc-2.0.4-13.13.x86_64.rpm RDoc documentation for rubyforge
ruby2.6-rubygem-rubyforge-testsuite-2.0.4-13.13.i586.rpm Test suite for rubyforge
ruby2.6-rubygem-rubyforge-testsuite-2.0.4-13.13.x86_64.rpm Test suite for rubyforge
ruby2.6-rubygem-rubyntlm-0.6.2-1.8.i586.rpm Ruby/NTLM library
ruby2.6-rubygem-rubyntlm-0.6.2-1.8.x86_64.rpm Ruby/NTLM library
ruby2.6-rubygem-rubyntlm-doc-0.6.2-1.8.i586.rpm RDoc documentation for rubyntlm
ruby2.6-rubygem-rubyntlm-doc-0.6.2-1.8.x86_64.rpm RDoc documentation for rubyntlm
ruby2.6-rubygem-rubyntlm-testsuite-0.6.2-1.8.i586.rpm Test suite for rubyntlm
ruby2.6-rubygem-rubyntlm-testsuite-0.6.2-1.8.x86_64.rpm Test suite for rubyntlm
ruby2.6-rubygem-rubyzip-1.2.2-2.1.i586.rpm rubyzip is a ruby module for reading and writing zip files
ruby2.6-rubygem-rubyzip-1.2.2-2.1.x86_64.rpm rubyzip is a ruby module for reading and writing zip files
ruby2.6-rubygem-rubyzip-doc-1.2.2-2.1.i586.rpm RDoc documentation for rubyzip
Advertisement
Advertisement