ruby2.6-rubygem-ruby-libvirt-0.7.1-1.4.i586.rpm


Advertisement

Description

ruby2.6-rubygem-ruby-libvirt - Ruby bindings for LIBVIRT

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ruby2.6-rubygem-ruby-libvirt-0.7.1-1.4.i586.rpm
Package name ruby2.6-rubygem-ruby-libvirt
Package version 0.7.1
Package release 1.4
Package architecture i586
Package type rpm
Category Development/Languages/Ruby
Homepage http://libvirt.org/ruby/
License LGPL-2.0-only
Maintainer -
Download size 284.40 KB
Installed size 1.08 MB
Ruby bindings for libvirt.

Alternatives

Package Version Architecture Repository
ruby2.6-rubygem-ruby-libvirt-0.7.1-1.4.x86_64.rpm 0.7.1 x86_64 openSUSE Oss
ruby2.6-rubygem-ruby-libvirt - - -

Requires

Name Value
libc.so.6(GLIBC_2.8) -
libruby2.6.so.2.6 -
libvirt-lxc.so.0 -
libvirt-lxc.so.0(LIBVIRT_LXC_1.0.2) -
libvirt-lxc.so.0(LIBVIRT_LXC_1.0.4) -
libvirt-qemu.so.0 -
libvirt-qemu.so.0(LIBVIRT_QEMU_0.10.0) -
libvirt-qemu.so.0(LIBVIRT_QEMU_0.8.3) -
libvirt-qemu.so.0(LIBVIRT_QEMU_0.9.4) -
libvirt.so.0 -
libvirt.so.0(LIBVIRT_0.0.3) -
libvirt.so.0(LIBVIRT_0.1.0) -
libvirt.so.0(LIBVIRT_0.1.1) -
libvirt.so.0(LIBVIRT_0.1.4) -
libvirt.so.0(LIBVIRT_0.1.5) -
libvirt.so.0(LIBVIRT_0.1.9) -
libvirt.so.0(LIBVIRT_0.10.0) -
libvirt.so.0(LIBVIRT_0.10.2) -
libvirt.so.0(LIBVIRT_0.2.0) -
libvirt.so.0(LIBVIRT_0.2.1) -
libvirt.so.0(LIBVIRT_0.2.3) -
libvirt.so.0(LIBVIRT_0.3.0) -
libvirt.so.0(LIBVIRT_0.3.2) -
libvirt.so.0(LIBVIRT_0.3.3) -
libvirt.so.0(LIBVIRT_0.4.0) -
libvirt.so.0(LIBVIRT_0.4.1) -
libvirt.so.0(LIBVIRT_0.4.2) -
libvirt.so.0(LIBVIRT_0.4.5) -
libvirt.so.0(LIBVIRT_0.5.0) -
libvirt.so.0(LIBVIRT_0.6.1) -
libvirt.so.0(LIBVIRT_0.6.3) -
libvirt.so.0(LIBVIRT_0.6.4) -
libvirt.so.0(LIBVIRT_0.7.0) -
libvirt.so.0(LIBVIRT_0.7.1) -
libvirt.so.0(LIBVIRT_0.7.2) -
libvirt.so.0(LIBVIRT_0.7.3) -
libvirt.so.0(LIBVIRT_0.7.5) -
libvirt.so.0(LIBVIRT_0.7.7) -
libvirt.so.0(LIBVIRT_0.8.0) -
libvirt.so.0(LIBVIRT_0.8.1) -
libvirt.so.0(LIBVIRT_0.8.2) -
libvirt.so.0(LIBVIRT_0.8.5) -
libvirt.so.0(LIBVIRT_0.8.6) -
libvirt.so.0(LIBVIRT_0.8.8) -
libvirt.so.0(LIBVIRT_0.9.0) -
libvirt.so.0(LIBVIRT_0.9.10) -
libvirt.so.0(LIBVIRT_0.9.11) -
libvirt.so.0(LIBVIRT_0.9.13) -
libvirt.so.0(LIBVIRT_0.9.2) -
libvirt.so.0(LIBVIRT_0.9.3) -
libvirt.so.0(LIBVIRT_0.9.4) -
libvirt.so.0(LIBVIRT_0.9.5) -
libvirt.so.0(LIBVIRT_0.9.7) -
libvirt.so.0(LIBVIRT_0.9.8) -
libvirt.so.0(LIBVIRT_0.9.9) -
libvirt.so.0(LIBVIRT_1.0.0) -
libvirt.so.0(LIBVIRT_1.0.1) -
libvirt.so.0(LIBVIRT_1.0.2) -
libvirt.so.0(LIBVIRT_1.0.3) -
libvirt.so.0(LIBVIRT_1.0.5) -
libvirt.so.0(LIBVIRT_1.1.0) -
libvirt.so.0(LIBVIRT_1.1.1) -
libvirt.so.0(LIBVIRT_1.1.3) -
libvirt.so.0(LIBVIRT_1.2.11) -
libvirt.so.0(LIBVIRT_1.2.12) -
libvirt.so.0(LIBVIRT_1.2.16) -
libvirt.so.0(LIBVIRT_1.2.19) -
libvirt.so.0(LIBVIRT_1.2.3) -
libvirt.so.0(LIBVIRT_1.2.5) -
libvirt.so.0(LIBVIRT_1.2.6) -
libvirt.so.0(LIBVIRT_1.2.7) -
libvirt.so.0(LIBVIRT_1.2.9) -
ruby(abi) = 2.6.0

Provides

Name Value
ruby2.6-rubygem-ruby-libvirt = 0.7.1-1.4
ruby2.6-rubygem-ruby-libvirt(x86-32) = 0.7.1-1.4
rubygem(ruby-libvirt) = 0.7.1
rubygem(ruby:2.6.0:ruby-libvirt) = 0.7.1
rubygem(ruby:2.6.0:ruby-libvirt:0) = 0.7.1
rubygem(ruby:2.6.0:ruby-libvirt:0.7) = 0.7.1
rubygem(ruby:2.6.0:ruby-libvirt:0.7.1) = 0.7.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ruby2.6-rubygem-ruby-libvirt-0.7.1-1.4.i586.rpm
Source Package rubygem-ruby-libvirt-0.7.1-1.4.src.rpm

Install Howto

Install ruby2.6-rubygem-ruby-libvirt rpm package:

# zypper install ruby2.6-rubygem-ruby-libvirt

Files

Path
/usr/lib/ruby/gems/2.6.0/cache/ruby-libvirt-0.7.1.gem
/usr/lib/ruby/gems/2.6.0/extensions/x86-linux/2.6.0/ruby-libvirt-0.7.1/_libvirt.so
/usr/lib/ruby/gems/2.6.0/extensions/x86-linux/2.6.0/ruby-libvirt-0.7.1/gem.build_complete
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/COPYING
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/NEWS
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/README
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/README.rdoc
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/Rakefile
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/.sitearchdir.time
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/_libvirt.c
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/_libvirt.so
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/common.c
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/common.h
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/connect.c
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/connect.h
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/domain.c
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/domain.h
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/extconf.h
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/extconf.rb
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/interface.c
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/interface.h
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/network.c
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/network.h
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/nodedevice.c
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/nodedevice.h
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/nwfilter.c
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/nwfilter.h
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/secret.c
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/secret.h
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/storage.c
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/storage.h
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/stream.c
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/ext/libvirt/stream.h
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/lib/_libvirt.so
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/lib/libvirt.rb
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/tests/test_conn.rb
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/tests/test_domain.rb
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/tests/test_interface.rb
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/tests/test_network.rb
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/tests/test_nodedevice.rb
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/tests/test_nwfilter.rb
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/tests/test_open.rb
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/tests/test_secret.rb
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/tests/test_storage.rb
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/tests/test_stream.rb
/usr/lib/ruby/gems/2.6.0/gems/ruby-libvirt-0.7.1/tests/test_utils.rb
/usr/lib/ruby/gems/2.6.0/specifications/ruby-libvirt-0.7.1.gemspec
/usr/share/doc/packages/ruby2.6-rubygem-ruby-libvirt/COPYING
/usr/share/doc/packages/ruby2.6-rubygem-ruby-libvirt/NEWS
/usr/share/doc/packages/ruby2.6-rubygem-ruby-libvirt/README
/usr/share/doc/packages/ruby2.6-rubygem-ruby-libvirt/README.rdoc

Changelog

2018-02-19 - factory-auto@kulow.org
- updated to version 0.7.1
see installed NEWS
2018-02-18 0.7.1
* Fix a bad bug in block_resize (Marius Rieder)
* Fix up some problems pointed out by clang
* Fix up the tests for small semantic differences in how libvirt works
2016-09-23 - coolo@suse.com
- updated to version 0.7.0
see installed NEWS
2016-09-22 0.7.0
* Fix network lease API to allow arguments that libvirt allows
* Implement VIRT_STORAGE_POOL_CREATE flags
* Implement more VIR_STORAGE_VOL flags
* Implement VIR_DOMAIN_QEMU_AGENT_COMMAND_SHUTDOWN
* Implement virDomainDefineXMLFlags
* Implement virDomainRename
* Implement virDomainSetUserPassword
* Implement VIR_DOMAIN_TIME_SYNC
* Fix the return value from virStreamSourceFunc so volume upload works
2015-11-21 - coolo@suse.com
- updated to version 0.6.0
see installed NEWS
2014-02-22 - coolo@suse.com
- updated to version 0.5.2
* Fix to make sure we don't free more entires than retrieved
2014-02-16 - kkaempf@suse.com
- use new macros
- drop ruby-libvirt-0.5.0-compile.patch
2014-01-05 - coolo@suse.com
- updated to version 0.5.1
* Fixes to compile against older libvirt
* Fixes to compile against ruby 1.8
2013-12-10 - dmacvicar@suse.de
- update to 0.5.0
2013-03-19 - dmacvicar@suse.de
- update to 0.4.0
- add the rubygem- prefix to the spec file name
2011-07-22 - fcastelli@novell.com
- Fix description for devel package.
2011-07-12 - fcastelli@novell.com
- Fixed spec file
- Upgraded to 0.3.0
Wed Mar 10 09:14:03 UTC 2010 - Christian Hueller
- Initial package

See Also

Package Description
ruby2.6-rubygem-ruby-libvirt-doc-0.7.1-1.4.i586.rpm RDoc documentation for ruby-libvirt
ruby2.6-rubygem-ruby-libvirt-doc-0.7.1-1.4.x86_64.rpm RDoc documentation for ruby-libvirt
ruby2.6-rubygem-ruby-openid-2.7.0-1.3.i586.rpm A library for consuming and serving OpenID identities
ruby2.6-rubygem-ruby-openid-2.7.0-1.3.x86_64.rpm A library for consuming and serving OpenID identities
ruby2.6-rubygem-ruby-openid-doc-2.7.0-1.3.i586.rpm RDoc documentation for ruby-openid
ruby2.6-rubygem-ruby-openid-doc-2.7.0-1.3.x86_64.rpm RDoc documentation for ruby-openid
ruby2.6-rubygem-ruby-openid-testsuite-2.7.0-1.3.i586.rpm Test suite for ruby-openid
ruby2.6-rubygem-ruby-openid-testsuite-2.7.0-1.3.x86_64.rpm Test suite for ruby-openid
ruby2.6-rubygem-ruby-shadow-2.5.0-1.18.i586.rpm *nix Shadow Password Module
ruby2.6-rubygem-ruby-shadow-2.5.0-1.18.x86_64.rpm *nix Shadow Password Module
ruby2.6-rubygem-ruby-shadow-doc-2.5.0-1.18.i586.rpm RDoc documentation for ruby-shadow
ruby2.6-rubygem-ruby-shadow-doc-2.5.0-1.18.x86_64.rpm RDoc documentation for ruby-shadow
ruby2.6-rubygem-ruby_dep-1.5.0-1.10.i586.rpm Extracts supported Ruby versions from Travis file
ruby2.6-rubygem-ruby_dep-1.5.0-1.10.x86_64.rpm Extracts supported Ruby versions from Travis file
ruby2.6-rubygem-ruby_dep-1_3-1.3.1-1.8.i586.rpm Extracts supported Ruby versions from Travis file
Advertisement
Advertisement