ruby2.6-rubygem-rails-5.2-5.2.3-1.1.x86_64.rpm


Advertisement

Description

ruby2.6-rubygem-rails-5.2 - Full-stack web application framework

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ruby2.6-rubygem-rails-5.2-5.2.3-1.1.x86_64.rpm
Package name ruby2.6-rubygem-rails-5.2
Package version 5.2.3
Package release 1.1
Package architecture x86_64
Package type rpm
Category Development/Languages/Ruby
Homepage http://rubyonrails.org
License MIT
Maintainer -
Download size 16.73 KB
Installed size 14.57 KB
Ruby on Rails is a full-stack web framework optimized for programmer happiness
and sustainable productivity. It encourages beautiful code by favoring
convention over configuration.

Alternatives

Package Version Architecture Repository
ruby2.6-rubygem-rails-5.2-5.2.3-1.1.i586.rpm 5.2.3 i586 openSUSE Oss
ruby2.6-rubygem-rails-5.2 - - -

Requires

Name Value
ruby(abi) = 2.6.0
rubygem(rake) -
rubygem(ruby:2.6.0:actioncable) = 5.2.3
rubygem(ruby:2.6.0:actionmailer) = 5.2.3
rubygem(ruby:2.6.0:actionpack) = 5.2.3
rubygem(ruby:2.6.0:actionview) = 5.2.3
rubygem(ruby:2.6.0:activejob) = 5.2.3
rubygem(ruby:2.6.0:activemodel) = 5.2.3
rubygem(ruby:2.6.0:activerecord) = 5.2.3
rubygem(ruby:2.6.0:activestorage) = 5.2.3
rubygem(ruby:2.6.0:activesupport) = 5.2.3
rubygem(ruby:2.6.0:bundler) >= 1.3.0
rubygem(ruby:2.6.0:railties) = 5.2.3
rubygem(ruby:2.6.0:sprockets-rails) >= 2.0.0

Provides

Name Value
ruby2.6-rubygem-rails-5.2 = 5.2.3-1.1
ruby2.6-rubygem-rails-5.2(x86-64) = 5.2.3-1.1
rubygem(rails) = 5.2.3
rubygem(ruby:2.6.0:rails) = 5.2.3
rubygem(ruby:2.6.0:rails:5) = 5.2.3
rubygem(ruby:2.6.0:rails:5.2) = 5.2.3
rubygem(ruby:2.6.0:rails:5.2.3) = 5.2.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ruby2.6-rubygem-rails-5.2-5.2.3-1.1.x86_64.rpm
Source Package rubygem-rails-5.2-5.2.3-1.1.src.rpm

Install Howto

Install ruby2.6-rubygem-rails-5.2 rpm package:

# zypper install ruby2.6-rubygem-rails-5.2

Files

Path
/usr/lib64/ruby/gems/2.6.0/cache/rails-5.2.3.gem
/usr/lib64/ruby/gems/2.6.0/gems/rails-5.2.3/README.md
/usr/lib64/ruby/gems/2.6.0/specifications/rails-5.2.3.gemspec
/usr/share/doc/packages/ruby2.6-rubygem-rails-5.2/README.md

Changelog

2019-03-29 - Stephan Kulow <coolo@suse.com>
- updated to version 5.2.3
no changelog found
2019-03-14 - Marcus Rueckert <mrueckert@suse.de>
- update to version 5.2.2.1:
https://weblog.rubyonrails.org/2019/3/13/Rails-4-2-5-1-5-1-6-2-have-been-released/
CVE-2019-5418 CVE-2019-5419 CVE-2019-5420
2019-02-06 - Stephan Kulow <coolo@suse.com>
- Move the recommends to the proper (generated) package (facepalm)
2019-02-03 - Stephan Kulow <coolo@suse.com>
- Fix bsc#1102075 by readding recommends
2019-01-19 - Marcus Rueckert <mrueckert@suse.de>
- rb_build_ruby_abi needs to be rb_build_ruby_abis
2019-01-18 - Marcus Rueckert <mrueckert@suse.de>
- limit to ruby 2.5 and above for 42.3/sle12
2018-12-08 - Stephan Kulow <coolo@suse.com>
- updated to version 5.2.2
no changelog found
2018-12-03 - mschnitzer@suse.com
- updated to version 5.2.1.1 (boo#1118076)
* No changelog in Rails itself. The actual changes can be found
in Rails submodules:
rubygem-activejob-5.2: Fixes CVE-2018-16476
rubygem-activestorage-5.2: Fixes CVE-2018-16477
It is advised to update to fix the security vulnerabilities.
2018-08-08 - mschnitzer@suse.com
- updated to version 5.2.1 (boo#1104209)
This base gem doesn't have any changelog. Please have
a look at the modules of Rails to get a list of all changes.
2018-04-13 - mschnitzer@suse.com
- initial package
see changelog: http://guides.rubyonrails.org/5_2_release_notes.html

See Also

Package Description
ruby2.6-rubygem-rails-5_0-5.0.7.2-1.1.i586.rpm Full-stack web application framework
ruby2.6-rubygem-rails-5_0-5.0.7.2-1.1.x86_64.rpm Full-stack web application framework
ruby2.6-rubygem-rails-5_1-5.1.7-1.1.i586.rpm Full-stack web application framework
ruby2.6-rubygem-rails-5_1-5.1.7-1.1.x86_64.rpm Full-stack web application framework
ruby2.6-rubygem-rails-deprecated_sanitizer-1.0.3-1.13.i586.rpm Deprecated sanitizer API extracted from Action View
ruby2.6-rubygem-rails-deprecated_sanitizer-1.0.3-1.13.x86_64.rpm Deprecated sanitizer API extracted from Action View
ruby2.6-rubygem-rails-deprecated_sanitizer-doc-1.0.3-1.13.i586.rpm RDoc documentation for rails-deprecated_sanitizer
ruby2.6-rubygem-rails-deprecated_sanitizer-doc-1.0.3-1.13.x86_64.rpm RDoc documentation for rails-deprecated_sanitizer
ruby2.6-rubygem-rails-deprecated_sanitizer-testsuite-1.0.3-1.13.i586.rpm Test suite for rails-deprecated_sanitizer
ruby2.6-rubygem-rails-deprecated_sanitizer-testsuite-1.0.3-1.13.x86_64.rpm Test suite for rails-deprecated_sanitizer
ruby2.6-rubygem-rails-doc-5.2-5.2.3-1.1.i586.rpm RDoc documentation for rails
ruby2.6-rubygem-rails-doc-5.2-5.2.3-1.1.x86_64.rpm RDoc documentation for rails
ruby2.6-rubygem-rails-doc-5_0-5.0.7.2-1.1.i586.rpm RDoc documentation for rails
ruby2.6-rubygem-rails-doc-5_0-5.0.7.2-1.1.x86_64.rpm RDoc documentation for rails
ruby2.6-rubygem-rails-doc-5_1-5.1.7-1.1.i586.rpm RDoc documentation for rails
Advertisement
Advertisement