ruby2.6-rubygem-pry-doc-1.0.0-1.1.x86_64.rpm


Advertisement

Description

ruby2.6-rubygem-pry-doc - Provides YARD and extended documentation support for Pry

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ruby2.6-rubygem-pry-doc-1.0.0-1.1.x86_64.rpm
Package name ruby2.6-rubygem-pry-doc
Package version 1.0.0
Package release 1.1
Package architecture x86_64
Package type rpm
Category Development/Languages/Ruby
Homepage https://github.com/pry/pry-doc
License MIT
Maintainer -
Download size 9.73 MB
Installed size 46.44 MB
Pry Doc is a Pry REPL plugin. It provides extended documentation support for
the REPL by means of improving the `show-doc` and `show-source` commands. With help
of the plugin the commands are be able to display the source code and the docs
of Ruby methods and classes implemented in C.

Alternatives

Package Version Architecture Repository
ruby2.6-rubygem-pry-doc-1.0.0-1.1.i586.rpm 1.0.0 i586 openSUSE Oss
ruby2.6-rubygem-pry-doc - - -

Requires

Name Value
etags -
ruby(abi) = 2.6.0
rubygem(ruby:2.6.0:pry:0) >= 0.11
rubygem(ruby:2.6.0:yard:0.9) >= 0.9.11

Provides

Name Value
ruby2.6-rubygem-pry-doc = 1.0.0-1.1
ruby2.6-rubygem-pry-doc(x86-64) = 1.0.0-1.1
rubygem(pry-doc) = 1.0.0
rubygem(ruby:2.6.0:pry-doc) = 1.0.0
rubygem(ruby:2.6.0:pry-doc:1) = 1.0.0
rubygem(ruby:2.6.0:pry-doc:1.0) = 1.0.0
rubygem(ruby:2.6.0:pry-doc:1.0.0) = 1.0.0

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ruby2.6-rubygem-pry-doc-1.0.0-1.1.x86_64.rpm
Source Package rubygem-pry-doc-1.0.0-1.1.src.rpm

Install Howto

Install ruby2.6-rubygem-pry-doc rpm package:

# zypper install ruby2.6-rubygem-pry-doc

Files

Path
/usr/lib64/ruby/gems/2.6.0/cache/pry-doc-1.0.0.gem
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/.gitignore
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/.travis.yml
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/.yardopts
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/CHANGELOG.md
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/Gemfile
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/LICENSE
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/README.md
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/Rakefile
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/pry-doc.gemspec
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc.rb
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/version.rb
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/20/checksums
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/20/object_types
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/20/proxy_types
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/20/objects/root.dat
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/21/checksums
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/21/object_types
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/21/proxy_types
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/21/objects/root.dat
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/22/checksums
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/22/object_types
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/22/proxy_types
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/22/objects/root.dat
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/23/checksums
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/23/object_types
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/23/proxy_types
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/23/objects/root.dat
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/24/checksums
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/24/complete
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/24/object_types
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/24/proxy_types
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/24/objects/root.dat
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/25/checksums
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/25/complete
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/25/object_types
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/25/proxy_types
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/25/objects/root.dat
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/26/checksums
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/26/complete
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/26/object_types
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/26/proxy_types
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/docs/26/objects/root.dat
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/pry_ext/method_info.rb
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/pry_ext/show_source_with_c_internals.rb
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/pry_ext/show_source_with_c_internals/c_file.rb
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/pry_ext/show_source_with_c_internals/code_fetcher.rb
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/pry_ext/show_source_with_c_internals/etag_parser.rb
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/pry_ext/show_source_with_c_internals/ruby_source_installer.rb
/usr/lib64/ruby/gems/2.6.0/gems/pry-doc-1.0.0/lib/pry-doc/pry_ext/show_source_with_c_internals/symbol_extractor.rb
/usr/lib64/ruby/gems/2.6.0/specifications/pry-doc-1.0.0.gemspec
/usr/share/doc/packages/ruby2.6-rubygem-pry-doc/CHANGELOG.md
/usr/share/doc/packages/ruby2.6-rubygem-pry-doc/LICENSE
/usr/share/doc/packages/ruby2.6-rubygem-pry-doc/README.md

Changelog

2019-01-14 - Stephan Kulow <coolo@suse.com>
- updated to version 1.0.0
see installed CHANGELOG.md
[#]## [v1.0.0][v1.0.0] (December 27, 2018)
* Added suport for Ruby 2.6 docs ([#90](https://github.com/pry/pry-doc/pull/90))
2018-11-22 - Stephan Kulow <coolo@suse.com>
- updated to version 0.13.5
see installed CHANGELOG.md
[#]## [v0.13.5][v0.13.5] (November 8, 2018)
* Fixed deprecation warnings emitted by Pry v0.12.0
([#87](https://github.com/pry/pry-doc/pull/87))
* Fixed MRI 2.0 regression ([#88](https://github.com/pry/pry-doc/pull/88))
2018-04-10 - factory-auto@kulow.org
- updated to version 0.13.4
see installed CHANGELOG.md
2018-03-13 - coolo@suse.com
- remove precompiled binaries
2018-03-04 - factory-auto@kulow.org
- updated to version 0.13.3
see installed CHANGELOG.md
2018-02-16 - factory-auto@kulow.org
- updated to version 0.13.1
see installed CHANGELOG.md
2018-02-15 - factory-auto@kulow.org
- updated to version 0.13.0
see installed CHANGELOG.md
2018-02-08 - coolo@suse.com
- updated to version 0.12.0
see installed CHANGELOG.md
[#]## [v0.12.0][v0.12.0] (January 21, 2018)
* Added suport for Ruby 2.5 docs ([#75](https://github.com/pry/pry-doc/pull/75))
2017-09-11 - coolo@suse.com
- updated to version 0.11.1
see installed CHANGELOG.md
[#]## [v0.11.1][v0.11.1] (August 8, 2017)
* Specified minimum required Ruby version in the gemspec
([#70](https://github.com/pry/pry-doc/pull/70))
[#]## [v0.11.0][v0.11.0] (August 8, 2017)
* **IMPORTANT:** Drop support for Ruby 1.9.3
([#68](https://github.com/pry/pry-doc/pull/68))
* Stopped raising exception when Pry Doc doesn't support current Ruby version
(we print a warning instead) ([#65](https://github.com/pry/pry-doc/pull/65))
2017-01-01 - coolo@suse.com
- updated to version 0.10.0
see installed CHANGELOG.md
[#]## [v0.10.0][v0.10.0] (December 31, 2016)
* Added support for Ruby 2.4 docs
([#46](https://github.com/pry/pry-doc/pull/46))

See Also

Package Description
ruby2.6-rubygem-pry-doc-testsuite-1.0.0-1.1.i586.rpm Test suite for pry-doc
ruby2.6-rubygem-pry-doc-testsuite-1.0.0-1.1.x86_64.rpm Test suite for pry-doc
ruby2.6-rubygem-pry_debug-0.1.0-6.16.i586.rpm A pure-ruby debugger
ruby2.6-rubygem-pry_debug-0.1.0-6.16.x86_64.rpm A pure-ruby debugger
ruby2.6-rubygem-pry_debug-doc-0.1.0-6.16.i586.rpm RDoc documentation for pry_debug
ruby2.6-rubygem-pry_debug-doc-0.1.0-6.16.x86_64.rpm RDoc documentation for pry_debug
ruby2.6-rubygem-pry_debug-testsuite-0.1.0-6.16.i586.rpm Test suite for pry_debug
ruby2.6-rubygem-pry_debug-testsuite-0.1.0-6.16.x86_64.rpm Test suite for pry_debug
ruby2.6-rubygem-public_suffix-3.0.3-1.3.i586.rpm Domain name parser based on the Public Suffix List
ruby2.6-rubygem-public_suffix-3.0.3-1.3.x86_64.rpm Domain name parser based on the Public Suffix List
ruby2.6-rubygem-public_suffix-doc-3.0.3-1.3.i586.rpm RDoc documentation for public_suffix
ruby2.6-rubygem-public_suffix-doc-3.0.3-1.3.x86_64.rpm RDoc documentation for public_suffix
ruby2.6-rubygem-public_suffix-testsuite-3.0.3-1.3.i586.rpm Test suite for public_suffix
ruby2.6-rubygem-public_suffix-testsuite-3.0.3-1.3.x86_64.rpm Test suite for public_suffix
ruby2.6-rubygem-puma-3.12.1-1.1.i586.rpm Puma is a simple, fast, threaded, and highly concurrent HTTP 1.1
Advertisement
Advertisement