ruby2.6-rubygem-nokogiri-1.10.2-1.1.i586.rpm


Advertisement

Description

ruby2.6-rubygem-nokogiri - Nokogiri (鋸) is an HTML, XML, SAX, and Reader parser

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ruby2.6-rubygem-nokogiri-1.10.2-1.1.i586.rpm
Package name ruby2.6-rubygem-nokogiri
Package version 1.10.2
Package release 1.1
Package architecture i586
Package type rpm
Category Development/Languages/Ruby
Homepage -
License MIT
Maintainer -
Download size 8.75 MB
Installed size 9.23 MB
Nokogiri (鋸) is an HTML, XML, SAX, and Reader parser.  Among
Nokogiri's many features is the ability to search documents via XPath
or CSS3 selectors.

Alternatives

Package Version Architecture Repository
ruby2.6-rubygem-nokogiri-1.10.2-1.1.x86_64.rpm 1.10.2 x86_64 openSUSE Oss
ruby2.6-rubygem-nokogiri - - -

Requires

Name Value
/usr/bin/ruby.ruby2.6 -
libc.so.6(GLIBC_2.4) -
libexslt.so.0 -
libruby2.6.so.2.6 -
libxml2.so.2 -
libxml2.so.2(LIBXML2_2.4.30) -
libxml2.so.2(LIBXML2_2.5.0) -
libxml2.so.2(LIBXML2_2.5.2) -
libxml2.so.2(LIBXML2_2.5.7) -
libxml2.so.2(LIBXML2_2.5.8) -
libxml2.so.2(LIBXML2_2.6.0) -
libxml2.so.2(LIBXML2_2.6.12) -
libxml2.so.2(LIBXML2_2.6.15) -
libxml2.so.2(LIBXML2_2.6.2) -
libxml2.so.2(LIBXML2_2.6.20) -
libxml2.so.2(LIBXML2_2.6.21) -
libxml2.so.2(LIBXML2_2.6.23) -
libxml2.so.2(LIBXML2_2.6.24) -
libxml2.so.2(LIBXML2_2.6.3) -
libxml2.so.2(LIBXML2_2.6.8) -
libxml2.so.2(LIBXML2_2.7.3) -
libxslt.so.1 -
libxslt.so.1(LIBXML2_1.0.11) -
libxslt.so.1(LIBXML2_1.0.13) -
libxslt.so.1(LIBXML2_1.0.18) -
ruby(abi) = 2.6.0
rubygem(ruby:2.6.0:mini_portile2:2.4) >= 2.4
update-alternatives -

Provides

Name Value
ruby2.6-rubygem-nokogiri = 1.10.2-1.1
ruby2.6-rubygem-nokogiri(x86-32) = 1.10.2-1.1
rubygem(nokogiri) = 1.10.2
rubygem(ruby:2.6.0:nokogiri) = 1.10.2
rubygem(ruby:2.6.0:nokogiri:1) = 1.10.2
rubygem(ruby:2.6.0:nokogiri:1.10) = 1.10.2
rubygem(ruby:2.6.0:nokogiri:1.10.2) = 1.10.2

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ruby2.6-rubygem-nokogiri-1.10.2-1.1.i586.rpm
Source Package rubygem-nokogiri-1.10.2-1.1.src.rpm

Install Howto

Install ruby2.6-rubygem-nokogiri rpm package:

# zypper install ruby2.6-rubygem-nokogiri

Files

Path
/etc/alternatives/nokogiri
/etc/alternatives/nokogiri-1.10.2
/etc/alternatives/nokogiri.ruby2.6
/usr/bin/nokogiri
/usr/bin/nokogiri-1.10.2
/usr/bin/nokogiri.ruby2.6
/usr/bin/nokogiri.ruby2.6-1.10.2
/usr/lib/ruby/gems/2.6.0/cache/nokogiri-1.10.2.gem
/usr/lib/ruby/gems/2.6.0/extensions/x86-linux/2.6.0/nokogiri-1.10.2/gem.build_complete
/usr/lib/ruby/gems/2.6.0/extensions/x86-linux/2.6.0/nokogiri-1.10.2/nokogiri/nokogiri.so
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/LICENSE-DEPENDENCIES.md
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/LICENSE.md
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/README.md
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/dependencies.yml
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/bin/nokogiri
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/.sitearchdir.-.nokogiri.time
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/depend
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/extconf.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/html_document.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/html_document.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/html_element_description.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/html_element_description.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/html_entity_lookup.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/html_entity_lookup.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/html_sax_parser_context.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/html_sax_parser_context.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/html_sax_push_parser.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/html_sax_push_parser.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/nokogiri.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/nokogiri.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/nokogiri.so
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_attr.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_attr.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_attribute_decl.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_attribute_decl.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_cdata.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_cdata.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_comment.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_comment.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_document.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_document.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_document_fragment.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_document_fragment.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_dtd.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_dtd.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_element_content.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_element_content.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_element_decl.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_element_decl.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_encoding_handler.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_encoding_handler.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_entity_decl.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_entity_decl.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_entity_reference.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_entity_reference.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_io.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_io.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_libxml2_hacks.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_libxml2_hacks.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_namespace.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_namespace.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_node.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_node.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_node_set.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_node_set.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_processing_instruction.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_processing_instruction.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_reader.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_reader.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_relax_ng.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_relax_ng.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_sax_parser.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_sax_parser.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_sax_parser_context.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_sax_parser_context.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_sax_push_parser.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_sax_push_parser.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_schema.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_schema.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_syntax_error.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_syntax_error.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_text.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_text.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_xpath_context.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xml_xpath_context.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xslt_stylesheet.c
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/ext/nokogiri/xslt_stylesheet.h
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/css.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/html.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/nokogiri.so
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/syntax_error.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/version.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xslt.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/css/node.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/css/parser.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/css/parser.y
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/css/parser_extras.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/css/syntax_error.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/css/tokenizer.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/css/tokenizer.rex
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/css/xpath_visitor.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/decorators/slop.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/html/builder.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/html/document.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/html/document_fragment.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/html/element_description.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/html/element_description_defaults.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/html/entity_lookup.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/html/sax/parser.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/html/sax/parser_context.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/html/sax/push_parser.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/attr.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/attribute_decl.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/builder.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/cdata.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/character_data.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/document.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/document_fragment.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/dtd.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/element_content.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/element_decl.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/entity_decl.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/entity_reference.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/namespace.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/node.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/node_set.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/notation.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/parse_options.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/pp.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/processing_instruction.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/reader.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/relax_ng.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/sax.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/schema.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/searchable.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/syntax_error.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/text.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/xpath.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/xpath_context.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/node/save_options.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/pp/character_data.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/pp/node.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/sax/document.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/sax/parser.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/sax/parser_context.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/sax/push_parser.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xml/xpath/syntax_error.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/nokogiri/xslt/stylesheet.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/xsd/
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/lib/xsd/xmlparser/nokogiri.rb
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/patches/
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/patches/libxml2/0001-Revert-Do-not-URI-escape-in-server-side-includes.patch
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/patches/libxml2/0002-Remove-script-macro-support.patch
/usr/lib/ruby/gems/2.6.0/gems/nokogiri-1.10.2/patches/libxml2/0003-Update-entities-to-remove-handling-of-ssi.patch
/usr/lib/ruby/gems/2.6.0/specifications/nokogiri-1.10.2.gemspec
/usr/share/doc/packages/ruby2.6-rubygem-nokogiri/LICENSE.md
/usr/share/doc/packages/ruby2.6-rubygem-nokogiri/README.md

Changelog

2019-03-29 - Stephan Kulow <coolo@suse.com>
- updated to version 1.10.2
no changelog found
2019-01-14 - mschnitzer@suse.com
- updated to version 1.10.1
[#]## Features
* [MRI] During installation, handle Xcode 10's new library path. [#1801, #1851] (Thanks, @mlj and @deepj!)
* Avoid unnecessary creation of `Proc`s in many methods. [#1776] (Thanks, @chopraanmol1!)
[#]## Bug fixes
* CSS selector `:has()` now correctly matches against any descendant. Previously this selector matched against only direct children). [#350] (Thanks, @Phrogz!)
* `NodeSet#attr` now returns `nil` if it's empty. Previously this raised a NoMethodError.
* [MRI] XPath errors are no longer suppressed during `XSLT::Stylesheet#transform`. Previously these errors were suppressed which led to silent failures and a subsequent segfault. [#1802]
2018-12-19 - Stephan Kulow <coolo@suse.com>
- updated to version 1.9.1
CHANGELOG.md removed upstream
2018-10-29 - mschnitzer@suse.com
- updated to version 1.8.5
[#]# Security Notes
[MRI] Pulled in upstream patches from libxml2 that address CVE-2018-14404 and CVE-2018-14567. Full details are available in [#1785](https://github.com/sparklemotion/nokogiri/issues/1785). Note that these patches are not yet (as of 2018-10-04) in an upstream release of libxml2.
[#]# Bug fixes
* [MRI] Fix regression in installation when building against system libraries, where some systems would not be able to find libxml2 or libxslt when present. (Regression introduced in v1.8.3.) [#1722]
* [JRuby] Fix node reparenting when the destination doc is empty. [#1773]
2018-07-04 - factory-auto@kulow.org
- updated to version 1.8.4
see installed CHANGELOG.md
[#] 1.8.4 / 2018-07-03
[#]# Bug fixes
* [MRI] Fix memory leak when creating nodes with namespaces. (Introduced in v1.5.7) [#1771]
2018-06-16 - factory-auto@kulow.org
- updated to version 1.8.3
see installed CHANGELOG.md
[#] 1.8.3 / 2018-06-16
[#]# Security Notes
[MRI] Behavior in libxml2 has been reverted which caused CVE-2018-8048 (loofah gem), CVE-2018-3740 (sanitize gem), and CVE-2018-3741 (rails-html-sanitizer gem). The commit in question is here:
> https://github.com/GNOME/libxml2/commit/960f0e2
and more information is available about this commit and its impact here:
> https://github.com/flavorjones/loofah/issues/144
This release simply reverts the libxml2 commit in question to protect users of Nokogiri's vendored libraries from similar vulnerabilities.
If you're offended by what happened here, I'd kindly ask that you comment on the upstream bug report here:
> https://bugzilla.gnome.org/show_bug.cgi?id=769760
[#]# Dependencies
* [MRI] libxml2 is updated from 2.9.7 to 2.9.8
[#]# Features
* Node#classes, #add_class, #append_class, and #remove_class are added.
* NodeSet#append_class is added.
* NodeSet#remove_attribute is a new alias for NodeSet#remove_attr.
* NodeSet#each now returns an Enumerator when no block is passed (Thanks, @park53kr!)
* [JRuby] General improvements in JRuby implementation (Thanks, @kares!)
[#]# Bug fixes
* CSS attribute selectors now gracefully handle queries using integers. [#711]
* Handle ASCII-8BIT encoding on fragment input [#553]
* Handle non-string return values within `Reader` [#898]
* [JRuby] Allow Node#replace to insert Comment and CDATA nodes. [#1666]
* [JRuby] Stability and speed improvements to `Node`, `Sax::PushParser`, and the JRuby implementation [#1708, #1710, #1501]

See Also

Package Description
ruby2.6-rubygem-nokogiri-doc-1.10.2-1.1.i586.rpm RDoc documentation for nokogiri
ruby2.6-rubygem-nokogiri-doc-1.10.2-1.1.x86_64.rpm RDoc documentation for nokogiri
ruby2.6-rubygem-nori-2.6.0-1.7.i586.rpm XML to Hash translator
ruby2.6-rubygem-nori-2.6.0-1.7.x86_64.rpm XML to Hash translator
ruby2.6-rubygem-nori-doc-2.6.0-1.7.i586.rpm RDoc documentation for nori
ruby2.6-rubygem-nori-doc-2.6.0-1.7.x86_64.rpm RDoc documentation for nori
ruby2.6-rubygem-nori-testsuite-2.6.0-1.7.i586.rpm Test suite for nori
ruby2.6-rubygem-nori-testsuite-2.6.0-1.7.x86_64.rpm Test suite for nori
ruby2.6-rubygem-oauth-0.5.4-1.4.i586.rpm OAuth Core Ruby implementation
ruby2.6-rubygem-oauth-0.5.4-1.4.x86_64.rpm OAuth Core Ruby implementation
ruby2.6-rubygem-oauth-doc-0.5.4-1.4.i586.rpm RDoc documentation for oauth
ruby2.6-rubygem-oauth-doc-0.5.4-1.4.x86_64.rpm RDoc documentation for oauth
ruby2.6-rubygem-oauth2-1.4.1-1.3.i586.rpm A Ruby wrapper for the OAuth 2.0 protocol
ruby2.6-rubygem-oauth2-1.4.1-1.3.x86_64.rpm A Ruby wrapper for the OAuth 2.0 protocol
ruby2.6-rubygem-oauth2-doc-1.4.1-1.3.i586.rpm RDoc documentation for oauth2
Advertisement
Advertisement