ruby2.6-rubygem-net-ldap-testsuite-0.16.1-1.3.x86_64.rpm


Advertisement

Description

ruby2.6-rubygem-net-ldap-testsuite - Test suite for net-ldap

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ruby2.6-rubygem-net-ldap-testsuite-0.16.1-1.3.x86_64.rpm
Package name ruby2.6-rubygem-net-ldap-testsuite
Package version 0.16.1
Package release 1.3
Package architecture x86_64
Package type rpm
Category Development/Languages/Ruby
Homepage http://github.com/ruby-ldap/ruby-net-ldap
License MIT
Maintainer -
Download size 41.16 KB
Installed size 103.36 KB
Test::Unit or RSpec files, useful for developers.

Alternatives

Package Version Architecture Repository
ruby2.6-rubygem-net-ldap-testsuite-0.16.1-1.3.i586.rpm 0.16.1 i586 openSUSE Oss
ruby2.6-rubygem-net-ldap-testsuite - - -

Requires

Name Value
ruby2.6-rubygem-net-ldap = 0.16.1

Provides

Name Value
ruby2.6-rubygem-net-ldap-testsuite = 0.16.1-1.3
ruby2.6-rubygem-net-ldap-testsuite(x86-64) = 0.16.1-1.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ruby2.6-rubygem-net-ldap-testsuite-0.16.1-1.3.x86_64.rpm
Source Package rubygem-net-ldap-0.16.1-1.3.src.rpm

Install Howto

Install ruby2.6-rubygem-net-ldap-testsuite rpm package:

# zypper install ruby2.6-rubygem-net-ldap-testsuite

Files

Path
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/test_auth_adapter.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/test_dn.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/test_entry.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/test_filter.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/test_filter_parser.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/test_helper.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/test_ldap.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/test_ldap_connection.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/test_ldif.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/test_password.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/test_rename.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/test_search.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/test_snmp.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/test_ssl_ber.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/testdata.ldif
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/ber/test_ber.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/ber/core_ext/test_array.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/ber/core_ext/test_string.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/fixtures/seed.ldif
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/fixtures/ca/ca.info
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/fixtures/ca/cacert.pem
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/fixtures/ca/cakey.pem
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/fixtures/openldap/memberof.ldif
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/fixtures/openldap/retcode.ldif
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/fixtures/openldap/slapd.conf.ldif
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/integration/test_add.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/integration/test_ber.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/integration/test_bind.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/integration/test_delete.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/integration/test_open.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/integration/test_password_modify.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/integration/test_return_codes.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/integration/test_search.rb
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/support/
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/support/vm/
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/support/vm/openldap/.gitignore
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/support/vm/openldap/README.md
/usr/lib64/ruby/gems/2.6.0/gems/net-ldap-0.16.1/test/support/vm/openldap/Vagrantfile

Changelog

2017-11-24 - mschnitzer@suse.com
- updated to version 0.16.1
* Send DN and newPassword with password_modify request #271
2017-02-25 - coolo@suse.com
- updated to version 0.16.0
see installed History.rdoc
=== Net::LDAP 0.16.0
* Sasl fix {#281}[https://github.com/ruby-ldap/ruby-net-ldap/pull/281]
* enable TLS hostname validation {#279}[https://github.com/ruby-ldap/ruby-net-ldap/pull/279]
* update rubocop to 0.42.0 {#278}[https://github.com/ruby-ldap/ruby-net-ldap/pull/278]
2016-07-14 - coolo@suse.com
- updated to version 0.15.0
see installed History.rdoc
=== Net::LDAP 0.15.0
* Respect connect_timeout when establishing SSL connections {#273}[https://github.com/ruby-ldap/ruby-net-ldap/pull/273]
2016-02-06 - coolo@suse.com
- updated to version 0.14.0
see installed History.rdoc
=== Net::LDAP 0.14.0
* Normalize the encryption parameter passed to the LDAP constructor {#264}[https://github.com/ruby-ldap/ruby-net-ldap/pull/264]
* Update Docs: Net::LDAP now requires ruby >= 2 {#261}[https://github.com/ruby-ldap/ruby-net-ldap/pull/261]
* fix symbol proc {#255}[https://github.com/ruby-ldap/ruby-net-ldap/pull/255]
* fix trailing commas {#256}[https://github.com/ruby-ldap/ruby-net-ldap/pull/256]
* fix deprecated hash methods {#254}[https://github.com/ruby-ldap/ruby-net-ldap/pull/254]
* fix space after comma {#253}[https://github.com/ruby-ldap/ruby-net-ldap/pull/253]
* fix space inside brackets {#252}[https://github.com/ruby-ldap/ruby-net-ldap/pull/252]
* Rubocop style fixes {#249}[https://github.com/ruby-ldap/ruby-net-ldap/pull/249]
* Lazy initialize Net::LDAP::Connection's internal socket {#235}[https://github.com/ruby-ldap/ruby-net-ldap/pull/235]
* Support for rfc3062 Password Modify, closes #163 {#178}[https://github.com/ruby-ldap/ruby-net-ldap/pull/178]
2016-01-21 - coolo@suse.com
- updated to version 0.13.0
see installed History.rdoc
=== Net::LDAP 0.13.0
* Set a connect_timeout for the creation of a socket {#243}[https://github.com/ruby-ldap/ruby-net-ldap/pull/243]
* Update bundler before installing gems with bundler {#245}[https://github.com/ruby-ldap/ruby-net-ldap/pull/245]
* Net::LDAP#encryption accepts string {#239}[https://github.com/ruby-ldap/ruby-net-ldap/pull/239]
* Adds correct UTF-8 encoding to Net::BER::BerIdentifiedString {#242}[https://github.com/ruby-ldap/ruby-net-ldap/pull/242]
* Remove 2.3.0-preview since ruby-head already is included {#241}[https://github.com/ruby-ldap/ruby-net-ldap/pull/241]
* Drop support for ruby 1.9.3 {#240}[https://github.com/ruby-ldap/ruby-net-ldap/pull/240]
* Fixed capitalization of StartTLSError {#234}[https://github.com/ruby-ldap/ruby-net-ldap/pull/234]
2015-11-12 - coolo@suse.com
- updated to version 0.12.1
see installed History.rdoc
=== Net::LDAP 0.12.1
* Whitespace formatting cleanup {#236}[https://github.com/ruby-ldap/ruby-net-ldap/pull/236]
* Set operation result if LDAP server is not accessible {#232}[https://github.com/ruby-ldap/ruby-net-ldap/pull/232]

See Also

Package Description
ruby2.6-rubygem-net-scp-1_1-1.1.2-2.14.i586.rpm A pure Ruby implementation of the SCP client protocol
ruby2.6-rubygem-net-scp-1_1-1.1.2-2.14.x86_64.rpm A pure Ruby implementation of the SCP client protocol
ruby2.6-rubygem-net-scp-1_2-1.2.1-1.1.i586.rpm A pure Ruby implementation of the SCP client protocol
ruby2.6-rubygem-net-scp-1_2-1.2.1-1.1.x86_64.rpm A pure Ruby implementation of the SCP client protocol
ruby2.6-rubygem-net-scp-2.0.0-1.1.i586.rpm A pure Ruby implementation of the SCP client protocol
ruby2.6-rubygem-net-scp-2.0.0-1.1.x86_64.rpm A pure Ruby implementation of the SCP client protocol
ruby2.6-rubygem-net-scp-doc-1_1-1.1.2-2.14.i586.rpm RDoc documentation for net-scp
ruby2.6-rubygem-net-scp-doc-1_1-1.1.2-2.14.x86_64.rpm RDoc documentation for net-scp
ruby2.6-rubygem-net-scp-doc-1_2-1.2.1-1.1.i586.rpm RDoc documentation for net-scp
ruby2.6-rubygem-net-scp-doc-1_2-1.2.1-1.1.x86_64.rpm RDoc documentation for net-scp
ruby2.6-rubygem-net-scp-doc-2.0.0-1.1.i586.rpm RDoc documentation for net-scp
ruby2.6-rubygem-net-scp-doc-2.0.0-1.1.x86_64.rpm RDoc documentation for net-scp
ruby2.6-rubygem-net-scp-testsuite-1_1-1.1.2-2.14.i586.rpm Test suite for net-scp
ruby2.6-rubygem-net-scp-testsuite-1_1-1.1.2-2.14.x86_64.rpm Test suite for net-scp
ruby2.6-rubygem-net-scp-testsuite-1_2-1.2.1-1.1.i586.rpm Test suite for net-scp
Advertisement
Advertisement