ruby2.6-rubygem-listen-3_0-3.0.8-1.10.i586.rpm


Advertisement

Description

ruby2.6-rubygem-listen-3_0 - Listen to file modifications

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ruby2.6-rubygem-listen-3_0-3.0.8-1.10.i586.rpm
Package name ruby2.6-rubygem-listen-3_0
Package version 3.0.8
Package release 1.10
Package architecture i586
Package type rpm
Category Development/Languages/Ruby
Homepage https://github.com/guard/listen
License MIT
Maintainer -
Download size 62.12 KB
Installed size 104.37 KB
The Listen gem listens to file modifications and notifies you about the
changes. Works everywhere!.

Alternatives

Package Version Architecture Repository
ruby2.6-rubygem-listen-3_0-3.0.8-1.10.x86_64.rpm 3.0.8 x86_64 openSUSE Oss
ruby2.6-rubygem-listen-3_0 - - -

Requires

Name Value
/usr/bin/ruby.ruby2.6 -
ruby(abi) = 2.6.0
rubygem(ruby:2.6.0:rb-fsevent) >= 0.9.4
rubygem(ruby:2.6.0:rb-fsevent:0) >= 0.9
rubygem(ruby:2.6.0:rb-inotify) >= 0.9.7
rubygem(ruby:2.6.0:rb-inotify:0) >= 0.9
update-alternatives -

Provides

Name Value
ruby2.6-rubygem-listen-3_0 = 3.0.8-1.10
ruby2.6-rubygem-listen-3_0(x86-32) = 3.0.8-1.10
rubygem(listen) = 3.0.8
rubygem(ruby:2.6.0:listen) = 3.0.8
rubygem(ruby:2.6.0:listen:3) = 3.0.8
rubygem(ruby:2.6.0:listen:3.0) = 3.0.8
rubygem(ruby:2.6.0:listen:3.0.8) = 3.0.8

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ruby2.6-rubygem-listen-3_0-3.0.8-1.10.i586.rpm
Source Package rubygem-listen-3_0-3.0.8-1.10.src.rpm

Install Howto

Install ruby2.6-rubygem-listen-3_0 rpm package:

# zypper install ruby2.6-rubygem-listen-3_0

Files

Path
/etc/alternatives/listen
/etc/alternatives/listen-3.0.8
/etc/alternatives/listen.ruby2.6
/usr/bin/listen
/usr/bin/listen-3.0.8
/usr/bin/listen.ruby2.6
/usr/bin/listen.ruby2.6-3.0.8
/usr/lib/ruby/gems/2.6.0/cache/listen-3.0.8.gem
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/CHANGELOG.md
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/CONTRIBUTING.md
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/LICENSE.txt
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/README.md
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/bin/listen
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/adapter.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/backend.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/change.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/cli.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/directory.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/file.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/fsm.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/listener.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/logger.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/options.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/queue_optimizer.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/record.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/silencer.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/version.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/adapter/base.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/adapter/bsd.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/adapter/config.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/adapter/darwin.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/adapter/linux.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/adapter/polling.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/adapter/windows.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/event/config.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/event/loop.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/event/processor.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/event/queue.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/internals/thread_pool.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/listener/config.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/record/entry.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/record/symlink_detector.rb
/usr/lib/ruby/gems/2.6.0/gems/listen-3.0.8/lib/listen/silencer/controller.rb
/usr/lib/ruby/gems/2.6.0/specifications/listen-3.0.8.gemspec
/usr/share/doc/packages/ruby2.6-rubygem-listen-3_0/CHANGELOG.md
/usr/share/doc/packages/ruby2.6-rubygem-listen-3_0/LICENSE.txt
/usr/share/doc/packages/ruby2.6-rubygem-listen-3_0/README.md

Changelog

2016-07-04 - coolo@suse.com
- updated to version 3.0.8
see installed CHANGELOG.md
2016-07-04 - coolo@suse.com
- split off 3.0 as rails 5 requires it
2016-02-10 - coolo@suse.com
- updated to version 3.0.6
see installed CHANGELOG.md
2015-11-23 - coolo@suse.com
- updated to version 3.0.5
see installed CHANGELOG.md
2015-11-05 - coolo@suse.com
- updated to version 3.0.4
see installed CHANGELOG.md
2015-07-24 - coolo@suse.com
- updated to version 3.0.3
see installed CHANGELOG.md
2015-07-10 - coolo@suse.com
- updated to version 3.0.2
see installed CHANGELOG.md
2015-07-01 - coolo@suse.com
- updated to version 3.0.1
see installed CHANGELOG.md
2015-06-29 - coolo@suse.com
- updated to version 3.0.0
see installed CHANGELOG.md
2015-06-19 - coolo@suse.com
- updated to version 2.10.1
see installed CHANGELOG.md

See Also

Package Description
ruby2.6-rubygem-listen-doc-3.1.5-1.10.i586.rpm RDoc documentation for listen
ruby2.6-rubygem-listen-doc-3.1.5-1.10.x86_64.rpm RDoc documentation for listen
ruby2.6-rubygem-listen-doc-3_0-3.0.8-1.10.i586.rpm RDoc documentation for listen
ruby2.6-rubygem-listen-doc-3_0-3.0.8-1.10.x86_64.rpm RDoc documentation for listen
ruby2.6-rubygem-little-plugger-1.1.4-1.8.i586.rpm LittlePlugger is a module that provides Gem based plugin management
ruby2.6-rubygem-little-plugger-1.1.4-1.8.x86_64.rpm LittlePlugger is a module that provides Gem based plugin management
ruby2.6-rubygem-little-plugger-doc-1.1.4-1.8.i586.rpm RDoc documentation for little-plugger
ruby2.6-rubygem-little-plugger-doc-1.1.4-1.8.x86_64.rpm RDoc documentation for little-plugger
ruby2.6-rubygem-little-plugger-testsuite-1.1.4-1.8.i586.rpm Test suite for little-plugger
ruby2.6-rubygem-little-plugger-testsuite-1.1.4-1.8.x86_64.rpm Test suite for little-plugger
ruby2.6-rubygem-locale-2.1.2-1.12.i586.rpm Ruby-Locale is the pure ruby library which provides basic APIs for
ruby2.6-rubygem-locale-2.1.2-1.12.x86_64.rpm Ruby-Locale is the pure ruby library which provides basic APIs for
ruby2.6-rubygem-locale-doc-2.1.2-1.12.i586.rpm RDoc documentation for locale
ruby2.6-rubygem-locale-doc-2.1.2-1.12.x86_64.rpm RDoc documentation for locale
ruby2.6-rubygem-locale-testsuite-2.1.2-1.12.i586.rpm Test suite for locale
Advertisement
Advertisement