ruby2.6-rubygem-launchy-2.4.3-1.13.x86_64.rpm


Advertisement

Description

ruby2.6-rubygem-launchy - Launchy is helper class for launching cross-platform applications in

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ruby2.6-rubygem-launchy-2.4.3-1.13.x86_64.rpm
Package name ruby2.6-rubygem-launchy
Package version 2.4.3
Package release 1.13
Package architecture x86_64
Package type rpm
Category Development/Languages/Ruby
Homepage http://github.com/copiousfreetime/launchy
License ISC
Maintainer -
Download size 59.50 KB
Installed size 86.97 KB
Launchy is helper class for launching cross-platform applications in a fire
and forget manner. There are application concepts (browser, email client, etc)
that are common across all platforms, and they may be launched differently on
each platform. Launchy is here to make a common approach to launching external
application from within ruby programs.

Alternatives

Package Version Architecture Repository
ruby2.6-rubygem-launchy-2.4.3-1.13.i586.rpm 2.4.3 i586 openSUSE Oss
ruby2.6-rubygem-launchy - - -

Requires

Name Value
/usr/bin/ruby.ruby2.6 -
ruby(abi) = 2.6.0
rubygem(ruby:2.6.0:addressable:2) >= 2.3
update-alternatives -

Provides

Name Value
ruby2.6-rubygem-launchy = 2.4.3-1.13
ruby2.6-rubygem-launchy(x86-64) = 2.4.3-1.13
rubygem(launchy) = 2.4.3
rubygem(ruby:2.6.0:launchy) = 2.4.3
rubygem(ruby:2.6.0:launchy:2) = 2.4.3
rubygem(ruby:2.6.0:launchy:2.4) = 2.4.3
rubygem(ruby:2.6.0:launchy:2.4.3) = 2.4.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ruby2.6-rubygem-launchy-2.4.3-1.13.x86_64.rpm
Source Package rubygem-launchy-2.4.3-1.13.src.rpm

Install Howto

Install ruby2.6-rubygem-launchy rpm package:

# zypper install ruby2.6-rubygem-launchy

Files

Path
/etc/alternatives/launchy
/etc/alternatives/launchy-2.4.3
/etc/alternatives/launchy.ruby2.6
/usr/bin/launchy
/usr/bin/launchy-2.4.3
/usr/bin/launchy.ruby2.6
/usr/bin/launchy.ruby2.6-2.4.3
/usr/lib64/ruby/gems/2.6.0/cache/launchy-2.4.3.gem
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/CONTRIBUTING.md
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/HISTORY.md
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/LICENSE
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/Manifest.txt
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/README.md
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/Rakefile
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/bin/launchy
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/lib/launchy.rb
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/lib/launchy/application.rb
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/lib/launchy/argv.rb
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/lib/launchy/cli.rb
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/lib/launchy/deprecated.rb
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/lib/launchy/descendant_tracker.rb
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/lib/launchy/detect.rb
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/lib/launchy/error.rb
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/lib/launchy/os_family.rb
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/lib/launchy/version.rb
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/lib/launchy/applications/browser.rb
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/lib/launchy/detect/host_os.rb
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/lib/launchy/detect/host_os_family.rb
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/lib/launchy/detect/nix_desktop_environment.rb
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/lib/launchy/detect/ruby_engine.rb
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/lib/launchy/detect/runner.rb
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/tasks/default.rake
/usr/lib64/ruby/gems/2.6.0/gems/launchy-2.4.3/tasks/this.rb
/usr/lib64/ruby/gems/2.6.0/specifications/launchy-2.4.3.gemspec
/usr/share/doc/packages/ruby2.6-rubygem-launchy/HISTORY.md
/usr/share/doc/packages/ruby2.6-rubygem-launchy/LICENSE
/usr/share/doc/packages/ruby2.6-rubygem-launchy/README.md

Changelog

2015-02-09 - coolo@suse.com
- updated to version 2.4.3
* Update documentation - <https://github.com/copiousfreetime/launchy/pull/81> - supremebeing7
* Fix launching of `exo-open` for XFCE - <https://github.com/copiousfreetime/launchy/issues/82> - dsandstrom
* Add iceweasel as a fallback browser - <https://github.com/copiousfreetime/launchy/pull/92> -  jackturnbull
* Reopen $stderr in really bad situation - <https://github.com/copiousfreetime/launchy/pull/77> - infertux
2013-11-29 - coolo@suse.com
- updated to version 2.4.2
* Fix kde issue - <https://github.com/copiousfreetime/launchy/issues/72>
2013-11-27 - coolo@suse.com
- updated to version 2.4.1
* Abstract out the argv of the commandline - <https://github.com/copiousfreetime/launchy/issues/71>
2013-11-22 - coolo@suse.com
- updated to version 2.4.0
* Support `Launchy.open( url, :debug => true )` - <http://github.com/copiousfreetime/launchy/issues/63> - schmich
* Fix inconsistencies in `debug?` and `dry_run?` methods - <http://github.com/copiousfreetime/launchy/issues/63> - schmich
* Fix detection of missing *nix desktops - <http://github.com/copiousfreetime/launchy/issues/70>
* Fix running tests in bare Linux environment - <http://github.com/copiousfreetime/launchy/issues/67> - gioele
* Fix mistaking windows drive as uri schema - <http://github.com/copiousfreetime/launchy/issues/65>
* Attempt fixing windows `start` command oddities, again - <http://github.com/copiousfreetime/launchy/issues/62>
2013-06-27 - coolo@suse.com
- fix usage of update-alternatives
2013-04-17 - coolo@suse.com
- updated to version 2.3.0
* Add the option to call a block on error instead of raising an exception
2013-02-12 - coolo@suse.com
- updated to version 2.2.0
* Change XFCE detection to not depend on grep (copiousfreetime/launchy#52 - thanks bogdan)
* Suppress forked process output (copiousfreetime/launchy#51)
* Display help/usage if no url is given (copiousfreetime/launchy#54)
* Detect the fluxbox environment (copiousfreetime/launchy#53)
* Automatically detect 'http' url's if they are missing the 'http://' (copiousfreetime/launchy#55)
* Update to latest project management rake tasks
2012-08-07 - coolo@suse.com
- updated to version 2.1.2
* Fix where HostOS would fail to convert to string on JRuby in 1.9 mode (copiousfreetime/launchy#45)
2010-06-11 - mrueckert@suse.de
- use rubygems_requires macro
2009-12-25 - prusnak@suse.cz
- update to 0.3.5

See Also

Package Description
ruby2.6-rubygem-launchy-doc-2.4.3-1.13.i586.rpm RDoc documentation for launchy
ruby2.6-rubygem-launchy-doc-2.4.3-1.13.x86_64.rpm RDoc documentation for launchy
ruby2.6-rubygem-launchy-testsuite-2.4.3-1.13.i586.rpm Test suite for launchy
ruby2.6-rubygem-launchy-testsuite-2.4.3-1.13.x86_64.rpm Test suite for launchy
ruby2.6-rubygem-levenshtein-0.2.2-9.24.i586.rpm Calculates the Levenshtein distance between two byte strings
ruby2.6-rubygem-levenshtein-0.2.2-9.24.x86_64.rpm Calculates the Levenshtein distance between two byte strings
ruby2.6-rubygem-levenshtein-doc-0.2.2-9.24.i586.rpm RDoc documentation for levenshtein
ruby2.6-rubygem-levenshtein-doc-0.2.2-9.24.x86_64.rpm RDoc documentation for levenshtein
ruby2.6-rubygem-levenshtein-testsuite-0.2.2-9.24.i586.rpm Test suite for levenshtein
ruby2.6-rubygem-levenshtein-testsuite-0.2.2-9.24.x86_64.rpm Test suite for levenshtein
ruby2.6-rubygem-librarian-0.1.2-4.13.i586.rpm A Framework for Bundlers
ruby2.6-rubygem-librarian-0.1.2-4.13.x86_64.rpm A Framework for Bundlers
ruby2.6-rubygem-librarian-doc-0.1.2-4.13.i586.rpm RDoc documentation for librarian
ruby2.6-rubygem-librarian-doc-0.1.2-4.13.x86_64.rpm RDoc documentation for librarian
ruby2.6-rubygem-librarian-testsuite-0.1.2-4.13.i586.rpm Test suite for librarian
Advertisement
Advertisement