ruby2.6-rubygem-jwt-doc-2.1.0-1.4.x86_64.rpm


Advertisement

Description

ruby2.6-rubygem-jwt-doc - RDoc documentation for jwt

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ruby2.6-rubygem-jwt-doc-2.1.0-1.4.x86_64.rpm
Package name ruby2.6-rubygem-jwt-doc
Package version 2.1.0
Package release 1.4
Package architecture x86_64
Package type rpm
Category Development/Languages/Ruby
Homepage http://github.com/jwt/ruby-jwt
License MIT
Maintainer -
Download size 36.16 KB
Installed size 30.56 KB
Documentation generated at gem installation time.
Usually in RDoc and RI formats.

Alternatives

Package Version Architecture Repository
ruby2.6-rubygem-jwt-doc-2.1.0-1.4.i586.rpm 2.1.0 i586 openSUSE Oss
ruby2.6-rubygem-jwt-doc - - -

Requires

Name Value
ruby2.6-rubygem-jwt = 2.1.0

Provides

Name Value
ruby2.6-rubygem-jwt-doc = 2.1.0-1.4
ruby2.6-rubygem-jwt-doc(x86-64) = 2.1.0-1.4

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ruby2.6-rubygem-jwt-doc-2.1.0-1.4.x86_64.rpm
Source Package rubygem-jwt-2.1.0-1.4.src.rpm

Install Howto

Install ruby2.6-rubygem-jwt-doc rpm package:

# zypper install ruby2.6-rubygem-jwt-doc

Files

Path
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/cache.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/allowed_algorithms-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/cdesc-JWT.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/decode-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/decode_verify_signature-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/encode-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/gem_version-c.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/signature_algorithm_and_key-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Algos/cdesc-Algos.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Algos/Ecdsa/cdesc-Ecdsa.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Algos/Ecdsa/sign-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Algos/Ecdsa/verify-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Algos/Eddsa/cdesc-Eddsa.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Algos/Eddsa/sign-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Algos/Eddsa/verify-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Algos/Hmac/cdesc-Hmac.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Algos/Hmac/sign-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Algos/Hmac/verify-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Algos/Rsa/cdesc-Rsa.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Algos/Rsa/sign-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Algos/Rsa/verify-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Algos/Unsupported/cdesc-Unsupported.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Algos/Unsupported/sign-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Algos/Unsupported/verify-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Decode/base64url_decode-c.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Decode/cdesc-Decode.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Decode/decode_header_and_payload-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Decode/decode_segments-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Decode/header-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Decode/new-c.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Decode/payload-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Decode/raw_segments-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Decode/signature-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/DecodeError/cdesc-DecodeError.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/DefaultOptions/cdesc-DefaultOptions.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Encode/algorithm-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Encode/base64url_encode-c.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Encode/cdesc-Encode.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Encode/encode_segments-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Encode/encoded_header-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Encode/encoded_payload-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Encode/encoded_signature-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Encode/header_fields-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Encode/key-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Encode/new-c.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Encode/payload-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Encode/segments-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/EncodeError/cdesc-EncodeError.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/ExpiredSignature/cdesc-ExpiredSignature.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/ImmatureSignature/cdesc-ImmatureSignature.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/IncorrectAlgorithm/cdesc-IncorrectAlgorithm.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/InvalidAudError/cdesc-InvalidAudError.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/InvalidIatError/cdesc-InvalidIatError.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/InvalidIssuerError/cdesc-InvalidIssuerError.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/InvalidJtiError/cdesc-InvalidJtiError.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/InvalidPayload/cdesc-InvalidPayload.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/InvalidSubError/cdesc-InvalidSubError.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/SecurityUtils/asn1_to_raw-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/SecurityUtils/cdesc-SecurityUtils.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/SecurityUtils/raw_to_asn1-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/SecurityUtils/rbnacl_fixup-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/SecurityUtils/secure_compare-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/SecurityUtils/verify_rsa-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Signature/cdesc-Signature.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Signature/sign-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Signature/verify-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/VERSION/cdesc-VERSION.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/VerificationError/cdesc-VerificationError.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Verify/cdesc-Verify.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Verify/exp_leeway-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Verify/global_leeway-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Verify/iat_leeway-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Verify/nbf_leeway-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Verify/new-c.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Verify/verify_aud-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Verify/verify_claims-c.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Verify/verify_expiration-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Verify/verify_iat-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Verify/verify_iss-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Verify/verify_jti-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Verify/verify_not_before-i.ri
/usr/lib64/ruby/gems/2.6.0/doc/jwt-2.1.0/ri/JWT/Verify/verify_sub-i.ri

Changelog

2017-10-11 - coolo@suse.com
- updated to version 2.1.0
see installed CHANGELOG.md
[#]# [2.1.0](https://github.com/jwt/ruby-jwt/tree/2.1.0) (2017-10-06)
[Full Changelog](https://github.com/jwt/ruby-jwt/compare/v2.0.0...2.1.0)
* *Implemented enhancements:**
- Ed25519 support planned? [\#217](https://github.com/jwt/ruby-jwt/issues/217)
- Verify JTI Proc [\#207](https://github.com/jwt/ruby-jwt/issues/207)
- Allow a list of algorithms for decode [\#241](https://github.com/jwt/ruby-jwt/pull/241) ([lautis](https://github.com/lautis))
- verify takes 2 params, second being payload closes: \#207 [\#238](https://github.com/jwt/ruby-jwt/pull/238) ([ab320012](https://github.com/ab320012))
- simplified logic for keyfinder [\#237](https://github.com/jwt/ruby-jwt/pull/237) ([ab320012](https://github.com/ab320012))
- Show backtrace if rbnacl-libsodium not loaded [\#231](https://github.com/jwt/ruby-jwt/pull/231) ([buzztaiki](https://github.com/buzztaiki))
- Support for ED25519 [\#229](https://github.com/jwt/ruby-jwt/pull/229) ([ab320012](https://github.com/ab320012))
* *Fixed bugs:**
- JWT.encode failing on encode for string [\#235](https://github.com/jwt/ruby-jwt/issues/235)
- The README says it uses an algorithm by default [\#226](https://github.com/jwt/ruby-jwt/issues/226)
- Fix string payload issue [\#236](https://github.com/jwt/ruby-jwt/pull/236) ([excpt](https://github.com/excpt))
* *Closed issues:**
- Change from 1.5.6 to 2.0.0 and appears a "Completed 401 Unauthorized" [\#240](https://github.com/jwt/ruby-jwt/issues/240)
- Why doesn't the decode function use a default algorithm? [\#227](https://github.com/jwt/ruby-jwt/issues/227)
* *Merged pull requests:**
- Update README.md [\#242](https://github.com/jwt/ruby-jwt/pull/242) ([excpt](https://github.com/excpt))
- Update ebert configuration [\#232](https://github.com/jwt/ruby-jwt/pull/232) ([excpt](https://github.com/excpt))
- added algos/strategy classes + structs for inputs [\#230](https://github.com/jwt/ruby-jwt/pull/230) ([ab320012](https://github.com/ab320012))
- Add HS256 algorithm to decode default options [\#228](https://github.com/jwt/ruby-jwt/pull/228) ([madkin10](https://github.com/madkin10))

See Also

Package Description
ruby2.6-rubygem-jwt-testsuite-1_5-1.5.6-1.3.i586.rpm Test suite for jwt
ruby2.6-rubygem-jwt-testsuite-1_5-1.5.6-1.3.x86_64.rpm Test suite for jwt
ruby2.6-rubygem-jwt-testsuite-2.1.0-1.4.i586.rpm Test suite for jwt
ruby2.6-rubygem-jwt-testsuite-2.1.0-1.4.x86_64.rpm Test suite for jwt
ruby2.6-rubygem-kgio-2.11.2-1.4.i586.rpm kinder, gentler I/O for Ruby
ruby2.6-rubygem-kgio-2.11.2-1.4.x86_64.rpm kinder, gentler I/O for Ruby
ruby2.6-rubygem-kgio-doc-2.11.2-1.4.i586.rpm RDoc documentation for kgio
ruby2.6-rubygem-kgio-doc-2.11.2-1.4.x86_64.rpm RDoc documentation for kgio
ruby2.6-rubygem-kgio-testsuite-2.11.2-1.4.i586.rpm Test suite for kgio
ruby2.6-rubygem-kgio-testsuite-2.11.2-1.4.x86_64.rpm Test suite for kgio
ruby2.6-rubygem-kramdown-1.17.0-1.3.i586.rpm kramdown is a fast, pure-Ruby Markdown-superset converter
ruby2.6-rubygem-kramdown-1.17.0-1.3.x86_64.rpm kramdown is a fast, pure-Ruby Markdown-superset converter
ruby2.6-rubygem-kramdown-doc-1.17.0-1.3.i586.rpm RDoc documentation for kramdown
ruby2.6-rubygem-kramdown-doc-1.17.0-1.3.x86_64.rpm RDoc documentation for kramdown
ruby2.6-rubygem-kramdown-testsuite-1.17.0-1.3.i586.rpm Test suite for kramdown
Advertisement
Advertisement