ruby2.6-rubygem-json-2.1.0-1.12.i586.rpm


Advertisement

Description

ruby2.6-rubygem-json - JSON Implementation for Ruby

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ruby2.6-rubygem-json-2.1.0-1.12.i586.rpm
Package name ruby2.6-rubygem-json
Package version 2.1.0
Package release 1.12
Package architecture i586
Package type rpm
Category Development/Languages/Ruby
Homepage http://flori.github.com/json
License Ruby
Maintainer -
Download size 288.50 KB
Installed size 802.47 KB
This is a JSON implementation as a Ruby extension in C.

Alternatives

Package Version Architecture Repository
ruby2.6-rubygem-json-2.1.0-1.12.x86_64.rpm 2.1.0 x86_64 openSUSE Oss
ruby2.6-rubygem-json - - -

Requires

Name Value
/usr/bin/ruby.ruby2.6 -
libc.so.6(GLIBC_2.4) -
libruby2.6.so.2.6 -
ruby(abi) = 2.6.0

Provides

Name Value
ruby2.6-rubygem-json = 2.1.0-1.12
ruby2.6-rubygem-json(x86-32) = 2.1.0-1.12
rubygem(json) = 2.1.0
rubygem(ruby:2.6.0:json) = 2.1.0
rubygem(ruby:2.6.0:json:2) = 2.1.0
rubygem(ruby:2.6.0:json:2.1) = 2.1.0
rubygem(ruby:2.6.0:json:2.1.0) = 2.1.0

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ruby2.6-rubygem-json-2.1.0-1.12.i586.rpm
Source Package rubygem-json-2.1.0-1.12.src.rpm

Install Howto

Install ruby2.6-rubygem-json rpm package:

# zypper install ruby2.6-rubygem-json

Files

Path
/usr/lib/ruby/gems/2.6.0/cache/json-2.1.0.gem
/usr/lib/ruby/gems/2.6.0/extensions/x86-linux/2.6.0/json-2.1.0/gem.build_complete
/usr/lib/ruby/gems/2.6.0/extensions/x86-linux/2.6.0/json-2.1.0/json/
/usr/lib/ruby/gems/2.6.0/extensions/x86-linux/2.6.0/json-2.1.0/json/ext/generator.so
/usr/lib/ruby/gems/2.6.0/extensions/x86-linux/2.6.0/json-2.1.0/json/ext/parser.so
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/.gitignore
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/.travis.yml
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/CHANGES.md
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/Gemfile
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/README-json-jruby.md
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/README.md
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/Rakefile
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/VERSION
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/install.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/json-java.gemspec
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/json.gemspec
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/json_pure.gemspec
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/data/example.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/data/index.html
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/data/prototype.js
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/diagrams/.keep
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/ext/
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/ext/json/extconf.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/ext/json/ext/
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/ext/json/ext/fbuffer/fbuffer.h
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/ext/json/ext/generator/.sitearchdir.-.json.-.ext.time
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/ext/json/ext/generator/depend
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/ext/json/ext/generator/extconf.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/ext/json/ext/generator/generator.c
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/ext/json/ext/generator/generator.h
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/ext/json/ext/generator/generator.so
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/ext/json/ext/parser/.sitearchdir.-.json.-.ext.time
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/ext/json/ext/parser/depend
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/ext/json/ext/parser/extconf.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/ext/json/ext/parser/parser.c
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/ext/json/ext/parser/parser.h
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/ext/json/ext/parser/parser.rl
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/ext/json/ext/parser/parser.so
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/java/
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/java/src/
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/java/src/json/
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/java/src/json/ext/ByteListTranscoder.java
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/java/src/json/ext/Generator.java
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/java/src/json/ext/GeneratorMethods.java
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/java/src/json/ext/GeneratorService.java
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/java/src/json/ext/GeneratorState.java
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/java/src/json/ext/OptionsReader.java
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/java/src/json/ext/Parser.java
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/java/src/json/ext/Parser.rl
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/java/src/json/ext/ParserService.java
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/java/src/json/ext/RuntimeInfo.java
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/java/src/json/ext/StringDecoder.java
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/java/src/json/ext/StringEncoder.java
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/java/src/json/ext/Utils.java
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/common.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/ext.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/generic_object.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/pure.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/version.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/add/bigdecimal.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/add/complex.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/add/core.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/add/date.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/add/date_time.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/add/exception.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/add/ostruct.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/add/range.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/add/rational.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/add/regexp.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/add/struct.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/add/symbol.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/add/time.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/ext/.keep
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/ext/generator.so
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/ext/parser.so
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/pure/generator.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/lib/json/pure/parser.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/references/rfc7159.txt
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/json_addition_test.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/json_common_interface_test.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/json_encoding_test.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/json_ext_parser_test.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/json_fixtures_test.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/json_generator_test.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/json_generic_object_test.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/json_parser_test.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/json_string_matching_test.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/test_helper.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail10.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail11.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail12.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail13.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail14.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail18.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail19.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail2.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail20.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail21.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail22.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail23.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail24.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail25.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail27.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail28.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail3.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail4.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail5.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail6.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail7.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail8.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/fail9.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/obsolete_fail1.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/pass1.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/pass15.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/pass16.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/pass17.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/pass2.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/pass26.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tests/fixtures/pass3.json
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tools/diff.sh
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tools/fuzz.rb
/usr/lib/ruby/gems/2.6.0/gems/json-2.1.0/tools/server.rb
/usr/lib/ruby/gems/2.6.0/specifications/json-2.1.0.gemspec
/usr/share/doc/packages/ruby2.6-rubygem-json/CHANGES.md
/usr/share/doc/packages/ruby2.6-rubygem-json/README.md

Changelog

2017-04-19 - coolo@suse.com
- updated to version 2.1.0
see installed CHANGES.md
[#]# 2017-04-18 (2.1.0)
* Allow passing of `decimal_class` option to specify a class as which to parse
JSON float numbers.
2017-04-12 - coolo@suse.com
- updated to version 2.0.4
see installed CHANGES.md
[#]# 2017-03-23 (2.0.4)
* Raise exception for incomplete unicode surrogates/character escape
sequences. This problem was reported by Daniel Gollahon (dgollahon).
* Fix arbitrary heap exposure problem. This problem was reported by Ahmad
Sherif (ahmadsherif).
2017-01-14 - coolo@suse.com
- updated to version 2.0.3
see installed CHANGES.md
[#]# 2017-01-12 (2.0.3)
* Set `required_ruby_version` to 1.9
* Some small fixes
2016-07-27 - coolo@suse.com
- updated to version 2.0.2
see installed CHANGES.md
[#]# 2016-07-26 (2.0.2)
* Specify `required_ruby_version` for json\_pure.
* Fix issue #295 failure when parsing frozen strings.
2016-07-02 - coolo@suse.com
- updated to version 2.0.1
CHANGES removed upstream
2015-06-03 - coolo@suse.com
- updated to version 1.8.3
see installed CHANGES
2015-06-01 (1.8.3)
* Fix potential memory leak, thx to nobu.
2015-02-04 - coolo@suse.com
- rename rpmlintrc and add it as source
2015-02-04 - hvogel@suse.com
- update to 1.8.2
* Some performance improvements by Vipul A M <vipulnsward@gmail.com>.
* Fix by Jason R. Clark <jclark@newrelic.com> to avoid mutation of
JSON.dump_default_options.
* More tests by Michael Mac-Vicar <mmacvicar@gmail.com> and fixing
space_before accessor in generator.
* Performance on Jruby improvemed by Ben Browning <bbrownin@redhat.com>.
* Some fixes to be compatible with the new Ruby 2.2 by
Zachary Scott <e@zzak.io> and SHIBATA Hiroshi <hsbt@ruby-lang.org>.
2014-09-30 - mrueckert@suse.de
- update to new packaging scheme and add gem2rpm.yml
- disable documentation to disable a loop between rdoc and json
2014-02-06 - coolo@suse.com
- use new macros

See Also

Package Description
ruby2.6-rubygem-json-doc-2.1.0-1.12.i586.rpm RDoc documentation for json
ruby2.6-rubygem-json-doc-2.1.0-1.12.x86_64.rpm RDoc documentation for json
ruby2.6-rubygem-json-jwt-1.10.0-1.1.i586.rpm JSON Web Token and its family (JSON Web Signature, JSON Web
ruby2.6-rubygem-json-jwt-1.10.0-1.1.x86_64.rpm JSON Web Token and its family (JSON Web Signature, JSON Web
ruby2.6-rubygem-json-jwt-doc-1.10.0-1.1.i586.rpm RDoc documentation for json-jwt
ruby2.6-rubygem-json-jwt-doc-1.10.0-1.1.x86_64.rpm RDoc documentation for json-jwt
ruby2.6-rubygem-json-jwt-testsuite-1.10.0-1.1.i586.rpm Test suite for json-jwt
ruby2.6-rubygem-json-jwt-testsuite-1.10.0-1.1.x86_64.rpm Test suite for json-jwt
ruby2.6-rubygem-json-schema-2.8.1-1.3.i586.rpm Ruby JSON Schema Validator
ruby2.6-rubygem-json-schema-2.8.1-1.3.x86_64.rpm Ruby JSON Schema Validator
ruby2.6-rubygem-json-schema-2_2-2.2.5-1.5.i586.rpm Ruby JSON Schema Validator
ruby2.6-rubygem-json-schema-2_2-2.2.5-1.5.x86_64.rpm Ruby JSON Schema Validator
ruby2.6-rubygem-json-schema-doc-2.8.1-1.3.i586.rpm RDoc documentation for json-schema
ruby2.6-rubygem-json-schema-doc-2.8.1-1.3.x86_64.rpm RDoc documentation for json-schema
ruby2.6-rubygem-json-schema-doc-2_2-2.2.5-1.5.i586.rpm RDoc documentation for json-schema
Advertisement
Advertisement