ruby2.6-rubygem-hashie-testsuite-3.6.0-1.3.i586.rpm


Advertisement

Description

ruby2.6-rubygem-hashie-testsuite - Test suite for hashie

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ruby2.6-rubygem-hashie-testsuite-3.6.0-1.3.i586.rpm
Package name ruby2.6-rubygem-hashie-testsuite
Package version 3.6.0
Package release 1.3
Package architecture i586
Package type rpm
Category Development/Languages/Ruby
Homepage https://github.com/intridea/hashie
License MIT
Maintainer -
Download size 56.66 KB
Installed size 144.77 KB
Test::Unit or RSpec files, useful for developers.

Alternatives

Package Version Architecture Repository
ruby2.6-rubygem-hashie-testsuite-3.6.0-1.3.x86_64.rpm 3.6.0 x86_64 openSUSE Oss
ruby2.6-rubygem-hashie-testsuite - - -

Requires

Name Value
ruby2.6-rubygem-hashie = 3.6.0

Provides

Name Value
ruby2.6-rubygem-hashie-testsuite = 3.6.0-1.3
ruby2.6-rubygem-hashie-testsuite(x86-32) = 3.6.0-1.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ruby2.6-rubygem-hashie-testsuite-3.6.0-1.3.i586.rpm
Source Package rubygem-hashie-3.6.0-1.3.src.rpm

Install Howto

Install ruby2.6-rubygem-hashie-testsuite rpm package:

# zypper install ruby2.6-rubygem-hashie-testsuite

Files

Path
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/spec_helper.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/array_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/clash_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/dash_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/hash_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/mash_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/rash_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/trash_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/utils_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/version_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/extensions/autoload_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/extensions/coercion_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/extensions/deep_fetch_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/extensions/deep_find_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/extensions/deep_locate_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/extensions/deep_merge_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/extensions/ignore_undeclared_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/extensions/indifferent_access_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/extensions/indifferent_access_with_rails_hwia_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/extensions/key_conversion_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/extensions/merge_initializer_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/extensions/method_access_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/extensions/strict_key_access_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/extensions/stringify_keys_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/extensions/symbolize_keys_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/extensions/dash/coercion_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/extensions/dash/indifferent_access_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/extensions/mash/keep_original_keys_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/extensions/mash/safe_assignment_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/extensions/mash/symbolize_keys_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/hashie/parsers/yaml_erb_parser_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/integration/
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/integration/elasticsearch/integration_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/integration/omniauth/app.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/integration/omniauth/integration_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/integration/omniauth-oauth2/app.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/integration/omniauth-oauth2/integration_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/integration/omniauth-oauth2/some_site.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/integration/rails/app.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/integration/rails/integration_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/integration/rails-without-dependency/integration_spec.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/support/integration_specs.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/support/logger.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/support/module_context.rb
/usr/lib/ruby/gems/2.6.0/gems/hashie-3.6.0/spec/support/ruby_version_check.rb

Changelog

2018-09-05 - coolo@suse.com
- updated to version 3.6.0
see installed CHANGELOG.md
[#]# [3.6.0] - 2018-08-13
[3.6.0]: https://github.com/intridea/hashie/compare/v3.5.7...v3.6.0
[#]## Added
* [#455](https://github.com/intridea/hashie/pull/455): Allow overriding methods when passing in a hash - [@lnestor](https://github.com/lnestor).
[#]## Fixed
* [#435](https://github.com/intridea/hashie/pull/435): Mash `default_proc`s are now propagated down to nested sub-Hashes - [@michaelherold](https://github.com/michaelherold).
* [#436](https://github.com/intridea/hashie/pull/436): Ensure that `Hashie::Extensions::IndifferentAccess` injects itself after a non-destructive merge - [@michaelherold](https://github.com/michaelherold).
* [#437](https://github.com/intridea/hashie/pull/437): Allow codependent properties to be set on Dash - [@michaelherold](https://github.com/michaelherold).
* [#438](https://github.com/intridea/hashie/pull/438): Fix: `NameError (uninitialized constant Hashie::Extensions::Parsers::YamlErbParser::Pathname)` in `Hashie::Mash.load` - [@onk](https://github.com/onk).
* [#457](https://github.com/intridea/hashie/pull/457): Fix `Trash` to allow it to copy properties from other properties - [@michaelherold](https://github.com/michaelherold).
[#]## Miscellaneous
* [#433](https://github.com/intridea/hashie/pull/433): Update Rubocop to the most recent version - [@michaelherold](https://github.com/michaelherold).
* [#434](https://github.com/intridea/hashie/pull/434): Add documentation around Mash sub-Hashes - [@michaelherold](https://github.com/michaelherold).
* [#439](https://github.com/intridea/hashie/pull/439): Add an integration spec for Elasticsearch - [@michaelherold](https://github.com/michaelherold).
2018-01-09 - coolo@suse.com
- updated to version 3.5.7
see installed CHANGELOG.md
[#]# [3.5.7] - 2017-12-19
[3.5.7]: https://github.com/intridea/hashie/compare/v3.5.6...v3.5.7
[#]## Fixed
[#430](https://github.com/intridea/hashie/pull/430): Fix Hashie::Rash randomly losing items - [@Antti](https://github.com/Antti)
[#]## Miscellaneous
* [#425](https://github.com/intridea/hashie/pull/425): Update rubies in CI - [@kachick](https://github.com/kachick).
2017-08-03 - coolo@suse.com
- updated to version 3.5.6
see installed CHANGELOG.md
[#]# [3.5.6] - 2017-07-12
[3.5.6]: https://github.com/intridea/hashie/compare/v3.5.5...v3.5.6
[#]## Miscellaneous
* [#416](https://github.com/intridea/hashie/pull/416): Fix `warning: instance variable @disable_warnings not initialized` - [@axfcampos](https://github.com/axfcampos).
* Your contribution here.
2017-03-16 - coolo@suse.com
- updated to version 3.5.5
see installed CHANGELOG.md
[#]# [3.5.5] - 2017-02-24
[3.5.5]: https://github.com/intridea/hashie/compare/v3.5.4...v3.5.5
[#]## Added
* [#326](https://github.com/intridea/hashie/pull/326): Added `Hashie::Extensions::Mash::KeepOriginalKeys` to give Mashes the ability to keep the original structure given to it - [@michaelherold](https://github.com/michaelherold).
[#]## Fixed
* [#415](https://github.com/intridea/hashie/pull/415): Fixed Mash logging keys multiple times which lead to a bad user experience or, in some cases, errors - [@michaelherold](https://github.com/michaelherold).
[#]# [3.5.4] - 2017-02-22
[3.5.4]: https://github.com/intridea/hashie/compare/v3.5.3...v3.5.4
[#]## Added
* [#412](https://github.com/intridea/hashie/pull/412): Added a Hashie::Extensions::Mash::SymbolizeKeys extension that overrides the default stringification behavior for keys - [@michaelherold](https://github.com/michaelherold).
[#]## Fixed
* [#409](https://github.com/intridea/hashie/pull/409): Fixed Railtie detection for projects where Rails is defined but Railties are not availble - [@CallumD](https://github.com/callumd).
* [#411](https://github.com/intridea/hashie/pull/411): Fixed a performance regression from 3.4.3 that caused a 10x slowdown in OmniAuth - [@michaelherold](https://github.com/michaelherold).

See Also

Package Description
ruby2.6-rubygem-highline-1_6-1.6.21-1.12.i586.rpm HighLine is a high-level command-line IO library
ruby2.6-rubygem-highline-1_6-1.6.21-1.12.x86_64.rpm HighLine is a high-level command-line IO library
ruby2.6-rubygem-highline-1_7-1.7.10-1.3.i586.rpm HighLine is a high-level command-line IO library
ruby2.6-rubygem-highline-1_7-1.7.10-1.3.x86_64.rpm HighLine is a high-level command-line IO library
ruby2.6-rubygem-highline-2.0.0-1.4.i586.rpm HighLine is a high-level command-line IO library
ruby2.6-rubygem-highline-2.0.0-1.4.x86_64.rpm HighLine is a high-level command-line IO library
ruby2.6-rubygem-highline-doc-1_6-1.6.21-1.12.i586.rpm RDoc documentation for highline
ruby2.6-rubygem-highline-doc-1_6-1.6.21-1.12.x86_64.rpm RDoc documentation for highline
ruby2.6-rubygem-highline-doc-1_7-1.7.10-1.3.i586.rpm RDoc documentation for highline
ruby2.6-rubygem-highline-doc-1_7-1.7.10-1.3.x86_64.rpm RDoc documentation for highline
ruby2.6-rubygem-highline-doc-2.0.0-1.4.i586.rpm RDoc documentation for highline
ruby2.6-rubygem-highline-doc-2.0.0-1.4.x86_64.rpm RDoc documentation for highline
ruby2.6-rubygem-highline-testsuite-1_6-1.6.21-1.12.i586.rpm Test suite for highline
ruby2.6-rubygem-highline-testsuite-1_6-1.6.21-1.12.x86_64.rpm Test suite for highline
ruby2.6-rubygem-highline-testsuite-1_7-1.7.10-1.3.i586.rpm Test suite for highline
Advertisement
Advertisement