ruby2.6-rubygem-excon-0.62.0-1.3.x86_64.rpm


Advertisement

Description

ruby2.6-rubygem-excon - speed, persistence, http(s)

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ruby2.6-rubygem-excon-0.62.0-1.3.x86_64.rpm
Package name ruby2.6-rubygem-excon
Package version 0.62.0
Package release 1.3
Package architecture x86_64
Package type rpm
Category Development/Languages/Ruby
Homepage https://github.com/excon/excon
License MIT
Maintainer -
Download size 454.41 KB
Installed size 780.37 KB
EXtended http(s) CONnections.

Alternatives

Package Version Architecture Repository
ruby2.6-rubygem-excon-0.62.0-1.3.i586.rpm 0.62.0 i586 openSUSE Oss
ruby2.6-rubygem-excon - - -

Requires

Name Value
/usr/bin/ruby.ruby2.6 -
ruby(abi) = 2.6.0

Provides

Name Value
ruby2.6-rubygem-excon = 0.62.0-1.3
ruby2.6-rubygem-excon(x86-64) = 0.62.0-1.3
rubygem(excon) = 0.62.0
rubygem(ruby:2.6.0:excon) = 0.62.0
rubygem(ruby:2.6.0:excon:0) = 0.62.0
rubygem(ruby:2.6.0:excon:0.62) = 0.62.0
rubygem(ruby:2.6.0:excon:0.62.0) = 0.62.0

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ruby2.6-rubygem-excon-0.62.0-1.3.x86_64.rpm
Source Package rubygem-excon-0.62.0-1.3.src.rpm

Install Howto

Install ruby2.6-rubygem-excon rpm package:

# zypper install ruby2.6-rubygem-excon

Files

Path
/usr/lib64/ruby/gems/2.6.0/cache/excon-0.62.0.gem
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/.document
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/.gitignore
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/.rspec
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/.travis.yml
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/CONTRIBUTING.md
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/CONTRIBUTORS.md
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/Gemfile
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/LICENSE.md
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/README.md
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/Rakefile
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/changelog.txt
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/excon.gemspec
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/benchmarks/class_vs_lambda.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/benchmarks/concat_vs_insert.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/benchmarks/concat_vs_interpolate.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/benchmarks/cr_lf.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/benchmarks/downcase-eq-eq_vs_casecmp.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/benchmarks/excon.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/benchmarks/excon_vs.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/benchmarks/for_vs_array_each.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/benchmarks/for_vs_hash_each.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/benchmarks/has_key-vs-lookup.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/benchmarks/headers_case_sensitivity.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/benchmarks/headers_split_vs_match.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/benchmarks/implicit_block-vs-explicit_block.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/benchmarks/merging.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/benchmarks/single_vs_double_quotes.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/benchmarks/string_ranged_index.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/benchmarks/strip_newline.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/benchmarks/vs_stdlib.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/data/cacert.pem
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/connection.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/constants.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/error.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/headers.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/pretty_printer.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/response.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/socket.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/ssl_socket.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/unix_socket.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/utils.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/version.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/extensions/uri.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/instrumentors/logging_instrumentor.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/instrumentors/standard_instrumentor.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/middlewares/base.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/middlewares/capture_cookies.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/middlewares/decompress.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/middlewares/escape_path.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/middlewares/expects.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/middlewares/idempotent.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/middlewares/instrumentor.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/middlewares/mock.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/middlewares/redirect_follower.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/middlewares/response_parser.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/test/server.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/test/plugin/
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/test/plugin/server/exec.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/test/plugin/server/puma.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/test/plugin/server/unicorn.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/lib/excon/test/plugin/server/webrick.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/authorization_header_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/bad_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/basic_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/batch_requests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/complete_responses.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/error_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/header_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/pipeline_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/proxy_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/query_string_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/request_headers_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/request_method_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/request_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/response_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/test_helper.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/thread_safety_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/timeout_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/utils_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/data/127.0.0.1.cert.crt
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/data/127.0.0.1.cert.key
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/data/excon.cert.crt
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/data/excon.cert.key
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/data/xs
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/middlewares/canned_response_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/middlewares/capture_cookies_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/middlewares/decompress_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/middlewares/escape_path_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/middlewares/idempotent_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/middlewares/instrumentation_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/middlewares/mock_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/middlewares/redirect_follower_tests.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/rackups/basic.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/rackups/basic.ru
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/rackups/basic_auth.ru
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/rackups/deflater.ru
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/rackups/proxy.ru
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/rackups/query_string.ru
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/rackups/redirecting.ru
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/rackups/redirecting_with_cookie.ru
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/rackups/request_headers.ru
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/rackups/request_methods.ru
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/rackups/response_header.ru
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/rackups/ssl.ru
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/rackups/ssl_mismatched_cn.ru
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/rackups/ssl_verify_peer.ru
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/rackups/streaming.ru
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/rackups/thread_safety.ru
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/rackups/timeout.ru
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/rackups/webrick_patch.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/servers/bad.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/servers/eof.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/servers/error.rb
/usr/lib64/ruby/gems/2.6.0/gems/excon-0.62.0/tests/servers/good.rb
/usr/lib64/ruby/gems/2.6.0/specifications/excon-0.62.0.gemspec
/usr/share/doc/packages/ruby2.6-rubygem-excon/LICENSE.md
/usr/share/doc/packages/ruby2.6-rubygem-excon/README.md
/usr/share/doc/packages/ruby2.6-rubygem-excon/changelog.txt

Changelog

2018-03-28 - factory-auto@kulow.org
- updated to version 0.62.0
see installed changelog.txt
0.62.0 2018-03-27
=================
remove binmode call for StringIO objects
2018-03-20 - factory-auto@kulow.org
- updated to version 0.61.0
see installed changelog.txt
0.61.0 2018-03-16
=================
use default ports for sockets if none specified
add ruby 2.4 and 2.5 to ci testing
follow relative location redirects
2018-01-09 - coolo@suse.com
- updated to version 0.60.0
see installed changelog.txt
0.60.0 2017-12-15
=================
add requests_in_batches
cleanup rakefile, gemfile, etc
add logger/logger= and logging instrumentor
rewind response_block in idempotent instrumentor
2017-09-11 - coolo@suse.com
- updated to version 0.59.0
see installed changelog.txt
0.59.0 2017-09-05
=================
fix backtick vs quote in error message
fix socket pooling to be per-connection instead of per thread
fix tests to ignore proxy env settings
0.58.0 08/01/2017
=================
remove unused error
add retry_interval and related settings for backoff
2017-08-03 - coolo@suse.com
- updated to version 0.58.0
see installed changelog.txt
0.57.1 06/30/2017
=================
fix remote-ip setting to prevent off-by-one issue
2017-06-20 - coolo@suse.com
- updated to version 0.57.0
see installed changelog.txt
0.57.0 06/14/2017
=================
add client_key_data and client_cert_data to valid keys
allow passing explicit host to unix sockets
2017-06-06 - coolo@suse.com
- updated to version 0.56.0
see installed changelog.txt
0.56.0 05/31/2017
=================
fix proxy parse errors
fix url-escaped proxy creds for ssl
2017-02-08 - coolo@suse.com
- updated to version 0.55.0
see installed changelog.txt
0.55.0 02/07/2017
=================
fix minor readme error
update bundled certs
update self-signed certs
update to test with ruby 2.3.3
fix unitialized ResponseParseError error
add missing 'spec_helper' require in tests
add missing 'time' require in tests
use unescape_uri for user/pass in Authorization header
use secure rubygems source uri
update gemnasium badge
update fury badge
update travis badge
update gittip badge
2016-10-18 - coolo@suse.com
- updated to version 0.54.0
see installed changelog.txt
2016-09-28 - coolo@suse.com
- updated to version 0.53.0
see installed changelog.txt
0.32.0 09/27/2016
=================
add ability to pass ssl options as strings
progress towards rspec
update bundled certs

See Also

Package Description
ruby2.6-rubygem-excon-doc-0.62.0-1.3.i586.rpm RDoc documentation for excon
ruby2.6-rubygem-excon-doc-0.62.0-1.3.x86_64.rpm RDoc documentation for excon
ruby2.6-rubygem-excon-testsuite-0.62.0-1.3.i586.rpm Test suite for excon
ruby2.6-rubygem-excon-testsuite-0.62.0-1.3.x86_64.rpm Test suite for excon
ruby2.6-rubygem-execjs-2.7.0-1.12.i586.rpm Run JavaScript code from Ruby
ruby2.6-rubygem-execjs-2.7.0-1.12.x86_64.rpm Run JavaScript code from Ruby
ruby2.6-rubygem-execjs-doc-2.7.0-1.12.i586.rpm RDoc documentation for execjs
ruby2.6-rubygem-execjs-doc-2.7.0-1.12.x86_64.rpm RDoc documentation for execjs
ruby2.6-rubygem-extlib-0.9.16-7.13.i586.rpm Support library for Merb
ruby2.6-rubygem-extlib-0.9.16-7.13.x86_64.rpm Support library for Merb
ruby2.6-rubygem-extlib-doc-0.9.16-7.13.i586.rpm RDoc documentation for extlib
ruby2.6-rubygem-extlib-doc-0.9.16-7.13.x86_64.rpm RDoc documentation for extlib
ruby2.6-rubygem-extlib-testsuite-0.9.16-7.13.i586.rpm Test suite for extlib
ruby2.6-rubygem-extlib-testsuite-0.9.16-7.13.x86_64.rpm Test suite for extlib
ruby2.6-rubygem-factory_girl-4.9.0-1.6.i586.rpm factory_girl provides a framework and DSL for defining and using
Advertisement
Advertisement