ruby2.6-rubygem-columnize-0.9.0-1.14.x86_64.rpm


Advertisement

Description

ruby2.6-rubygem-columnize - Module to format an Array as an Array of String aligned in columns

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ruby2.6-rubygem-columnize-0.9.0-1.14.x86_64.rpm
Package name ruby2.6-rubygem-columnize
Package version 0.9.0
Package release 1.14
Package architecture x86_64
Package type rpm
Category Development/Languages/Ruby
Homepage https://github.com/rocky/columnize
License Ruby and GPL-2.0
Maintainer -
Download size 36.50 KB
Installed size 50.53 KB
In showing a long lists, sometimes one would prefer to see the value
arranged aligned in columns. Some examples include listing methods
of an object or debugger commands.
See Examples in the rdoc documentation for examples.

Alternatives

Package Version Architecture Repository
ruby2.6-rubygem-columnize-0.9.0-1.14.i586.rpm 0.9.0 i586 openSUSE Oss
ruby2.6-rubygem-columnize - - -

Requires

Name Value
ruby(abi) = 2.6.0

Provides

Name Value
ruby2.6-rubygem-columnize = 0.9.0-1.14
ruby2.6-rubygem-columnize(x86-64) = 0.9.0-1.14
rubygem(columnize) = 0.9.0
rubygem(ruby:2.6.0:columnize) = 0.9.0
rubygem(ruby:2.6.0:columnize:0) = 0.9.0
rubygem(ruby:2.6.0:columnize:0.9) = 0.9.0
rubygem(ruby:2.6.0:columnize:0.9.0) = 0.9.0

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ruby2.6-rubygem-columnize-0.9.0-1.14.x86_64.rpm
Source Package rubygem-columnize-0.9.0-1.14.src.rpm

Install Howto

Install ruby2.6-rubygem-columnize rpm package:

# zypper install ruby2.6-rubygem-columnize

Files

Path
/usr/lib64/ruby/gems/2.6.0/cache/columnize-0.9.0.gem
/usr/lib64/ruby/gems/2.6.0/gems/columnize-0.9.0/.gitignore
/usr/lib64/ruby/gems/2.6.0/gems/columnize-0.9.0/.travis.yml
/usr/lib64/ruby/gems/2.6.0/gems/columnize-0.9.0/AUTHORS
/usr/lib64/ruby/gems/2.6.0/gems/columnize-0.9.0/COPYING
/usr/lib64/ruby/gems/2.6.0/gems/columnize-0.9.0/ChangeLog
/usr/lib64/ruby/gems/2.6.0/gems/columnize-0.9.0/Gemfile
/usr/lib64/ruby/gems/2.6.0/gems/columnize-0.9.0/Gemfile.lock
/usr/lib64/ruby/gems/2.6.0/gems/columnize-0.9.0/Makefile
/usr/lib64/ruby/gems/2.6.0/gems/columnize-0.9.0/NEWS
/usr/lib64/ruby/gems/2.6.0/gems/columnize-0.9.0/README.md
/usr/lib64/ruby/gems/2.6.0/gems/columnize-0.9.0/Rakefile
/usr/lib64/ruby/gems/2.6.0/gems/columnize-0.9.0/THANKS
/usr/lib64/ruby/gems/2.6.0/gems/columnize-0.9.0/columnize.gemspec
/usr/lib64/ruby/gems/2.6.0/gems/columnize-0.9.0/lib/Makefile
/usr/lib64/ruby/gems/2.6.0/gems/columnize-0.9.0/lib/columnize.rb
/usr/lib64/ruby/gems/2.6.0/gems/columnize-0.9.0/lib/columnize/Makefile
/usr/lib64/ruby/gems/2.6.0/gems/columnize-0.9.0/lib/columnize/columnize.rb
/usr/lib64/ruby/gems/2.6.0/gems/columnize-0.9.0/lib/columnize/opts.rb
/usr/lib64/ruby/gems/2.6.0/gems/columnize-0.9.0/lib/columnize/version.rb
/usr/lib64/ruby/gems/2.6.0/specifications/columnize-0.9.0.gemspec
/usr/share/doc/packages/ruby2.6-rubygem-columnize/COPYING
/usr/share/doc/packages/ruby2.6-rubygem-columnize/ChangeLog
/usr/share/doc/packages/ruby2.6-rubygem-columnize/README.md

Changelog

2015-02-10 - coolo@suse.com
- updated to version 0.9.0, no changelog
2014-10-12 - adrian@suse.de
- adapt to new rubygem packaging style
2014-05-18 - coolo@suse.com
- updated to version 0.8.9
- Add columnize method to Array class and a place to set its default options
- Add option :colfmt to allow a format specifier to use (e.g. '%02d') in stringifying
list items
- Add option linesuffix (default is "\n")
- When using arrange_array each line now has trailing ","
2012-03-09 - cfarrell@suse.com
- license update: Ruby
This is essentially the Ruby license
2012-03-08 - saschpe@suse.de
- Update to version 0.3.6:
* Bugfix release, see CHANGELOG for details
2010-06-11 - mrueckert@suse.de
- use rubygems_requires macro
2009-10-05 - mrueckert@suse.de
- initial package

See Also

Package Description
ruby2.6-rubygem-columnize-doc-0.9.0-1.14.i586.rpm RDoc documentation for columnize
ruby2.6-rubygem-columnize-doc-0.9.0-1.14.x86_64.rpm RDoc documentation for columnize
ruby2.6-rubygem-columnize-testsuite-0.9.0-1.14.i586.rpm Test suite for columnize
ruby2.6-rubygem-columnize-testsuite-0.9.0-1.14.x86_64.rpm Test suite for columnize
ruby2.6-rubygem-commander-4.4.7-1.3.i586.rpm The complete solution for Ruby command-line executables
ruby2.6-rubygem-commander-4.4.7-1.3.x86_64.rpm The complete solution for Ruby command-line executables
ruby2.6-rubygem-commander-doc-4.4.7-1.3.i586.rpm RDoc documentation for commander
ruby2.6-rubygem-commander-doc-4.4.7-1.3.x86_64.rpm RDoc documentation for commander
ruby2.6-rubygem-commander-testsuite-4.4.7-1.3.i586.rpm Test suite for commander
ruby2.6-rubygem-commander-testsuite-4.4.7-1.3.x86_64.rpm Test suite for commander
ruby2.6-rubygem-concurrent-ruby-1.1.5-1.1.i586.rpm Modern concurrency tools for Ruby. Inspired by Erlang, Clojure,
ruby2.6-rubygem-concurrent-ruby-1.1.5-1.1.x86_64.rpm Modern concurrency tools for Ruby. Inspired by Erlang, Clojure,
ruby2.6-rubygem-concurrent-ruby-doc-1.1.5-1.1.i586.rpm RDoc documentation for concurrent-ruby
ruby2.6-rubygem-concurrent-ruby-doc-1.1.5-1.1.x86_64.rpm RDoc documentation for concurrent-ruby
ruby2.6-rubygem-cool.io-1.5.3-1.5.i586.rpm A cool framework for doing high performance I/O in Ruby
Advertisement
Advertisement