ruby2.6-rubygem-amqp-testsuite-1.8.0-1.3.x86_64.rpm


Advertisement

Description

ruby2.6-rubygem-amqp-testsuite - Test suite for amqp

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ruby2.6-rubygem-amqp-testsuite-1.8.0-1.3.x86_64.rpm
Package name ruby2.6-rubygem-amqp-testsuite
Package version 1.8.0
Package release 1.3
Package architecture x86_64
Package type rpm
Category Development/Languages/Ruby
Homepage http://rubyamqp.info
License BSD-2-Clause or Ruby
Maintainer -
Download size 35.71 KB
Installed size 119.76 KB
Test::Unit or RSpec files, useful for developers.

Alternatives

Package Version Architecture Repository
ruby2.6-rubygem-amqp-testsuite-1.8.0-1.3.i586.rpm 1.8.0 i586 openSUSE Oss
ruby2.6-rubygem-amqp-testsuite - - -

Requires

Name Value
ruby2.6-rubygem-amqp = 1.8.0

Provides

Name Value
ruby2.6-rubygem-amqp-testsuite = 1.8.0-1.3
ruby2.6-rubygem-amqp-testsuite(x86-64) = 1.8.0-1.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ruby2.6-rubygem-amqp-testsuite-1.8.0-1.3.x86_64.rpm
Source Package rubygem-amqp-1.8.0-1.3.src.rpm

Install Howto

Install ruby2.6-rubygem-amqp-testsuite rpm package:

# zypper install ruby2.6-rubygem-amqp-testsuite

Files

Path
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/spec_helper.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/authentication_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/automatic_binding_for_default_direct_exchange_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/automatic_recovery_predicate_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/basic_get_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/basic_publish_with_message_framing_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/basic_return_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/channel_close_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/channel_level_exception_handling_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/channel_level_exception_with_multiple_channels_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/concurrent_publishing_on_a_shared_channel_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/connection_close_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/connection_level_exception_handling_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/declare_and_immediately_bind_a_server_named_queue_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/declare_one_hundred_server_named_queues_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/direct_exchange_routing_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/exchange_declaration_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/exchange_to_exchange_binding_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/fanout_exchange_routing_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/headers_exchange_routing_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/hello_world_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/mandatory_messages_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/message_acknowledgement_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/message_metadata_access_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/multiple_consumers_per_queue_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/ordering_of_published_messages_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/queue_declaration_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/queue_exclusivity_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/queue_redeclaration_with_incompatible_attributes_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/queue_status_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/redelivery_of_unacknowledged_messages_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/remove_individual_binding_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/reply_queue_communication_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/store_and_forward_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/topic_subscription_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/tx_commit_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/tx_rollback_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/extensions/
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/extensions/rabbitmq/publisher_confirmations_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/recovery/per_channel_automatic_recovery_on_graceful_broker_shutdown_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/recovery/per_channel_automatic_recovery_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/regressions/concurrent_publishing_on_the_same_channel_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/regressions/empty_message_body_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/regressions/issue66_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/integration/stress/publishing_of_messages_with_incrementing_sizes_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/unit/
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/unit/amqp/channel_id_allocation_spec.rb
/usr/lib64/ruby/gems/2.6.0/gems/amqp-1.8.0/spec/unit/amqp/connection_spec.rb

Changelog

2018-01-09 - coolo@suse.com
- updated to version 1.8.0
see installed ChangeLog.md
2017-02-03 - coolo@suse.com
- updated to version 1.7.0
see installed ChangeLog.md
2016-04-06 - coolo@suse.com
- updated to version 1.6.0
see installed ChangeLog.md
[#]# Changes Between 1.5.x and 1.6.0 (Apr 4th, 2016)
[#]## amq-protocol Update
Minimum `amq-protocol` version is now `2.0.1`.
[#]## Provide More Details in TCP Connection Failure Exception
Contributed by Neil Hooey.
GH issue: [#222](https://github.com/ruby-amqp/amqp/issues/222).
[#]## Ensures frameset is cleared after an unhandled exception
Ensures frameset is cleared after an unhandled exception.
This avoids confusing exceptions such as
```
undefined method `method_class' for #<AMQ::Protocol::BodyFrame:0x0000001e8a60b0>
```
Contributed by Michael Lutsiuk.
GH issue: [#218](https://github.com/ruby-amqp/amqp/issues/218)
2015-08-26 - coolo@suse.com
- updated to version 1.5.1
see installed ChangeLog.md
2014-10-13 - coolo@suse.com
- updated to version 1.5.0
[#]## Only Await basic.consume-ok If nowait is false
2014-10-13 - coolo@suse.com
- adapt to new rubygem packaging
2014-07-13 - coolo@suse.com
- updated to version 1.4.1
[#]## Server-Named Queue Recovery Fix
Server-named queues are now correctly recovered again.
Contributed by Jack C Hong.
[#]# Changes Between 1.3.x and 1.4.0
[#]## connection.blocked Support
[connection.blocked](https://www.rabbitmq.com/connection-blocked.html) notifications
are now correctly supported by the library.
2014-02-22 - coolo@suse.com
- updated to version 1.3.0
[#]## Exchange-to-Exchange Bindings Support
amqp gem now supports [Exchange-to-Exchange Bindings](http://www.rabbitmq.com/e2e.html), a RabbitMQ
extension.
`AMQP::Exchange#bind` and `AMQP::Exchange#unbind` work very much like `AMQP::Queue#bind` and
`AMQP::Queue#unbind`, with the argument exchange being the source one.
[#]## Internal Exchange Declaration
amqp gem now supports declaration of internal exchanges
(used via exchange-to-exchange bindings, cannot be published to
by clients).
To declare an exchange as internal, add `:internal => true` to
declaration options.
[#]## Initial Connection Failures Retries
Set connection status to closed on connection failure, which
means connection retries succeed.
2014-01-20 - coolo@suse.com
- updated to version 1.2.0
amqp gem now supports [Authentication Failure
Notification](http://www.rabbitmq.com/auth-notification.html). Public
API for authentication failure handling hasn't changed.
This extension is available in RabbitMQ 3.2+.
[#]# basic.qos Recovery Fix
`basic.qos` setting will now be recovered first thing after
channel recovery, to the most recent value passed via `:prefetch` channel
constructor option or `AMQP::Channel#prefetch`.
2013-12-12 - coolo@suse.com
- updated to version 1.1.7
[#]## Automatic Recovery Fix
Automatic connection recovery now correctly recovers bindings again.
Contributed by Devin Christensen.
[#]# Changes Between 1.1.5 and 1.1.6
[#]## 65535 Channels Per Connection
amqp gem now allows for 65535 channels per connection and
not Ruby process.
Contributed by Neo (http://neo.com) developers.
[#]# Changes Between 1.1.4 and 1.1.5
[#]## channel.close is Delayed Until After Channel is Open
This eliminates a race condition in some codebases that use
very short lived channels.
[#]# Changes Between 1.1.3 and 1.1.4
[#]## ConnectionClosedError is Back
`ConnectionClosedError` is now defined again.

See Also

Package Description
ruby2.6-rubygem-archive-tar-minitar-0.5.2-9.12.i586.rpm Provides POSIX tarchive management from Ruby programs
ruby2.6-rubygem-archive-tar-minitar-0.5.2-9.12.x86_64.rpm Provides POSIX tarchive management from Ruby programs
ruby2.6-rubygem-archive-tar-minitar-doc-0.5.2-9.12.i586.rpm RDoc documentation for archive-tar-minitar
ruby2.6-rubygem-archive-tar-minitar-doc-0.5.2-9.12.x86_64.rpm RDoc documentation for archive-tar-minitar
ruby2.6-rubygem-arel-3_0-3.0.3-1.14.i586.rpm Arel is a SQL AST manager for Ruby
ruby2.6-rubygem-arel-3_0-3.0.3-1.14.x86_64.rpm Arel is a SQL AST manager for Ruby
ruby2.6-rubygem-arel-6-6.0.4-1.10.i586.rpm Arel Really Exasperates Logicians
ruby2.6-rubygem-arel-6-6.0.4-1.10.x86_64.rpm Arel Really Exasperates Logicians
ruby2.6-rubygem-arel-7-7.1.4-1.10.i586.rpm Arel Really Exasperates Logicians
ruby2.6-rubygem-arel-7-7.1.4-1.10.x86_64.rpm Arel Really Exasperates Logicians
ruby2.6-rubygem-arel-8-8.0.0-1.3.i586.rpm Arel Really Exasperates Logicians
ruby2.6-rubygem-arel-8-8.0.0-1.3.x86_64.rpm Arel Really Exasperates Logicians
ruby2.6-rubygem-arel-9.0.0-2.4.i586.rpm Arel Really Exasperates Logicians
ruby2.6-rubygem-arel-9.0.0-2.4.x86_64.rpm Arel Really Exasperates Logicians
ruby2.6-rubygem-arel-doc-3_0-3.0.3-1.14.i586.rpm RDoc documentation for arel
Advertisement
Advertisement