ruby-devel-2.6-1.1.x86_64.rpm


Advertisement

Description

ruby-devel - Development files to link against Ruby

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ruby-devel-2.6-1.1.x86_64.rpm
Package name ruby-devel
Package version 2.6
Package release 1.1
Package architecture x86_64
Package type rpm
Category Development/Languages/Ruby
Homepage http://www.ruby-lang.org/
License MIT
Maintainer -
Download size 8.30 KB
Installed size 84 B
Development files to link against Ruby.

Alternatives

Package Version Architecture Repository
ruby-devel-2.6-1.1.i586.rpm 2.6 i586 openSUSE Oss
ruby-devel - - -

Requires

Name Value
ruby -
ruby2.6-devel >= 2.6.1

Provides

Name Value
ruby-devel = 2.6-1.1
ruby-devel(x86-64) = 2.6-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ruby-devel-2.6-1.1.x86_64.rpm
Source Package ruby-2.6-1.1.src.rpm

Install Howto

Install ruby-devel rpm package:

# zypper install ruby-devel

Files

Path
/usr/share/doc/packages/ruby-devel/README

Changelog

2019-01-29 - Stephan Kulow <coolo@suse.com>
- switch the default ruby to 2.6
2017-11-14 - behlert@suse.de
- switch the default ruby to 2.5
2017-07-11 - coolo@suse.com
- switch the default ruby to 2.4
2015-02-18 - coolo@suse.com
- bump version
2014-09-10 - mrueckert@suse.de
- to make it easier to migrate from the old scheme to the new
scheme BuildIgnore: ruby aswell
2014-09-09 - mrueckert@suse.de
- cleaned up buildrequires/requires and added buildignore for rubygem-gem2rpm
2014-06-23 - mrueckert@suse.de
- remove obsolete expand line
2014-06-20 - mrueckert@suse.de
- remove the provides to avoid have choice
2014-06-14 - mrueckert@suse.de
- migrated to just plain wrapper packages
- patches moved to ruby2.1 package:
rubygems-1.5.0_buildroot.patch
ruby-1.9.2p290_tcl_no_stupid_rpaths.patch
drop_content_size_check_in_xmlrpc.patch
ruby19-export_init_prelude.patch
2014-05-16 - kkaempf@suse.com
- Update to 2.1.2
- fix for a regression of Hash#reject in Ruby 2.1.1
- support for build with Readline-6.3 (see Bug #9578)
- updated bundled version of libyaml with psych
- some bug fixes.

See Also

Package Description
ruby-geos-3.7.1-1.1.i586.rpm Ruby bindings for Geometry Engine
ruby-geos-3.7.1-1.1.x86_64.rpm Ruby bindings for Geometry Engine
ruby-libprelude-5.0.0-1.1.i586.rpm Ruby bindings for libprelude
ruby-libprelude-5.0.0-1.1.x86_64.rpm Ruby bindings for libprelude
ruby-marisa-0.2.4-7.5.i586.rpm Ruby bindings for marisa
ruby-marisa-0.2.4-7.5.x86_64.rpm Ruby bindings for marisa
ruby-obexftp-0.24-4.27.i586.rpm ObexFTP Implements the Object Exchange (OBEX) - Ruby bindings
ruby-obexftp-0.24-4.27.x86_64.rpm ObexFTP Implements the Object Exchange (OBEX) - Ruby bindings
ruby-rrdtool-1.7.1-1.1.i586.rpm Ruby bindings for RRDtool
ruby-rrdtool-1.7.1-1.1.x86_64.rpm Ruby bindings for RRDtool
ruby-selinux-2.9-2.1.i586.rpm Ruby bindings for the SELinux runtime library
ruby-selinux-2.9-2.1.x86_64.rpm Ruby bindings for the SELinux runtime library
ruby-solv-0.7.4-1.1.i586.rpm Ruby bindings for the libsolv library
ruby-solv-0.7.4-1.1.x86_64.rpm Ruby bindings for the libsolv library
ruby-xapian-1.4.9-1.3.i586.rpm Files needed for developing Ruby scripts which use Xapian
Advertisement
Advertisement