qwt6-qt5-designer-6.1.3-2.5.x86_64.rpm


Advertisement

Description

qwt6-qt5-designer - Plugin for the Qt5 Interface designer

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename qwt6-qt5-designer-6.1.3-2.5.x86_64.rpm
Package name qwt6-qt5-designer
Package version 6.1.3
Package release 2.5
Package architecture x86_64
Package type rpm
Category Development/Tools/GUI Builders
Homepage https://qwt.sourceforge.net/
License SUSE-QWT-1.0
Maintainer -
Download size 43.52 KB
Installed size 167.30 KB
The qwt6-qt5-designer package contains the plugin for the Qt5 User Interface
designer tool.

Alternatives

Package Version Architecture Repository
qwt6-qt5-designer-6.1.3-2.5.i586.rpm 6.1.3 i586 openSUSE Oss
qwt6-qt5-designer - - -

Requires

Name Value
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.12)(64bit) -
libQt5Designer.so.5()(64bit) -
libQt5Designer.so.5(Qt_5)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5Widgets.so.5()(64bit) -
libQt5Widgets.so.5(Qt_5)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libqwt-qt5.so.6()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
qwt6-qt5-devel = 6.1.3

Provides

Name Value
libqwt_designer_plugin.so()(64bit) -
qwt-qt5-designer = 6.1.3
qwt6-qt5-designer = 6.1.3-2.5
qwt6-qt5-designer(x86-64) = 6.1.3-2.5

Conflicts

Name Value
otherproviders(qwt-qt5-designer) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package qwt6-qt5-designer-6.1.3-2.5.x86_64.rpm
Source Package qwt6-qt5-6.1.3-2.5.src.rpm

Install Howto

Install qwt6-qt5-designer rpm package:

# zypper install qwt6-qt5-designer

Files

Path
/usr/lib64/qt5/plugins/designer/libqwt_designer_plugin.so

Changelog

2017-08-05 - aloisio@gmx.com
- Fixed manpages conflict with qwt5
2017-07-26 - aloisio@gmx.com
- Remove _tmp manpages and rename the existing one to -qt5
pattern to avoid conflict with the qt4 package
- Dropped pre_checkin.sh
2017-07-25 - aloisio@gmx.com
- Remove _multibuild prior to Factory submission
2017-05-30 - aloisio@gmx.com
- Build qwt6-qt5 as separate package
* add qwt6-qt5.spec
* add qwt6-qt5.changes
* add qwt-qt5.patch
(thanks to awissu and other contributors of the KDE:Qt5 package)
- Refreshed qwt-rpath.patch as qwt-6.1.3-rpath.patch
- Create and install pc files for pkg-config:
* add qwt-6.1.3-pkgconfig.patch
- Use mkspecs directory
* add qwt-6.1.3-mkspecs.patch
- Use sover macro
- Build the examples modules
- Renamed the libqwt6 package as libqwt-qt%%sover
- Use license macro on openSUSE >= 42.2
- Add man page
- Added pre_checkin.sh to keep .changes files in sync
- Spec cleanup
2016-09-29 - aloisio@gmx.com
- Update to version 6.1.3
* QwtPlotMagnifier, QwtPlotZoomer: handling of non linear
transformations ( f.e logarithmic )
* Date/Time scales fixed
QwtDate::ceil(), QwtDate::weekNumber(), QwtDate::utcOffset()
QwtDateScaleEngine fixed when aligning to months
* QwtPlotLayout: layout bug for legends witdh visisble
scrollbars fixed
* Plot items
hiding QwtPlotLegendItem without entries
QwtPlotShapeItem render code fixed
* QwtPlotGLCanvas
slightly improved, nevertheless better use Qwt 6.2 when being
interested in OpenGL
* Other
QwtGraphic boundingRect updates fixed
QwtSyntheticPointData::x() fixed
QwtLogScaleEngine::divideScale ignoring stepSize parameter
for ranges below one "decade"
QwtPlotAbstractBarChart::getCanvasMarginHint fixed
- Fixed source URL
2015-02-04 - dap.darkness@gmail.com
- Update to Qwt 6.1.2
* fixes at QwtPlot, color maps, controls and scales.
- Removed Mandriva support.
- Renamed qwt-6.1.0-rpath.patch to qwt-rpath.patch
because upstream doesn't want merge it. Updated.
2013-08-12 - tittiatcoke@gmail.com
- qwt6-designer is now conflicting with qwt-designer.
2013-08-09 - dap.darkness@gmail.com
- Update to Qwt 6.1.0
* New plot items
* Scales beyond linear and logarithmic transformations
* Datetime scales
* Redesign of the dial and meter widgets
* Basic support for an OpenGL plot canvas
* A new system for plot legends
* Off-screen paint device for vector graphics
* Changes and improvements to several classes
- Added qwt-6.1.0-rpath.patch to prevent
https://sourceforge.net/p/qwt/bugs/191
- Qmake debug info stripping was disabled.
2013-01-28 - koprok@nand.bg
- Update to Qwt 6.0.2
* qwtfunctions.pri added
* QwtPlotDict::detachItems fixed
* QwtWeedingCurveFitter::fitCurve performance improvements
* QwtDynGridLayout fixed for non widget items
* QwtInterval: avoid annoying compiler warning
* Autoscaling of curves without points fixed
* QwtPlotDirectPainter::drawSeries bad translation removed
* QwtPlotIntervalCurve: drawing of symbols fixed
* QwtPlotlayout: minor layout bufs fixed
* Usage of QwtPlotRasterItem::pixelHint fixed
* QwtPlotRenderer: several minor fixes
* QwtRasterData: CONREC algorithm fixed
* QwtThermo: layout code fixed
* QwtThermo: memory leak fixed
* QwtMmlDocument: compiler issues
* Logarithmic autoscaler fixed for intervals close below a decade
2012-11-20 - nico.kruber@gmail.com
- Fix the SLES build (%make_install is not expanded on SLES)

See Also

Package Description
qwt6-qt5-devel-6.1.3-2.5.i586.rpm Include headers and Qt Designer plugin for Qwt(Qt5)
qwt6-qt5-devel-6.1.3-2.5.x86_64.rpm Include headers and Qt Designer plugin for Qwt(Qt5)
qwt6-qt5-devel-doc-6.1.3-2.5.i586.rpm Development documentation for Qwt(Qt5)
qwt6-qt5-devel-doc-6.1.3-2.5.x86_64.rpm Development documentation for Qwt(Qt5)
qwt6-qt5-examples-6.1.3-2.5.i586.rpm Example programs using Qwt(Qt5)
qwt6-qt5-examples-6.1.3-2.5.x86_64.rpm Example programs using Qwt(Qt5)
qwtplot3d-devel-0.2.7+git20190410.a6d0890d-1.1.i586.rpm Development tools for programs which uses QwtPlot3D Widget set
qwtplot3d-devel-0.2.7+git20190410.a6d0890d-1.1.x86_64.rpm Development tools for programs which uses QwtPlot3D Widget set
qxmledit-0.9.13-1.1.i586.rpm XML Editor and XSD Viewer
qxmledit-0.9.13-1.1.x86_64.rpm XML Editor and XSD Viewer
qxmledit-devel-0.9.13-1.1.i586.rpm XML Editor Development Files
qxmledit-devel-0.9.13-1.1.x86_64.rpm XML Editor Development Files
qxtglobalshortcut-devel-0.0.1+git1533120914.688715b-1.4.i586.rpm Development files for qxtglobalshortcut
qxtglobalshortcut-devel-0.0.1+git1533120914.688715b-1.4.x86_64.rpm Development files for qxtglobalshortcut
rabbitmq-java-client-3.5.0-2.4.noarch.rpm Java AMQP client library
Advertisement
Advertisement