qoauth-qt5-devel-2.0.0-3.2.x86_64.rpm


Advertisement

Description

qoauth-qt5-devel - Development files for QOAuth

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename qoauth-qt5-devel-2.0.0-3.2.x86_64.rpm
Package name qoauth-qt5-devel
Package version 2.0.0
Package release 3.2
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage https://github.com/ayoy/qoauth
License LGPL-2.1-or-later
Maintainer -
Download size 14.07 KB
Installed size 16.43 KB
QOAuth supports interaction with OAuth-powered network services,
in the style of Qt libraries.
This package contains files for developing applications using QOAuth.

Alternatives

Package Version Architecture Repository
qoauth-qt5-devel-2.0.0-13.10.x86_64.rpm 2.0.0 x86_64 KDE 5
qoauth-qt5-devel-2.0.0-13.10.i586.rpm 2.0.0 i586 KDE 5
qoauth-qt5-devel-2.0.0-3.2.i586.rpm 2.0.0 i586 openSUSE Oss
qoauth-qt5-devel-2.0.0-ku.5.5.x86_64.rpm 2.0.0 x86_64 KDE Unstable
qoauth-qt5-devel-2.0.0-ku.5.5.i586.rpm 2.0.0 i586 KDE Unstable
qoauth-qt5-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libqoauth2 = 2.0.0
pkgconfig(Qt5Core) -
pkgconfig(Qt5Network) -
pkgconfig(qca2-qt5) -

Provides

Name Value
pkgconfig(qoauth) = 2.0.0
qoauth-qt5-devel = 2.0.0-3.2
qoauth-qt5-devel(x86-64) = 2.0.0-3.2

Conflicts

Name Value
qoauth-devel -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package qoauth-qt5-devel-2.0.0-3.2.x86_64.rpm
Source Package qoauth-qt5-2.0.0-3.2.src.rpm

Install Howto

Install qoauth-qt5-devel rpm package:

# zypper install qoauth-qt5-devel

Files

Path
/usr/include/QtOAuth/QtOAuth
/usr/include/QtOAuth/interface.h
/usr/include/QtOAuth/qoauth_global.h
/usr/include/QtOAuth/qoauth_namespace.h
/usr/lib64/libqoauth.prl
/usr/lib64/libqoauth.so
/usr/lib64/pkgconfig/qoauth.pc
/usr/lib64/qt5/
/usr/lib64/qt5/mkspecs/
/usr/lib64/qt5/mkspecs/features/oauth.prf

Changelog

2018-08-15 - schwab@suse.de
- qoauth-ppc64-libdir.patch: Also add riscv64 as lib64 platform
- Use %licence for LICENSE
2017-03-14 - sor.alexei@meowr.ru
- Add qoauth-qt5-fix-includedir.patch: fix the include directory.
- A minor spec cleanup.
2017-01-30 - jengelh@inai.de
- Trim filler words from descriptions
2017-01-19 - wbauer@tmo.at
- Change license to LGPL-2.1+
- Install LICENSE file
2016-12-28 - jengelh@inai.de
- Ensure all directories are owned. Re-set RPM groups,
drop extra author mentions.
2016-12-27 - wbauer@tmo.at
- Update to version 2.0.0:
* Qt5 support
- Rename qoauth-rpmoptflags.patch to qoauth-qt5-rpmoptflags.patch
- Rename qoauth-ppc64-libdir.patch to qoauth-qt5-ppc64-libdir.patch
- Add pcfile.patch to adjust the pkgconfig file to Qt5
2015-05-28 - ro@suse.de
- expand qoauth-ppc64-libdir.patch for s390x
2013-12-15 - uweigand@de.ibm.com
- qoauth-ppc64-libdir.patch: Add ppc64le as lib64 platform
2013-03-18 - schwab@suse.de
- Add aarch64 to the list of lib64 platforms
2012-07-06 - dvaleev@suse.com
- fix ppc64 libdir

See Also

Package Description
qore-0.8.13-2.4.i586.rpm Multithreaded Programming Language
qore-0.8.13-2.4.x86_64.rpm Multithreaded Programming Language
qore-devel-0.8.13-2.4.i586.rpm The header files needed to compile programs using the qore library
qore-devel-0.8.13-2.4.x86_64.rpm The header files needed to compile programs using the qore library
qore-devel-doc-0.8.13-2.4.i586.rpm C++ API documentation for the qore library
qore-devel-doc-0.8.13-2.4.x86_64.rpm C++ API documentation for the qore library
qore-doc-0.8.13-2.4.i586.rpm API documentation, programming language reference, and Qore example programs
qore-doc-0.8.13-2.4.x86_64.rpm API documentation, programming language reference, and Qore example programs
qore-json-module-1.4-5.12.i586.rpm JSON module for Qore
qore-json-module-1.4-5.12.x86_64.rpm JSON module for Qore
qore-json-module-doc-1.4-5.12.i586.rpm JSON module for Qore
qore-json-module-doc-1.4-5.12.x86_64.rpm JSON module for Qore
qore-misc-tools-0.8.13-2.4.i586.rpm Miscellaneous user tools writen in Qore Programming Language
qore-misc-tools-0.8.13-2.4.x86_64.rpm Miscellaneous user tools writen in Qore Programming Language
qore-mysql-module-2.0.2.1-1.2.i586.rpm MySQL DBI module for Qore
Advertisement
Advertisement