qml-box2d-0+git.1451747535.1b37be7-2.6.x86_64.rpm


Advertisement

Description

qml-box2d - QML Box2D plugin

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename qml-box2d-0+git.1451747535.1b37be7-2.6.x86_64.rpm
Package name qml-box2d
Package version 0+git.1451747535.1b37be7
Package release 2.6
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage https://github.com/qml-box2d/qml-box2d
License Zlib
Maintainer -
Download size 66.89 KB
Installed size 273.52 KB
This plugin is meant to be installed to your Qt/imports directory, or shipped
in a directory of which the parent is added as import path.
The goal is to expose the functionality of Box2D as QML components, in order
to make it easy to write physics-based games in QML.

Alternatives

Package Version Architecture Repository
qml-box2d-0+git.1451747535.1b37be7-9.35.x86_64.rpm 0+git.1451747535.1b37be7 x86_64 Education
qml-box2d-0+git.1451747535.1b37be7-9.35.i586.rpm 0+git.1451747535.1b37be7 i586 Education
qml-box2d-0+git.1451747535.1b37be7-8.35.x86_64.rpm 0+git.1451747535.1b37be7 x86_64 Games
qml-box2d-0+git.1451747535.1b37be7-8.35.i586.rpm 0+git.1451747535.1b37be7 i586 Games
qml-box2d-0+git.1451747535.1b37be7-2.6.i586.rpm 0+git.1451747535.1b37be7 i586 openSUSE Oss
qml-box2d - - -

Requires

Name Value
libBox2D.so.2.3.1()(64bit) -
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.12)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5Qml.so.5()(64bit) -
libQt5Qml.so.5(Qt_5)(64bit) -
libQt5Quick.so.5()(64bit) -
libQt5Quick.so.5(Qt_5)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -

Provides

Name Value
libBox2D.so()(64bit) -
qml-box2d = 0+git.1451747535.1b37be7-2.6
qml-box2d(x86-64) = 0+git.1451747535.1b37be7-2.6

Download

Type URL
Mirror widehat.opensuse.org
Binary Package qml-box2d-0+git.1451747535.1b37be7-2.6.x86_64.rpm
Source Package qml-box2d-0+git.1451747535.1b37be7-2.6.src.rpm

Install Howto

Install qml-box2d rpm package:

# zypper install qml-box2d

Files

Path
/usr/lib64/qt5/
/usr/lib64/qt5/qml/
/usr/lib64/qt5/qml/Box2D.2.0/libBox2D.so
/usr/lib64/qt5/qml/Box2D.2.0/qmldir
/usr/share/doc/packages/qml-box2d/COPYING
/usr/share/doc/packages/qml-box2d/README

Changelog

2016-08-21 - jengelh@inai.de
- Ensure all created directories are owned.
Set RPM group classification.
2016-08-21 - bruno@ioda-net.ch
- Simplify BuildRequires list with the use of pkgconfig(Qt5Quick)
This fix the unresolvable qtquick 1 failure on TW
2016-07-03 - bruno@ioda-net.ch
- Update to version 0+git.1451747535.1b37be7:
* Corrected some filenames in header comments
- Don't use github url for src, we use service for that.
2015-12-27 - bruno@ioda-net.ch
- First packaging for openSUSE
- Make qml-box2d find system Box2D

See Also

Package Description
qmltermwidget-0.2.0-1.1.i586.rpm QML port of qtermwidget
qmltermwidget-0.2.0-1.1.x86_64.rpm QML port of qtermwidget
qmmp-1.3.2-1.1.i586.rpm Qt-based Multimedia Player
qmmp-1.3.2-1.1.x86_64.rpm Qt-based Multimedia Player
qmmp-plugin-pack-1.3.0-1.2.i586.rpm Extra plugins for Qmmp
qmmp-plugin-pack-1.3.0-1.2.x86_64.rpm Extra plugins for Qmmp
qmmp-plugin-pack-ffap-1.3.0-1.2.i586.rpm Enhanced Monkey's Audio (APE) decoder for Qmmp
qmmp-plugin-pack-ffap-1.3.0-1.2.x86_64.rpm Enhanced Monkey's Audio (APE) decoder for Qmmp
qmmp-plugin-pack-ffvideo-1.3.0-1.2.i586.rpm Video Playback Qmmp plugin
qmmp-plugin-pack-ffvideo-1.3.0-1.2.x86_64.rpm Video Playback Qmmp plugin
qmmp-plugin-pack-goom-1.3.0-1.2.i586.rpm Goom visualisation Qmmp plugin
qmmp-plugin-pack-goom-1.3.0-1.2.x86_64.rpm Goom visualisation Qmmp plugin
qmmp-plugin-pack-samplerate-1.3.0-1.2.i586.rpm Qmmp plugin which uses libsamplerate for decoding
qmmp-plugin-pack-samplerate-1.3.0-1.2.x86_64.rpm Qmmp plugin which uses libsamplerate for decoding
qmmp-plugin-pack-xmp-1.3.0-1.2.i586.rpm Qmmp plugin which uses the libxmp module library
Advertisement
Advertisement