python3-xattr-0.9.6-2.1.x86_64.rpm


Advertisement

Description

python3-xattr - Python wrapper for extended filesystem attributes

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python3-xattr-0.9.6-2.1.x86_64.rpm
Package name python3-xattr
Package version 0.9.6
Package release 2.1
Package architecture x86_64
Package type rpm
Category Development/Languages/Python
Homepage http://github.com/xattr/xattr
License MIT
Maintainer -
Download size 32.92 KB
Installed size 75.44 KB
Extended attributes extend the basic attributes of files and directories
in the file system.  They are stored as name:data pairs associated with
file system objects (files, directories, symlinks, etc).
Extended attributes are currently only available on Darwin 8.0+ (Mac OS X 10.4)
and Linux 2.6+. Experimental support is included for Solaris and FreeBSD.

Alternatives

Package Version Architecture Repository
python3-xattr-0.9.6-2.1.i586.rpm 0.9.6 i586 openSUSE Oss
python3-xattr - - -

Requires

Name Value
/usr/bin/python3 -
libc.so.6(GLIBC_2.4)(64bit) -
libpthread.so.0()(64bit) -
libpython3.7m.so.1.0()(64bit) -
python(abi) = 3.7
python3-cffi >= 1.11
update-alternatives -

Provides

Name Value
python3-xattr = 0.9.6-2.1
python3-xattr(x86-64) = 0.9.6-2.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python3-xattr-0.9.6-2.1.x86_64.rpm
Source Package python-xattr-0.9.6-2.1.src.rpm

Install Howto

Install python3-xattr rpm package:

# zypper install python3-xattr

Files

Path
/etc/alternatives/xattr
/usr/bin/xattr
/usr/bin/xattr-3.7
/usr/lib64/python3.7/site-packages/xattr/__init__.py
/usr/lib64/python3.7/site-packages/xattr/_lib.abi3.so
/usr/lib64/python3.7/site-packages/xattr/compat.py
/usr/lib64/python3.7/site-packages/xattr/lib.py
/usr/lib64/python3.7/site-packages/xattr/lib_build.py
/usr/lib64/python3.7/site-packages/xattr/pyxattr_compat.py
/usr/lib64/python3.7/site-packages/xattr/tool.py
/usr/lib64/python3.7/site-packages/xattr-0.9.6-py3.7.egg-info/PKG-INFO
/usr/lib64/python3.7/site-packages/xattr-0.9.6-py3.7.egg-info/SOURCES.txt
/usr/lib64/python3.7/site-packages/xattr-0.9.6-py3.7.egg-info/dependency_links.txt
/usr/lib64/python3.7/site-packages/xattr-0.9.6-py3.7.egg-info/entry_points.txt
/usr/lib64/python3.7/site-packages/xattr-0.9.6-py3.7.egg-info/not-zip-safe
/usr/lib64/python3.7/site-packages/xattr-0.9.6-py3.7.egg-info/requires.txt
/usr/lib64/python3.7/site-packages/xattr-0.9.6-py3.7.egg-info/top_level.txt
/usr/lib64/python3.7/site-packages/xattr/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib64/python3.7/site-packages/xattr/__pycache__/__init__.cpython-37.pyc
/usr/lib64/python3.7/site-packages/xattr/__pycache__/compat.cpython-37.opt-1.pyc
/usr/lib64/python3.7/site-packages/xattr/__pycache__/compat.cpython-37.pyc
/usr/lib64/python3.7/site-packages/xattr/__pycache__/lib.cpython-37.opt-1.pyc
/usr/lib64/python3.7/site-packages/xattr/__pycache__/lib.cpython-37.pyc
/usr/lib64/python3.7/site-packages/xattr/__pycache__/lib_build.cpython-37.opt-1.pyc
/usr/lib64/python3.7/site-packages/xattr/__pycache__/lib_build.cpython-37.pyc
/usr/lib64/python3.7/site-packages/xattr/__pycache__/pyxattr_compat.cpython-37.opt-1.pyc
/usr/lib64/python3.7/site-packages/xattr/__pycache__/pyxattr_compat.cpython-37.pyc
/usr/lib64/python3.7/site-packages/xattr/__pycache__/tool.cpython-37.opt-1.pyc
/usr/lib64/python3.7/site-packages/xattr/__pycache__/tool.cpython-37.pyc
/usr/share/doc/packages/python3-xattr/README.rst
/usr/share/licenses/python3-xattr/LICENSE.txt

Changelog

2019-03-22 - Dirk Mueller <dmueller@suse.com>
- fix tests run failing on older distributions due to incorrect locale
2019-03-01 - Tomá? Chvátal <tchvatal@suse.com>
- Update to 0.9.6:
* Fix release build by including *.[ch] in Manifest.in
* Extract inline C code for syntax highlighting and easier maintenance
https://github.com/xattr/xattr/pull/75
* Fix Travis build
https://github.com/xattr/xattr/pull/74
* Always include sys/types.h (musl compatibility)
https://github.com/xattr/xattr/pull/73
- Enable tests
2018-07-12 - ecsos@opensuse.org
- update to 0.9.3:
* Do not attempt to use surrogateescape unless it is available
https://github.com/xattr/xattr/issues/59
2018-02-22 - rjschwei@suse.com
- Relax version constraint for cffi requirement
2017-08-30 - tbechtold@suse.com
- update to 0.9.2:
* Fix BSD issue w/ lsattr and long attrs
https://github.com/xattr/xattr/pull/57
* Remove unreachable code
https://github.com/xattr/xattr/pull/56
* Allow (Python 2) long for fd
https://github.com/xattr/xattr/pull/51
* Fix Python 3 bytes handling in xattr.tool
https://github.com/xattr/xattr/pull/50
* Use cffi 1.X features to build native module for faster import
https://github.com/xattr/xattr/pull/47
* NOTE: Version 0.9.0 is the same, was momentarily uploaded with
incomplete CHANGES.txt
- use pypi for Source url
- convert to singlespec
- require the cffi version it was built against
2017-05-26 - ngompa13@gmail.com
- Properly add python-cffi as a runtime requirement
2016-06-01 - tbechtold@suse.com
- update to 0.8.0:
* Use os.fsencode where available to better handle filesystem quirks related
to surrogates
* Options bugfix and compatibility module for pyxattr API
* Added xattr/tests/*.py to MANIFEST.in
2015-10-18 - ecsos@opensuse.org
- update to 0.7.8
* Added MANIFEST.in to ensure that the .txt files are included
https://github.com/xattr/xattr/issues/40
- update to 0.7.7
* Fixed FreeBSD build
https://github.com/xattr/xattr/pull/32
- update to 0.7.6
* Fixed Solaris & Solaris Studio support and Python 2.6
compatibility
https://github.com/xattr/xattr/pull/29
2015-09-30 - dmueller@suse.com
- require the cffi version it was built against to avoid (bsc#948198)
2014-09-16 - tbechtold@suse.com
- update to version 0.7.5:
* Improved error message when str/unicode is passed where bytes is
required
* Improved Python 3 compatibility
* Added some unicode-specific tests

See Also

Package Description
python3-xcb-proto-devel-7.6_1.13-1.3.i586.rpm Python libraries mandatory for XML-XCB Development
python3-xcb-proto-devel-7.6_1.13-1.3.x86_64.rpm Python libraries mandatory for XML-XCB Development
python3-xcffib-0.7.0-1.2.noarch.rpm A drop in replacement for xpyb, an XCB python binding
python3-xhtml2pdf-0.2.3-1.1.noarch.rpm PDF Generator Using HTML and CSS
python3-xlrd-1.2.0-1.3.noarch.rpm Python module for extracting data from Excel spreadsheet files
python3-xlwt-1.3.0-1.3.noarch.rpm Library to Create Spreadsheet Files Compatible With MS Excel 97/2000/XP/2003
python3-xmlsec-1.3.6-1.4.i586.rpm Python bindings for the XML Security Library
python3-xmlsec-1.3.6-1.4.x86_64.rpm Python bindings for the XML Security Library
python3-xmltodict-0.12.0-2.1.noarch.rpm Module to make XML working resemble JSON
python3-xpybutil-0.0.5-2.2.noarch.rpm Abstraction over xpyb
python3-xsge_gui-1.1.0.1-1.2.noarch.rpm xSGE GUI Toolkit
python3-xsge_lighting-1.0.1-1.2.noarch.rpm xSGE Lighting Library
python3-xsge_particle-0.1-1.2.noarch.rpm xSGE Particles
python3-xsge_path-1.0.1-1.2.noarch.rpm xSGE Path
python3-xsge_physics-0.13.1-1.2.noarch.rpm xSGE Physics Framework
Advertisement
Advertisement